summaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-02-09 14:29:40 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-02-09 14:30:19 +0000
commit2ce0c1d967992abd4ed87937abb149b0755ec11f (patch)
tree3bf568d8a3baebc4b3021eb47224d84895fe3e21 /x11
parent39e56dc49ccd7b4e347e2146f752de52413cfdcf (diff)
downloadfreebsd-ports-2ce0c1d967992abd4ed87937abb149b0755ec11f.zip
x11/hyprpaper: unbreak build with GCC after f2258673f15e
/usr/local/bin/ld: CMakeFiles/hyprpaper.dir/src/Hyprpaper.cpp.o: in function `CHyprpaper::createLSForMonitor(SMonitor*)': Hyprpaper.cpp:(.text+0xb27): undefined reference to `std::__1::__vector_base_common<true>::__throw_length_error() const' /usr/local/bin/ld: CMakeFiles/hyprpaper.dir/src/Hyprpaper.cpp.o: in function `CHyprpaper::createPoolFile(unsigned long, std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> >&)': Hyprpaper.cpp:(.text+0xc01): undefined reference to `std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> >::append(char const*)' /usr/local/bin/ld: CMakeFiles/hyprpaper.dir/src/Hyprpaper.cpp.o: in function `CHyprpaper::createBuffer(SPoolBuffer*, int, int, unsigned int)': Hyprpaper.cpp:(.text+0xf25): undefined reference to `std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> >::operator=(std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> > const&)' /usr/local/bin/ld: CMakeFiles/hyprpaper.dir/src/Hyprpaper.cpp.o: in function `CHyprpaper::ensurePoolBuffersPresent()': Hyprpaper.cpp:(.text+0x1162): undefined reference to `std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> >::operator=(std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> > const&)' /usr/local/bin/ld: Hyprpaper.cpp:(.text+0x15d1): undefined reference to `std::__1::__vector_base_common<true>::__throw_length_error() const' /usr/local/bin/ld: CMakeFiles/hyprpaper.dir/src/Hyprpaper.cpp.o: in function `CHyprpaper::removeOldHyprpaperImages()': Hyprpaper.cpp:(.text+0x18cb): undefined reference to `std::__1::__fs::filesystem::directory_iterator::directory_iterator(std::__1::__fs::filesystem::path const&, std::__1::error_code*, std::__1::__fs::filesystem::directory_options)' [...]
Diffstat (limited to 'x11')
-rw-r--r--x11/hyprpaper/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/x11/hyprpaper/Makefile b/x11/hyprpaper/Makefile
index 25eb373e5c73..b615b81be6d2 100644
--- a/x11/hyprpaper/Makefile
+++ b/x11/hyprpaper/Makefile
@@ -47,6 +47,7 @@ do-install:
${STAGEDIR}${PREFIX}/bin
# XXX Drop after FreeBSD 12.3 EOL around 2023-03-01 (don't forget distinfo)
+.if ${CXX} == c++ && exists(/usr/lib/libc++.so)
.if !exists(/usr/include/c++/v1/concepts) || make(makesum) || make(fetch)
USES+= llvm:min=12,build
CC= clang${LLVM_VERSION}
@@ -66,5 +67,6 @@ bundled-libcxx:
-B ${WRKDIR}/libcxx_build -S ${WRKSRC_libcxx}/libcxx
@${DO_MAKE_BUILD:NDESTDIR*} install -C ${WRKDIR}/libcxx_build
.endif
+.endif # exists(/usr/lib/libc++.so)
.include <bsd.port.mk>