summaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2003-12-21 19:48:18 +0000
committerEric Anholt <anholt@FreeBSD.org>2003-12-21 19:48:18 +0000
commit20a753b6d2c6ddd15531feedefc1287c8d99c7a5 (patch)
treeaca2be51395cc5ed2b220764d71050e524b4ec87 /x11
parent7cbb15a29fd81b8318f3089d7030fda6a81ade31 (diff)
downloadfreebsd-ports-20a753b6d2c6ddd15531feedefc1287c8d99c7a5.zip
New port: Prerelease version of libXau from freedesktop.org:
Authentication Protocol library for X11 Testing is encouraged, but please do not use these ports as dependencies until they are updated to release tarballs and the XFree86 ports have been updated to depend on them.
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/libXau/Makefile29
-rw-r--r--x11/libXau/distinfo1
-rw-r--r--x11/libXau/files/patch-Makefile.in11
-rw-r--r--x11/libXau/files/patch-configure10
-rw-r--r--x11/libXau/pkg-descr6
-rw-r--r--x11/libXau/pkg-plist5
7 files changed, 63 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index b68a61298708..52fc56ca4ef2 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -72,6 +72,7 @@
SUBDIR += kdelibs3
SUBDIR += keylaunch
SUBDIR += kgamma
+ SUBDIR += libXau
SUBDIR += libXtrans
SUBDIR += libcapplet
SUBDIR += libdnd
diff --git a/x11/libXau/Makefile b/x11/libXau/Makefile
new file mode 100644
index 000000000000..6be7af37a993
--- /dev/null
+++ b/x11/libXau/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: libXau
+# Date Created: 29 Oct, 2003
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libXau
+PORTVERSION= 0.1.p1
+CATEGORIES= x11
+MASTER_SITES= http://pdx.freedesktop.org/~anholt/dist/
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= Authentication Protocol library for X11
+
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig \
+ ${X11BASE}/libdata/pkgconfig/xproto.pc:${PORTSDIR}/x11/xproto
+
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-0.1
+
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/x11/libXau/distinfo b/x11/libXau/distinfo
new file mode 100644
index 000000000000..83a3b24fc643
--- /dev/null
+++ b/x11/libXau/distinfo
@@ -0,0 +1 @@
+MD5 (libXau-0.1.p1.tar.bz2) = 7247a9d52f22551272a60d0e64a4f459
diff --git a/x11/libXau/files/patch-Makefile.in b/x11/libXau/files/patch-Makefile.in
new file mode 100644
index 000000000000..2bfc929d0cf4
--- /dev/null
+++ b/x11/libXau/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sun Nov 9 22:48:57 2003
++++ Makefile.in Sun Nov 9 22:49:09 2003
+@@ -167,7 +167,7 @@
+
+ xauinclude_HEADERS = Xauth.h
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = xau.pc
+
+ EXTRA_DIST = xau.pc.in Autest.c
diff --git a/x11/libXau/files/patch-configure b/x11/libXau/files/patch-configure
new file mode 100644
index 000000000000..5815ec632b3a
--- /dev/null
+++ b/x11/libXau/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Sat Nov 8 17:53:34 2003
++++ configure Sat Nov 8 17:53:46 2003
+@@ -18793,6 +18793,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/x11/libXau/pkg-descr b/x11/libXau/pkg-descr
new file mode 100644
index 000000000000..83a3d8fbfcb5
--- /dev/null
+++ b/x11/libXau/pkg-descr
@@ -0,0 +1,6 @@
+This package contains a library for the Authorization Protocol for X11.
+
+WWW: http://www.freedesktop.org/Software/xlibs
+
+- Eric Anholt
+anholt@FreeBSD.org
diff --git a/x11/libXau/pkg-plist b/x11/libXau/pkg-plist
new file mode 100644
index 000000000000..e19e3f4e2eae
--- /dev/null
+++ b/x11/libXau/pkg-plist
@@ -0,0 +1,5 @@
+include/X11/Xauth.h
+lib/libXau.a
+lib/libXau.so
+lib/libXau.so.0
+libdata/pkgconfig/xau.pc