summaryrefslogtreecommitdiff
path: root/x11-wm/windowmaker/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2000-02-16 13:05:08 +0000
committerThomas Gellekum <tg@FreeBSD.org>2000-02-16 13:05:08 +0000
commit1210188ed1df1656b0d43d10651951ef4b2dab88 (patch)
tree52cbc182d57a3e482a0901773ff91dbd4292600e /x11-wm/windowmaker/Makefile
parent48a39f1753f60fc008ad29741dfc82cc5d3a5631 (diff)
downloadfreebsd-ports-1210188ed1df1656b0d43d10651951ef4b2dab88.zip
Merge libwmfun port with WindowMaker. Fix PLIST.
PR: 16727 Submitted by: Maxim Sobolev <sobomax@altavista.net> Reviewed by: Will Andrews <andrews@technologist.com> Use libungif instead of giflib.
Diffstat (limited to 'x11-wm/windowmaker/Makefile')
-rw-r--r--x11-wm/windowmaker/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/x11-wm/windowmaker/Makefile b/x11-wm/windowmaker/Makefile
index e82bfbce8e92..b219a10a6093 100644
--- a/x11-wm/windowmaker/Makefile
+++ b/x11-wm/windowmaker/Makefile
@@ -16,7 +16,7 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DATAFILES}
MAINTAINER= handy@physics.montana.edu
LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm \
- gif.5:${PORTSDIR}/graphics/giflib \
+ ungif.5:${PORTSDIR}/graphics/libungif \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.3:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
@@ -35,7 +35,7 @@ CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
--disable-debug
MAN1= geticonset.1x getstyle.1x seticons.1x setstyle.1x \
- wdwrite.1x wmaker.1x wmsetbg.1x wxcopy.1x wxpaste.1x
+ wdwrite.1x wmaker.1x wmsetbg.1x wsetfont.1x wxcopy.1x wxpaste.1x
DATAFILES= WindowMaker-extra-0.1.tar.bz2
@@ -58,6 +58,10 @@ pre-extract:
${ECHO} "You can add hooks for Gnome and KDE by defining USE_GNOME and/or USE_KDE"
.endif
+post-extract:
+ @cd ${WRKSRC} && \
+ ${TAR} xfz libwmfun-0.0.2.tar.gz
+
post-patch:
@perl -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/WPrefs.app/Paths.c \
${WRKSRC}/WindowMaker/Defaults/*
@@ -70,5 +74,6 @@ post-install:
@cd ${WRKDIR}/WindowMaker-extra-0.1; \
${MAKE} ${MAKE_ARGS} install
${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+ ${MKDIR} ${PREFIX}/share/WindowMaker/Sounds
.include <bsd.port.mk>