summaryrefslogtreecommitdiff
path: root/x11-toolkits/libgtkeditor/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-09-25 11:27:12 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-09-25 11:27:12 +0000
commite28c640e1f140a05ae63945786430d8adf1b737b (patch)
treebc509e2b52fd5eafc2b637472373f7d12d42856b /x11-toolkits/libgtkeditor/Makefile
parentb714ec93da346cc8149f76d5c0cea1733505d344 (diff)
downloadfreebsd-ports-e28c640e1f140a05ae63945786430d8adf1b737b.zip
Add libgtkeditor - a source code editor widget for GTK+.
Diffstat (limited to 'x11-toolkits/libgtkeditor/Makefile')
-rw-r--r--x11-toolkits/libgtkeditor/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-toolkits/libgtkeditor/Makefile b/x11-toolkits/libgtkeditor/Makefile
new file mode 100644
index 000000000000..76f5eaf90f5c
--- /dev/null
+++ b/x11-toolkits/libgtkeditor/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: libgtkeditor
+# Date created: 25 September 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libgtkeditor
+PORTVERSION= 0.1.8
+CATEGORIES= x11-toolkits editors
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME:S/lib//}
+DISTNAME= ${PORTNAME:S/lib//}-${PORTVERSION}
+
+MAINTAINER= sobomax@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/share/automake/install-sh:${PORTSDIR}/devel/automake
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
+ unicode.0:${PORTSDIR}/devel/libunicode
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+CONFIGURE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+pre-configure:
+.for file in install-sh config.sub mkinstalldirs
+ @${LN} -sf ${LOCALBASE}/share/automake/${file} ${WRKSRC}/${file}
+.endfor
+
+post-configure:
+ @${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/scanner.c
+
+pre-install:
+ @${MKDIR} ${PREFIX}/include/tktext-port
+
+.include <bsd.port.mk>