summaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-05-03 20:47:08 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-05-03 20:47:08 +0000
commite8c3cba86bdd74ab744fed8ef296627d66256c04 (patch)
treec732a34ed3f46a22c1fe16512f8ccae63aade7bc /www
parentca44a51151a90deafd6fd3c41f339cd8dcf06b3f (diff)
downloadfreebsd-ports-e8c3cba86bdd74ab744fed8ef296627d66256c04.zip
Add rubygem-webrick 1.6.0
WEBrick is an HTTP server toolkit that can be configured as an HTTPS server, a proxy server, and a virtual-host server. WEBrick features complete logging of both server operations and HTTP access. WEBrick supports both basic and digest authentication in addition to algorithms not in RFC 2617. A WEBrick server can be composed of multiple WEBrick servers or servlets to provide differing behavior on a per-host or per-path basis. WEBrick includes servlets for handling CGI scripts, ERB pages, Ruby blocks and directory listings. WEBrick also includes tools for daemonizing a process and starting a process at a higher privilege level and dropping permissions. WWW: https://github.com/ruby/webrick
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-webrick/Makefile20
-rw-r--r--www/rubygem-webrick/distinfo3
-rw-r--r--www/rubygem-webrick/pkg-descr17
4 files changed, 41 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index e1c346cc8af9..267fd8bbf3c3 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -2154,6 +2154,7 @@
SUBDIR += rubygem-webdrivers
SUBDIR += rubygem-webmock
SUBDIR += rubygem-webpack-rails-rails60
+ SUBDIR += rubygem-webrick
SUBDIR += rubygem-webrobots
SUBDIR += rubygem-websocket
SUBDIR += rubygem-websocket-driver
diff --git a/www/rubygem-webrick/Makefile b/www/rubygem-webrick/Makefile
new file mode 100644
index 000000000000..2b1347f362b8
--- /dev/null
+++ b/www/rubygem-webrick/Makefile
@@ -0,0 +1,20 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= webrick
+PORTVERSION= 1.6.0
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= HTTP server toolkit
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-webrick/distinfo b/www/rubygem-webrick/distinfo
new file mode 100644
index 000000000000..fcc0ce58b229
--- /dev/null
+++ b/www/rubygem-webrick/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1588450792
+SHA256 (rubygem/webrick-1.6.0.gem) = 994a3dbae705ad3551fa752c1ced53448459a2712c6e27dd56fe36f4d706eb6f
+SIZE (rubygem/webrick-1.6.0.gem) = 59392
diff --git a/www/rubygem-webrick/pkg-descr b/www/rubygem-webrick/pkg-descr
new file mode 100644
index 000000000000..163d25c887d5
--- /dev/null
+++ b/www/rubygem-webrick/pkg-descr
@@ -0,0 +1,17 @@
+WEBrick is an HTTP server toolkit that can be configured as an HTTPS server, a
+proxy server, and a virtual-host server.
+
+WEBrick features complete logging of both server operations and HTTP access.
+
+WEBrick supports both basic and digest authentication in addition to algorithms
+not in RFC 2617.
+
+A WEBrick server can be composed of multiple WEBrick servers or servlets to
+provide differing behavior on a per-host or per-path basis. WEBrick includes
+servlets for handling CGI scripts, ERB pages, Ruby blocks and directory
+listings.
+
+WEBrick also includes tools for daemonizing a process and starting a process at
+a higher privilege level and dropping permissions.
+
+WWW: https://github.com/ruby/webrick