summaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2020-05-01 11:21:24 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2020-05-01 11:21:24 +0000
commit42468780bc5f384d76cb7dba53e47da4e0722ec1 (patch)
tree288151d31df88737867c72ec86990b20191adb7c /www
parenta35a63dcf669a9b1935c49a402e7fb8b8a608770 (diff)
downloadfreebsd-ports-42468780bc5f384d76cb7dba53e47da4e0722ec1.zip
Security update to 12.9.5.
Changelog: https://about.gitlab.com/releases/2020/04/30/security-release-12-10-2-released/ Security: e8483115-8b8e-11ea-bdcf-001b217b3468
Diffstat (limited to 'www')
-rw-r--r--www/gitlab-ce/Makefile10
-rw-r--r--www/gitlab-ce/distinfo6
-rw-r--r--www/gitlab-ce/pkg-plist3
3 files changed, 11 insertions, 8 deletions
diff --git a/www/gitlab-ce/Makefile b/www/gitlab-ce/Makefile
index 23edd1a81e4f..004097b69d77 100644
--- a/www/gitlab-ce/Makefile
+++ b/www/gitlab-ce/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= gitlab-ce
-PORTVERSION= 12.9.3
-PORTREVISION= 4
+PORTVERSION= 12.9.5
+PORTREVISION= 0
CATEGORIES= www devel
MAINTAINER= mfechner@FreeBSD.org
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
# the rubygems of RUN_DEPENDS matches the order of the Gemfile
# which makes maintaining this long list much easier!
-MY_DEPENDS= git>=2.22.2:devel/git \
+MY_DEPENDS= git>=2.24.3:devel/git \
gitlab-shell>=12.0.0:devel/gitlab-shell \
gitlab-workhorse>=8.25.2:www/gitlab-workhorse \
gitaly>=${PORTVERSION}:devel/gitaly \
@@ -113,7 +113,7 @@ MY_DEPENDS= git>=2.22.2:devel/git \
rubygem-rouge317>=3.17.0<3.18:textproc/rubygem-rouge317 \
rubygem-truncato>=0.7.11<0.8.0:textproc/rubygem-truncato \
rubygem-bootstrap_form>=4.2.0<4.3.0:devel/rubygem-bootstrap_form \
- rubygem-nokogiri>=1.10.8<1.11.0:textproc/rubygem-nokogiri \
+ rubygem-nokogiri>=1.10.9<1.11.0:textproc/rubygem-nokogiri \
rubygem-escape_utils>=1.1<2.0:textproc/rubygem-escape_utils \
rubygem-icalendar>=0:devel/rubygem-icalendar \
rubygem-diffy>=3.3<4:textproc/rubygem-diffy \
@@ -245,7 +245,7 @@ USE_GITLAB= yes
GL_ACCOUNT= gitlab-org
GL_PROJECT= gitlab-foss
# Find the here: https://gitlab.com/gitlab-org/gitlab-foss/-/tags
-GL_COMMIT= 571e31b8362a6903c97c5d42f2211151941a7cd3
+GL_COMMIT= 58afee038ec5ae1c6e1887238a0d9b3aba9cfb86
USERS= git
GROUPS= git
diff --git a/www/gitlab-ce/distinfo b/www/gitlab-ce/distinfo
index 32daf62eba8d..bf4934a68d9d 100644
--- a/www/gitlab-ce/distinfo
+++ b/www/gitlab-ce/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1586981336
-SHA256 (gitlab-org-gitlab-foss-571e31b8362a6903c97c5d42f2211151941a7cd3_GL0.tar.gz) = dc6448e3af0a77ef0c588c48e6db9f91a15f18bfb57fc336c2268dd44c22a575
-SIZE (gitlab-org-gitlab-foss-571e31b8362a6903c97c5d42f2211151941a7cd3_GL0.tar.gz) = 89130246
+TIMESTAMP = 1588326501
+SHA256 (gitlab-org-gitlab-foss-58afee038ec5ae1c6e1887238a0d9b3aba9cfb86_GL0.tar.gz) = 7cd1267906dad7e4c1030d309fccaf81dd18ae589a52793751040895050fcbee
+SIZE (gitlab-org-gitlab-foss-58afee038ec5ae1c6e1887238a0d9b3aba9cfb86_GL0.tar.gz) = 89140411
diff --git a/www/gitlab-ce/pkg-plist b/www/gitlab-ce/pkg-plist
index 79dd1f33d910..b326ecfd9be0 100644
--- a/www/gitlab-ce/pkg-plist
+++ b/www/gitlab-ce/pkg-plist
@@ -16186,6 +16186,7 @@
%%WWWDIR%%/spec/controllers/notification_settings_controller_spec.rb
%%WWWDIR%%/spec/controllers/oauth/applications_controller_spec.rb
%%WWWDIR%%/spec/controllers/oauth/authorizations_controller_spec.rb
+%%WWWDIR%%/spec/controllers/oauth/authorized_applications_controller_spec.rb
%%WWWDIR%%/spec/controllers/oauth/token_info_controller_spec.rb
%%WWWDIR%%/spec/controllers/omniauth_callbacks_controller_spec.rb
%%WWWDIR%%/spec/controllers/passwords_controller_spec.rb
@@ -17005,6 +17006,7 @@
%%WWWDIR%%/spec/features/projects/show/user_sees_last_commit_ci_status_spec.rb
%%WWWDIR%%/spec/features/projects/show/user_sees_readme_spec.rb
%%WWWDIR%%/spec/features/projects/show/user_sees_setup_shortcut_buttons_spec.rb
+%%WWWDIR%%/spec/features/projects/show/user_uploads_files_spec.rb
%%WWWDIR%%/spec/features/projects/snippets/create_snippet_spec.rb
%%WWWDIR%%/spec/features/projects/snippets/show_spec.rb
%%WWWDIR%%/spec/features/projects/snippets/user_comments_on_snippet_spec.rb
@@ -21954,6 +21956,7 @@
%%WWWDIR%%/spec/support/shared_examples/features/navbar_shared_examples.rb
%%WWWDIR%%/spec/support/shared_examples/features/project_features_apply_to_issuables_shared_examples.rb
%%WWWDIR%%/spec/support/shared_examples/features/project_list_shared_examples.rb
+%%WWWDIR%%/spec/support/shared_examples/features/project_upload_files_shared_examples.rb
%%WWWDIR%%/spec/support/shared_examples/features/protected_branches_access_control_ce_shared_examples.rb
%%WWWDIR%%/spec/support/shared_examples/features/reportable_note_shared_examples.rb
%%WWWDIR%%/spec/support/shared_examples/features/resolving_discussions_in_issues_shared_examples.rb