summaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-21 11:18:43 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-21 11:18:43 +0000
commitf67b7f37ae7d9c72139f1b1414122f21074e25ba (patch)
tree4ca838002cf9fa6ffcc8c38cc013b2bc14a49335 /www
parent7aafea7e71f21361bf026d36d10e0c17ddce93e6 (diff)
downloadfreebsd-ports-f67b7f37ae7d9c72139f1b1414122f21074e25ba.zip
Stage www/publicfile and assign maintainership to submitter
PR: 192885 Submitted by: uffe
Diffstat (limited to 'www')
-rw-r--r--www/publicfile/Makefile6
-rw-r--r--www/publicfile/files/patch-Makefile49
-rw-r--r--www/publicfile/files/patch-auto_home_stage.h9
3 files changed, 61 insertions, 3 deletions
diff --git a/www/publicfile/Makefile b/www/publicfile/Makefile
index 370371d973a3..e1ef87e0fa0c 100644
--- a/www/publicfile/Makefile
+++ b/www/publicfile/Makefile
@@ -3,11 +3,11 @@
PORTNAME= publicfile
PORTVERSION= 0.52
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www ftp
MASTER_SITES= http://cr.yp.to/publicfile/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= uffe@uffe.org
COMMENT= Secure, read-only, anonymous HTTP/FTP server
RUN_DEPENDS= setuidgid:${PORTSDIR}/sysutils/daemontools \
@@ -23,7 +23,6 @@ SSL_DESC= provide SSL support through ucspi-ssl
CONFLICTS= xshttpd-3*
LEGAL_TEXT= No license -- see http://cr.yp.to/softwarelaw.html
-NO_STAGE= yes
.include <bsd.port.options.mk>
pre-everything::
@@ -89,5 +88,6 @@ post-patch:
@${ECHO_CMD} "${CC} ${CFLAGS}" > ${WRKSRC}/conf-cc
@${ECHO_CMD} "${CC} -s" > ${WRKSRC}/conf-ld
@${ECHO_CMD} "${PREFIX}" > ${WRKSRC}/conf-home
+ @${ECHO_CMD} "${STAGEDIR}${PREFIX}" > ${WRKSRC}/conf-stage
.include <bsd.port.mk>
diff --git a/www/publicfile/files/patch-Makefile b/www/publicfile/files/patch-Makefile
new file mode 100644
index 000000000000..b866e30ee586
--- /dev/null
+++ b/www/publicfile/files/patch-Makefile
@@ -0,0 +1,49 @@
+--- Makefile.orig 1999-11-09 08:23:46.000000000 +0100
++++ Makefile 2014-08-21 12:29:41.000000000 +0200
+@@ -32,6 +32,14 @@
+ compile auto_home.c
+ ./compile auto_home.c
+
++auto_home_stage.c: \
++auto-str conf-stage
++ ./auto-str auto_home `head -1 conf-stage` > auto_home_stage.c
++
++auto_home_stage.o: \
++compile auto_home_stage.c
++ ./compile auto_home_stage.c
++
+ byte_chr.o: \
+ compile byte_chr.c byte.h
+ ./compile byte_chr.c
+@@ -231,7 +239,7 @@
+ ./choose clr tryshsgr hasshsgr.h1 hasshsgr.h2 > hasshsgr.h
+
+ hier.o: \
+-compile hier.c auto_home.h
++compile hier.c auto_home_stage.h
+ ./compile hier.c
+
+ httpd: \
+@@ -257,9 +265,9 @@
+ ./compile httpdate.c
+
+ install: \
+-load install.o hier.o auto_home.o strerr.a substdio.a open.a error.a \
++load install.o hier.o auto_home_stage.o strerr.a substdio.a open.a error.a \
+ str.a
+- ./load install hier.o auto_home.o strerr.a substdio.a \
++ ./load install hier.o auto_home_stage.o strerr.a substdio.a \
+ open.a error.a str.a
+
+ install.o: \
+@@ -268,8 +276,8 @@
+ ./compile install.c
+
+ instcheck: \
+-load instcheck.o hier.o auto_home.o strerr.a substdio.a error.a str.a
+- ./load instcheck hier.o auto_home.o strerr.a substdio.a \
++load instcheck.o hier.o auto_home_stage.o strerr.a substdio.a error.a str.a
++ ./load instcheck hier.o auto_home_stage.o strerr.a substdio.a \
+ error.a str.a
+
+ instcheck.o: \
diff --git a/www/publicfile/files/patch-auto_home_stage.h b/www/publicfile/files/patch-auto_home_stage.h
new file mode 100644
index 000000000000..9b12a18e6e49
--- /dev/null
+++ b/www/publicfile/files/patch-auto_home_stage.h
@@ -0,0 +1,9 @@
+--- /dev/null 2014-08-21 12:22:00.000000000 +0200
++++ auto_home_stage.h 2014-08-21 12:25:14.000000000 +0200
+@@ -0,0 +1,6 @@
++#ifndef AUTO_HOME_STAGE_H_
++#define AUTO_HOME_STAGE_H_
++
++extern char auto_home[];
++
++#endif