summaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2014-09-04 14:24:25 +0000
committerAlex Dupre <ale@FreeBSD.org>2014-09-04 14:24:25 +0000
commitf23aed7bde4b7e82cbb2943a38f6f60f51038567 (patch)
tree65444edf752ebaf49e944ea49c7e7dad35e1de9a /www
parentb3f383ce848e6d547e583f3f4ce764dd3c400cb6 (diff)
downloadfreebsd-ports-f23aed7bde4b7e82cbb2943a38f6f60f51038567.zip
Import PHP 5.6 branch!
Diffstat (limited to 'www')
-rw-r--r--www/Makefile4
-rw-r--r--www/mod_php56/Makefile16
-rw-r--r--www/php56-opcache/Makefile12
-rw-r--r--www/php56-session/Makefile10
-rw-r--r--www/php56-tidy/Makefile10
5 files changed, 52 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index d1ad66b010d5..0704fdb1bba0 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -480,6 +480,7 @@
SUBDIR += mod_perl2
SUBDIR += mod_php5
SUBDIR += mod_php55
+ SUBDIR += mod_php56
SUBDIR += mod_proctitle
SUBDIR += mod_proxy_html
SUBDIR += mod_proxy_uwsgi
@@ -1401,6 +1402,9 @@
SUBDIR += php55-opcache
SUBDIR += php55-session
SUBDIR += php55-tidy
+ SUBDIR += php56-opcache
+ SUBDIR += php56-session
+ SUBDIR += php56-tidy
SUBDIR += phpbb
SUBDIR += phpbb3
SUBDIR += phpgroupware
diff --git a/www/mod_php56/Makefile b/www/mod_php56/Makefile
new file mode 100644
index 000000000000..7438bd681762
--- /dev/null
+++ b/www/mod_php56/Makefile
@@ -0,0 +1,16 @@
+# Created by: marcus@FreeBSD.org
+# $FreeBSD$
+
+CATEGORIES= www devel
+PKGNAMEPREFIX= mod_
+
+MAINTAINER= ale@FreeBSD.org
+
+PHP_PORT= lang/php56
+MASTERDIR= ${.CURDIR}/../../${PHP_PORT}
+
+OPTIONS_DEFINE= AP2FILTER
+AP2FILTER_DESC= Use Apache 2.x filter interface (experimental)
+OPTIONS_EXCLUDE= CGI CLI FPM EMBED
+
+.include "${MASTERDIR}/Makefile"
diff --git a/www/php56-opcache/Makefile b/www/php56-opcache/Makefile
new file mode 100644
index 000000000000..563247fbd78c
--- /dev/null
+++ b/www/php56-opcache/Makefile
@@ -0,0 +1,12 @@
+# Created by: Martin Matuska <mm@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= www
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -opcache
+
+USE_ZENDEXT= yes
+
+.include "${MASTERDIR}/Makefile"
diff --git a/www/php56-session/Makefile b/www/php56-session/Makefile
new file mode 100644
index 000000000000..a8c4fc1105fc
--- /dev/null
+++ b/www/php56-session/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= www
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -session
+
+.include "${MASTERDIR}/Makefile"
diff --git a/www/php56-tidy/Makefile b/www/php56-tidy/Makefile
new file mode 100644
index 000000000000..872746370284
--- /dev/null
+++ b/www/php56-tidy/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= www
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -tidy
+
+.include "${MASTERDIR}/Makefile"