summaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2015-12-08 16:37:44 +0000
committerMartin Wilke <miwi@FreeBSD.org>2015-12-08 16:37:44 +0000
commitef8a1d903d815d000ad21d03958d51e3fd674d2b (patch)
tree1a93ee412460f6755dc65edc977cacc028d568b0 /www
parent2b0e322fd1a407768d5d1169b07d300244f34c92 (diff)
downloadfreebsd-ports-ef8a1d903d815d000ad21d03958d51e3fd674d2b.zip
A fairly simple user-registration application for Django,
designed to make allowing user signups as painless as possible WWW: http://django-registration-redux.readthedocs.org/ PR: 202834 Submitted by: Kevin Golding <ports@caomhin.org> Approved by: mat (mentor) Differential Revision: https://reviews.freebsd.org/D4433
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django-registration-redux/Makefile23
-rw-r--r--www/py-django-registration-redux/distinfo2
-rw-r--r--www/py-django-registration-redux/pkg-descr4
4 files changed, 30 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index cf8e24befa6e..2910f6ef3ba4 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1559,6 +1559,7 @@
SUBDIR += py-django-redis
SUBDIR += py-django-registration
SUBDIR += py-django-registration-defaults
+ SUBDIR += py-django-registration-redux
SUBDIR += py-django-reversion
SUBDIR += py-django-sekizai
SUBDIR += py-django-signals-ahoy
diff --git a/www/py-django-registration-redux/Makefile b/www/py-django-registration-redux/Makefile
new file mode 100644
index 000000000000..c7179b01f083
--- /dev/null
+++ b/www/py-django-registration-redux/Makefile
@@ -0,0 +1,23 @@
+# Created by: Kevin Golding <ports@caomhin.org>
+# $FreeBSD$
+
+PORTNAME= django-registration-redux
+PORTVERSION= 1.2
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@caomhin.org
+COMMENT= User-registration application for Django
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django>=1.4:${PORTSDIR}/www/py-django
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= distutils autoplist
+
+CONFLICTS_INSTALL= pootle-* py-django-registration
+
+.include <bsd.port.mk>
diff --git a/www/py-django-registration-redux/distinfo b/www/py-django-registration-redux/distinfo
new file mode 100644
index 000000000000..c1549b38c066
--- /dev/null
+++ b/www/py-django-registration-redux/distinfo
@@ -0,0 +1,2 @@
+SHA256 (django-registration-redux-1.2.tar.gz) = 006abd8b3606f1bc7da8ffc773a1f4a5380b3f0f6ab65c00a7d864b4f60bc9ba
+SIZE (django-registration-redux-1.2.tar.gz) = 72391
diff --git a/www/py-django-registration-redux/pkg-descr b/www/py-django-registration-redux/pkg-descr
new file mode 100644
index 000000000000..ee0300c135f5
--- /dev/null
+++ b/www/py-django-registration-redux/pkg-descr
@@ -0,0 +1,4 @@
+A fairly simple user-registration application for Django,
+designed to make allowing user signups as painless as possible
+
+WWW: http://django-registration-redux.readthedocs.org/