summaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2013-08-03 22:28:37 +0000
committerMikhail Teterin <mi@FreeBSD.org>2013-08-03 22:28:37 +0000
commitcb1aab0fd81a7da31ae48e2c7ac8fae7e5e60bdf (patch)
tree9e217959f54cd69205f5bec4dd705ee4110e4a81 /www
parent10b999c7c44d4088e2e1217d72c30a683ca3ab7f (diff)
downloadfreebsd-ports-cb1aab0fd81a7da31ae48e2c7ac8fae7e5e60bdf.zip
Add patches to build and work with Apache-2.4 (which
has special requrements for users of ap_log_error()) and Tcl-8.6 (which uses -fvisibility=hidden if it can). No functional changes for those, who were able to build before, thus no PORTREVISION bump (I wish, previous committer followed this rule too).
Diffstat (limited to 'www')
-rw-r--r--www/websh/Makefile3
-rw-r--r--www/websh/files/patch-apache2.415
-rw-r--r--www/websh/files/patch-dllexport24
3 files changed, 41 insertions, 1 deletions
diff --git a/www/websh/Makefile b/www/websh/Makefile
index fae2cfa02c42..c1ca66a64690 100644
--- a/www/websh/Makefile
+++ b/www/websh/Makefile
@@ -21,7 +21,6 @@ MAKE_JOBS_UNSAFE= yes
TCL_DVER= ${TCL_VER:S/.//}
USE_TCL= 84+
-INVALID_TCL_VER=86
USE_AUTOTOOLS= autoconf
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src/unix
CONFIGURE_ARGS+=--with-tclinclude=${TCL_INCLUDEDIR} \
@@ -49,6 +48,8 @@ post-patch:
`${DIRNAME} $$p`/`${BASENAME} $$p .html`.whtml; \
done
${REINPLACE_CMD} -e 's,\.html,.whtml,g' ${WRKSRC:H:H}/doc/mod_websh/htdocs/*.ws3
+ ${REINPLACE_CMD} -e 's|__declspec(dllexport)|DLLEXPORT|' \
+ ${WRKSRC}/../generic/*.[ch]
post-configure:
# Remove the "STUBS" and the PACKAGE_* defines, which may conflict
diff --git a/www/websh/files/patch-apache2.4 b/www/websh/files/patch-apache2.4
new file mode 100644
index 000000000000..0c72b371d3af
--- /dev/null
+++ b/www/websh/files/patch-apache2.4
@@ -0,0 +1,15 @@
+--- ../../src/generic/mod_websh.h 2005-12-12 12:13:55.000000000 -0500
++++ ../../src/generic/mod_websh.h 2013-08-03 16:46:07.000000000 -0400
+@@ -30,4 +30,12 @@
+ #include "util_script.h"
+
++/*
++ * This is required for Apache-2.4 -- see:
++ * http://httpd.apache.org/docs/2.4/developer/new_api_2_4.html
++ */
++#ifdef APLOG_USE_MODULE
++APLOG_USE_MODULE(websh);
++#endif
++
+ /* define APACHE2 if appropriate */
+ #ifdef AP_SERVER_BASEREVISION
diff --git a/www/websh/files/patch-dllexport b/www/websh/files/patch-dllexport
new file mode 100644
index 000000000000..c7fb97954a7e
--- /dev/null
+++ b/www/websh/files/patch-dllexport
@@ -0,0 +1,24 @@
+--- ../generic/macros.h 2007-03-19 13:18:37.000000000 -0400
++++ ../generic/macros.h 2013-08-03 17:39:59.000000000 -0400
+@@ -29,8 +29,4 @@
+ #endif
+
+-#ifndef WIN32
+-#define __declspec(dllexport)
+-#endif
+-
+ #include "log.h"
+
+--- ../generic/mod_websh.c 2009-06-12 09:37:16.000000000 -0400
++++ ../generic/mod_websh.c 2013-08-03 17:46:06.000000000 -0400
+@@ -81,8 +81,8 @@
+
+ #ifndef APACHE2
+-module MODULE_VAR_EXPORT websh_module;
++DLLEXPORT module MODULE_VAR_EXPORT websh_module;
+ #define APPOOL pool
+ #else /* APACHE2 */
+-module AP_MODULE_DECLARE_DATA websh_module;
++DLLEXPORT module AP_MODULE_DECLARE_DATA websh_module;
+ #define APPOOL apr_pool_t
+ #endif /* APACHE2 */