summaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2006-02-18 16:58:04 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2006-02-18 16:58:04 +0000
commitc35a9bf510ec13490cc930dceda5ca256f94ff7a (patch)
treee4fe18c4ffc204b07fa01fa41c9ed14d3071885b /www
parent5bd2c255ed60eb8986a7f1c6f0fd19578d59c21a (diff)
downloadfreebsd-ports-c35a9bf510ec13490cc930dceda5ca256f94ff7a.zip
Close pipe for gzipped stream properly.
Obtained from: http://vimrc.hp.infoseek.co.jp/w3m-pclose.html (written in Japanese) Reported by: naddy
Diffstat (limited to 'www')
-rw-r--r--www/w3m/Makefile2
-rw-r--r--www/w3m/files/patch-file.c13
2 files changed, 12 insertions, 3 deletions
diff --git a/www/w3m/Makefile b/www/w3m/Makefile
index bb5204d6dd4f..5d9be439a83c 100644
--- a/www/w3m/Makefile
+++ b/www/w3m/Makefile
@@ -7,7 +7,7 @@
PORTNAME= w3m
PORTVERSION= ${W3M_VERSION}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES+= www ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/www/w3m/files/patch-file.c b/www/w3m/files/patch-file.c
index 957e32f09c93..07868a248356 100644
--- a/www/w3m/files/patch-file.c
+++ b/www/w3m/files/patch-file.c
@@ -1,5 +1,5 @@
---- file.c Sun Oct 9 22:12:16 2005
-+++ file.c Sun Oct 9 22:11:10 2005
+--- file.c.orig Sun Feb 19 01:37:44 2006
++++ file.c Sun Feb 19 01:39:59 2006
@@ -262,7 +262,8 @@
{
return (type == NULL || type[0] == '\0' ||
@@ -10,3 +10,12 @@
}
static int
+@@ -7891,7 +7892,7 @@
+ uf->scheme = SCM_LOCAL;
+ }
+ UFhalfclose(uf);
+- uf->stream = newFileStream(f1, (void (*)())pclose);
++ uf->stream = newFileStream(f1, (void (*)())fclose);
+ }
+
+ static FILE *