summaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-06-06 13:38:32 +0000
committerJohn Marino <marino@FreeBSD.org>2014-06-06 13:38:32 +0000
commita9639cf227ed71a6a66cd5151e81462a1a8c370a (patch)
tree0fcadacbcdd5e6835728f226c62abf20d3538211 /www
parentde3e3429dc0cb2fbe8bd92cce769df612dd0086f (diff)
downloadfreebsd-ports-a9639cf227ed71a6a66cd5151e81462a1a8c370a.zip
www/templatelite: Stage support and cleanup
The suggested patch was technically correct, but it was putting lipstick on a pig. The install target was pretty ugly. Let's clean this up a bit without homegrown copytrees, then pet portlint. Also, get rid of NOPORTDOCS in favor of standard options. Sorry, not of the original patch is left. PR: ports/190683 Submitted by: joe@thrallingpenguin.com Reworked by: marino
Diffstat (limited to 'www')
-rw-r--r--www/templatelite/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/www/templatelite/Makefile b/www/templatelite/Makefile
index 46ebb661c6d4..67deba384a99 100644
--- a/www/templatelite/Makefile
+++ b/www/templatelite/Makefile
@@ -8,24 +8,24 @@ MASTER_SITES= SF/${PORTNAME}/Template%20Lite/Template%20Lite%20version%20${PORTV
DISTNAME= template_lite_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A smaller, faster alternative to the Smarty template engine
+COMMENT= Smaller, faster alternative to the Smarty template engine
NO_BUILD= yes
USE_PHP= pcre
WANT_PHP_WEB= yes
-WRKSRC= ${WRKDIR}/template_lite
+WRKSRC= ${WRKDIR}/template_lite
SUB_FILES= pkg-message
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
do-install:
- @${MKDIR} ${DATADIR}
- @cd ${WRKSRC}/src && ${FIND} * | ${TAR} cTf - - | ${TAR} xUCf ${DATADIR} -
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @cd ${WRKSRC}/docs && ${FIND} * | ${TAR} cTf - - | ${TAR} xUCf ${DOCSDIR} -
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ @cd ${WRKSRC}/src && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
.endif
-post-install:
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.mk>