summaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-10-15 14:55:14 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-10-15 14:55:14 +0000
commit7f0f664d7e0d5fbb1fd0e1cc45d4b413f66c97ae (patch)
treed30bee8baf5be305289898828fb58299162e2f54 /www
parentb3175cfda759707ed077a4649b634cad8934eb1b (diff)
downloadfreebsd-ports-7f0f664d7e0d5fbb1fd0e1cc45d4b413f66c97ae.zip
Drop 8 support.
With hat: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D3694
Diffstat (limited to 'www')
-rw-r--r--www/mod_spdy/Makefile13
-rw-r--r--www/node-devel/Makefile2
-rw-r--r--www/tengine/Makefile5
-rw-r--r--www/trafficserver/Makefile2
4 files changed, 3 insertions, 19 deletions
diff --git a/www/mod_spdy/Makefile b/www/mod_spdy/Makefile
index 4f10a67e7aba..ad1bd1fc37d0 100644
--- a/www/mod_spdy/Makefile
+++ b/www/mod_spdy/Makefile
@@ -50,7 +50,7 @@ GCC_DESC= Build mod_spdy with GCC 4.6+
.include <bsd.port.options.mk>
-.if ${OSVERSION} < 900033 || ${PORT_OPTIONS:MGCC}
+.if ${PORT_OPTIONS:MGCC}
BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
CONFIGURE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
MAKE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
@@ -60,15 +60,8 @@ MAKE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
USE_GCC?= yes
GYP_DEFINES+= gcc_version=${CXX:S/g++//}
.else
-.if ${OSVERSION} < 902000
-BROKEN= Depends on deleted lang/llvm32
-#BUILD_DEPENDS+= ${LOCALBASE}/bin/clang32:${PORTSDIR}/lang/clang32
-CC= ${LOCALBASE}/bin/clang32
-CXX= ${LOCALBASE}/bin/clang++32
-.else
CC= clang
CXX= clang++
-.endif
GYP_DEFINES+= clang=1
.endif
@@ -97,10 +90,6 @@ MAKE_ENV+= BUILDTYPE=${BUILDTYPE}
.include <bsd.port.pre.mk>
-.if ${ARCH} == i386 && ${OSVERSION} < 901000
-BROKEN= does not link due to libtool not respecting CC
-.endif
-
post-extract:
@${MKDIR} ${WRKSRC}/temp/progress
@${CP} ${DISTDIR}/${DIST_SUBDIR}/httpd-2.2.22.tar.gz ${WRKSRC}/temp/ && \
diff --git a/www/node-devel/Makefile b/www/node-devel/Makefile
index a2b8c38d6069..f15c94b5df37 100644
--- a/www/node-devel/Makefile
+++ b/www/node-devel/Makefile
@@ -26,7 +26,7 @@ REINPLACE_ARGS= -i ''
.include <bsd.port.options.mk>
-.if ${OSVERSION} >= 900033 && exists(/usr/bin/clang)
+.if exists(/usr/bin/clang)
CC= clang
CXX= clang++
GYP_DEFINES+= clang=1
diff --git a/www/tengine/Makefile b/www/tengine/Makefile
index 3aa4074fd450..3170fc4261ee 100644
--- a/www/tengine/Makefile
+++ b/www/tengine/Makefile
@@ -164,11 +164,6 @@ XSS_DESC= 3rd party xss module
.include <bsd.port.options.mk>
-# FreeBSD 8 and earlier are unsupported
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 900500
-IGNORE= is unsupported on FreeBSD 8 and earlier
-.endif
-
NGINX_VARDIR?= /var
NGINX_LOGDIR?= ${NGINX_VARDIR}/log
NGINX_RUNDIR?= ${NGINX_VARDIR}/run
diff --git a/www/trafficserver/Makefile b/www/trafficserver/Makefile
index 9d8e4521af91..2fb43ecf289f 100644
--- a/www/trafficserver/Makefile
+++ b/www/trafficserver/Makefile
@@ -77,7 +77,7 @@ CONFIGURE_ARGS+= --disable-freelist
IGNORE= no allocation strategy selected
.endif
-.if ${OSVERSION} >= 900033 && exists(/usr/bin/clang)
+.if exists(/usr/bin/clang)
CC= clang
CXX= clang++
.endif