summaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2007-04-23 01:28:02 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2007-04-23 01:28:02 +0000
commit647e11a36ac7fdd205da3084919de772d855be08 (patch)
tree78f6f33d4443522aeb189827fae5e2c42b1ff6d0 /www
parentcd913f1611a33a5d559e4500c0cad95ae1cbfb9f (diff)
downloadfreebsd-ports-647e11a36ac7fdd205da3084919de772d855be08.zip
add rubygem-taggable 2.0.2
Add tagging capabilities to your ActiveRecord objects
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-taggable/Makefile23
-rw-r--r--www/rubygem-taggable/distinfo3
-rw-r--r--www/rubygem-taggable/pkg-descr6
-rw-r--r--www/rubygem-taggable/pkg-plist53
5 files changed, 86 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index dd7fcf8ca2a4..5a1686b7277d 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1066,6 +1066,7 @@
SUBDIR += rubygem-rubyfulsoup
SUBDIR += rubygem-scrapi
SUBDIR += rubygem-scrubyt
+ SUBDIR += rubygem-taggable
SUBDIR += sams
SUBDIR += sarg
SUBDIR += sbox-dtc
diff --git a/www/rubygem-taggable/Makefile b/www/rubygem-taggable/Makefile
new file mode 100644
index 000000000000..6d0feff1467f
--- /dev/null
+++ b/www/rubygem-taggable/Makefile
@@ -0,0 +1,23 @@
+# ex:ts=8
+# Ports collection makefile for: taggable
+# Date created: Apr 22, 2007
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= taggable
+PORTVERSION= 2.0.2
+CATEGORIES= www rubygems
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= acts_as_taggable-${PORTVERSION}
+
+MAINTAINER= ijliao@FreeBSD.org
+COMMENT= Add tagging capabilities to your ActiveRecord objects
+
+GEM_NAME= ${DISTNAME}
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/www/rubygem-taggable/distinfo b/www/rubygem-taggable/distinfo
new file mode 100644
index 000000000000..d8e8209f8825
--- /dev/null
+++ b/www/rubygem-taggable/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/acts_as_taggable-2.0.2.gem) = 76b46879bd8a23f1136b97cfeaf72d5c
+SHA256 (rubygem/acts_as_taggable-2.0.2.gem) = 163bc7ea3e5d29c0bf4ae952457ee8eccefb4aab1c885ca4b4ec438f8fb0739f
+SIZE (rubygem/acts_as_taggable-2.0.2.gem) = 17408
diff --git a/www/rubygem-taggable/pkg-descr b/www/rubygem-taggable/pkg-descr
new file mode 100644
index 000000000000..c4c0ebb3d4ee
--- /dev/null
+++ b/www/rubygem-taggable/pkg-descr
@@ -0,0 +1,6 @@
+This ActiveRecord acts-as mixin provides an easy way for addind tagging
+capabilities (also known as folksnomy) to your ActiveRecord objects. It
+allows you to apply tags to your objects as well as search for tagged
+objects.
+
+WWW: http://rubyforge.org/projects/taggable/
diff --git a/www/rubygem-taggable/pkg-plist b/www/rubygem-taggable/pkg-plist
new file mode 100644
index 000000000000..d7fe26cc0f6a
--- /dev/null
+++ b/www/rubygem-taggable/pkg-plist
@@ -0,0 +1,53 @@
+%%GEM_CACHE%%
+%%GEM_SPEC%%
+%%GEM_LIB_DIR%%/CHANGELOG
+%%GEM_LIB_DIR%%/README
+%%GEM_LIB_DIR%%/lib/taggable.rb
+%%GEM_LIB_DIR%%/test/acts_as_taggable_test.rb
+%%GEM_LIB_DIR%%/test/config.yml
+%%GEM_LIB_DIR%%/test/config.yml.sample
+%%GEM_LIB_DIR%%/test/debug.log
+@dirrm %%GEM_LIB_DIR%%/test
+@dirrm %%GEM_LIB_DIR%%/lib
+@dirrm %%GEM_LIB_DIR%%
+%%GEM_DOC_DIR%%/rdoc/classes/ActiveRecord.html
+%%GEM_DOC_DIR%%/rdoc/classes/ActiveRecord/Acts/Taggable/ClassMethods.html
+%%GEM_DOC_DIR%%/rdoc/classes/ActiveRecord/Acts/Taggable/ClassMethods.src/M000009.html
+%%GEM_DOC_DIR%%/rdoc/classes/ActiveRecord/Acts/Taggable/InstanceMethods.html
+%%GEM_DOC_DIR%%/rdoc/classes/ActiveRecord/Acts/Taggable/InstanceMethods.src/M000010.html
+%%GEM_DOC_DIR%%/rdoc/classes/ActiveRecord/Acts/Taggable/InstanceMethods.src/M000011.html
+%%GEM_DOC_DIR%%/rdoc/classes/ActiveRecord/Acts/Taggable/InstanceMethods.src/M000012.html
+%%GEM_DOC_DIR%%/rdoc/classes/ActiveRecord/Acts/Taggable/InstanceMethods.src/M000013.html
+%%GEM_DOC_DIR%%/rdoc/classes/ActiveRecord/Acts/Taggable/InstanceMethods.src/M000014.html
+%%GEM_DOC_DIR%%/rdoc/classes/ActiveRecord/Acts/Taggable/InstanceMethods.src/M000015.html
+%%GEM_DOC_DIR%%/rdoc/classes/ActiveRecord/Acts/Taggable/InstanceMethods.src/M000016.html
+%%GEM_DOC_DIR%%/rdoc/classes/ActiveRecord/Acts/Taggable/InstanceMethods.src/M000017.html
+%%GEM_DOC_DIR%%/rdoc/classes/ActiveRecord/Acts/Taggable/InstanceMethods.src/M000018.html
+%%GEM_DOC_DIR%%/rdoc/classes/ActiveRecord/Acts/Taggable/SingletonMethods.html
+%%GEM_DOC_DIR%%/rdoc/classes/ActiveRecord/Acts/Taggable/SingletonMethods.src/M000001.html
+%%GEM_DOC_DIR%%/rdoc/classes/ActiveRecord/Acts/Taggable/SingletonMethods.src/M000002.html
+%%GEM_DOC_DIR%%/rdoc/classes/ActiveRecord/Acts/Taggable/SingletonMethods.src/M000003.html
+%%GEM_DOC_DIR%%/rdoc/classes/ActiveRecord/Acts/Taggable/SingletonMethods.src/M000004.html
+%%GEM_DOC_DIR%%/rdoc/classes/ActiveRecord/Acts/Taggable/SingletonMethods.src/M000006.html
+%%GEM_DOC_DIR%%/rdoc/classes/ActiveRecord/Acts/Taggable/SingletonMethods.src/M000007.html
+%%GEM_DOC_DIR%%/rdoc/classes/ActiveRecord/Acts/Taggable/SingletonMethods.src/M000008.html
+%%GEM_DOC_DIR%%/rdoc/created.rid
+%%GEM_DOC_DIR%%/rdoc/files/CHANGELOG.html
+%%GEM_DOC_DIR%%/rdoc/files/README.html
+%%GEM_DOC_DIR%%/rdoc/files/lib/taggable_rb.html
+%%GEM_DOC_DIR%%/rdoc/fr_class_index.html
+%%GEM_DOC_DIR%%/rdoc/fr_file_index.html
+%%GEM_DOC_DIR%%/rdoc/fr_method_index.html
+%%GEM_DOC_DIR%%/rdoc/index.html
+%%GEM_DOC_DIR%%/rdoc/rdoc-style.css
+@dirrm %%GEM_DOC_DIR%%/rdoc/files/lib
+@dirrm %%GEM_DOC_DIR%%/rdoc/files
+@dirrm %%GEM_DOC_DIR%%/rdoc/classes/ActiveRecord/Acts/Taggable/SingletonMethods.src
+@dirrm %%GEM_DOC_DIR%%/rdoc/classes/ActiveRecord/Acts/Taggable/InstanceMethods.src
+@dirrm %%GEM_DOC_DIR%%/rdoc/classes/ActiveRecord/Acts/Taggable/ClassMethods.src
+@dirrm %%GEM_DOC_DIR%%/rdoc/classes/ActiveRecord/Acts/Taggable
+@dirrm %%GEM_DOC_DIR%%/rdoc/classes/ActiveRecord/Acts
+@dirrm %%GEM_DOC_DIR%%/rdoc/classes/ActiveRecord
+@dirrm %%GEM_DOC_DIR%%/rdoc/classes
+@dirrm %%GEM_DOC_DIR%%/rdoc
+@dirrm %%GEM_DOC_DIR%%