summaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-06-03 18:04:57 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-06-03 18:04:57 +0000
commit503914d96098c753ada3c97383ec473162faabf3 (patch)
tree305ebc638595361a1b2192157d476e4b860257c8 /www
parent029068d4d94de10b3ae7441dc6e9a93581520963 (diff)
downloadfreebsd-ports-503914d96098c753ada3c97383ec473162faabf3.zip
- Add LICENSE
- Fix shebangs - Simplify WRKSRC handling - Fix stripping - Drop @dirrm* from plist
Diffstat (limited to 'www')
-rw-r--r--www/webstone/Makefile34
-rw-r--r--www/webstone/files/patch-CGI-test__ws25_cgi.c11
-rw-r--r--www/webstone/files/patch-src_CGI-test_ws25__cgi.c11
-rw-r--r--www/webstone/files/patch-src_Makefile.in (renamed from www/webstone/files/patch-Makefile.in)6
-rw-r--r--www/webstone/files/patch-src_genrand.c (renamed from www/webstone/files/patch-genrand.c)6
-rw-r--r--www/webstone/files/patch-src_webclient.c (renamed from www/webstone/files/patch-webclient.c)10
-rw-r--r--www/webstone/files/patch-src_webmaster.c (renamed from www/webstone/files/patch-webmaster.c)10
-rw-r--r--www/webstone/pkg-plist4
8 files changed, 51 insertions, 41 deletions
diff --git a/www/webstone/Makefile b/www/webstone/Makefile
index 7f98384026f2..7e64d83d3171 100644
--- a/www/webstone/Makefile
+++ b/www/webstone/Makefile
@@ -3,6 +3,7 @@
PORTNAME= webstone
PORTVERSION= 2.5
+PORTREVISION= 1
CATEGORIES= www benchmarks
MASTER_SITES= http://www.mindcraft.com/webstone/
DISTNAME= ws25_src
@@ -10,28 +11,41 @@ DISTNAME= ws25_src
MAINTAINER= ports@FreeBSD.org
COMMENT= World wide web server benchmarking
-USES= tar:tgz
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= shebangfix tar:tgz
GNU_CONFIGURE= yes
-WRKSRC= ${WRKDIR}/WebStone2.5/src
+WRKSRC= ${WRKDIR}/WebStone${PORTVERSION}
+CONFIGURE_WRKSRC= ${WRKSRC}/src
+BUILD_WRKSRC= ${WRKSRC}/src
ALL_TARGET= install
+post-patch:
+ @${FIND} ${WRKSRC}/bin -name "*.pl" -o -name "*.wpl" | ${XARGS} \
+ ${REINPLACE_CMD} -i '' -e '1s|.*perl.*|#!${perl_CMD}|'
+
do-install:
- @${RM} ${WRKSRC}/../bin/runs/keepme
- @${RMDIR} ${WRKSRC}/../bin/runs
+ @${RM} ${WRKSRC}/bin/runs/keepme
+ @${RMDIR} ${WRKSRC}/bin/runs
@${MKDIR} ${STAGEDIR}${PREFIX}/webstone/bin
@${MKDIR} ${STAGEDIR}${PREFIX}/webstone/conf
@${MKDIR} ${STAGEDIR}${PREFIX}/webstone/lgm
- ${INSTALL_SCRIPT} ${WRKSRC}/../bin/* ${STAGEDIR}${PREFIX}/webstone/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/../lgm/* ${STAGEDIR}${PREFIX}/webstone/lgm
- ${INSTALL_DATA} ${WRKSRC}/../conf/* ${STAGEDIR}${PREFIX}/webstone/conf
- ${INSTALL_SCRIPT} ${WRKSRC}/../webstone ${STAGEDIR}${PREFIX}/webstone
- @${MKDIR} ${WRKSRC}/../bin/runs
- @${TOUCH} ${WRKSRC}/../bin/runs/keepme
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/* ${STAGEDIR}${PREFIX}/webstone/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/lgm/* ${STAGEDIR}${PREFIX}/webstone/lgm
+ ${INSTALL_DATA} ${WRKSRC}/conf/* ${STAGEDIR}${PREFIX}/webstone/conf
+ ${INSTALL_SCRIPT} ${WRKSRC}/webstone ${STAGEDIR}${PREFIX}/webstone
+ @${MKDIR} ${WRKSRC}/bin/runs
+ @${TOUCH} ${WRKSRC}/bin/runs/keepme
.for file in webclient webmaster genrand
+ ${CHMOD} u+w ${STAGEDIR}${PREFIX}/webstone/bin/${file}
${STRIP_CMD} ${STAGEDIR}${PREFIX}/webstone/bin/${file}
+ ${CHMOD} u-w ${STAGEDIR}${PREFIX}/webstone/bin/${file}
.endfor
.for file in ws20_cgi ws25_cgi
+ ${CHMOD} u+w ${STAGEDIR}${PREFIX}/webstone/lgm/${file}
${STRIP_CMD} ${STAGEDIR}${PREFIX}/webstone/lgm/${file}
+ ${CHMOD} u-w ${STAGEDIR}${PREFIX}/webstone/lgm/${file}
.endfor
.include <bsd.port.mk>
diff --git a/www/webstone/files/patch-CGI-test__ws25_cgi.c b/www/webstone/files/patch-CGI-test__ws25_cgi.c
deleted file mode 100644
index e303d84c965e..000000000000
--- a/www/webstone/files/patch-CGI-test__ws25_cgi.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- CGI-test/ws25_cgi.c~ 1998-07-25 10:49:54.000000000 +0200
-+++ CGI-test/ws25_cgi.c 2011-12-20 19:17:47.104175312 +0100
-@@ -62,7 +62,7 @@
- #include <stdio.h>
- #include <sys/types.h>
-
--void
-+int
- main()
- {
- char *query_string;
diff --git a/www/webstone/files/patch-src_CGI-test_ws25__cgi.c b/www/webstone/files/patch-src_CGI-test_ws25__cgi.c
new file mode 100644
index 000000000000..639787138681
--- /dev/null
+++ b/www/webstone/files/patch-src_CGI-test_ws25__cgi.c
@@ -0,0 +1,11 @@
+--- src/CGI-test/ws25_cgi.c.orig 1998-07-25 08:49:54 UTC
++++ src/CGI-test/ws25_cgi.c
+@@ -62,7 +62,7 @@
+ #include <stdio.h>
+ #include <sys/types.h>
+
+-void
++int
+ main()
+ {
+ char *query_string;
diff --git a/www/webstone/files/patch-Makefile.in b/www/webstone/files/patch-src_Makefile.in
index d2f98058f3b5..c418580b8cca 100644
--- a/www/webstone/files/patch-Makefile.in
+++ b/www/webstone/files/patch-src_Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig Mon Sep 4 18:52:21 2000
-+++ Makefile.in Mon Sep 4 18:52:45 2000
-@@ -64,9 +64,9 @@
+--- src/Makefile.in.orig 1998-07-25 07:50:19 UTC
++++ src/Makefile.in
+@@ -64,9 +64,9 @@ TARGETS = $(EXECUTABLE1) $(EXECUTABLE2)
.SUFFIXES:
.SUFFIXES: .c .o
diff --git a/www/webstone/files/patch-genrand.c b/www/webstone/files/patch-src_genrand.c
index 467174752a66..2e792b7fa46b 100644
--- a/www/webstone/files/patch-genrand.c
+++ b/www/webstone/files/patch-src_genrand.c
@@ -1,5 +1,5 @@
---- genrand.c~ 1998-07-25 09:50:16.000000000 +0200
-+++ genrand.c 2011-12-20 19:16:38.086174883 +0100
+--- src/genrand.c.orig 1998-07-25 07:50:16 UTC
++++ src/genrand.c
@@ -31,7 +31,7 @@
#include <sys/stat.h>
#include "sysdep.h"
@@ -9,7 +9,7 @@
main(const int argc, char* argv[])
{
FILE* file;
-@@ -70,4 +70,5 @@
+@@ -70,4 +70,5 @@ main(const int argc, char* argv[])
}
fclose(file);
diff --git a/www/webstone/files/patch-webclient.c b/www/webstone/files/patch-src_webclient.c
index d6d66e1eede0..be22b95ef122 100644
--- a/www/webstone/files/patch-webclient.c
+++ b/www/webstone/files/patch-src_webclient.c
@@ -1,6 +1,6 @@
---- webclient.c.orig 1998-07-25 09:50:17.000000000 +0200
-+++ webclient.c 2011-12-20 19:15:12.739176097 +0100
-@@ -79,7 +79,7 @@
+--- src/webclient.c.orig 1998-07-25 07:50:17 UTC
++++ src/webclient.c
+@@ -79,7 +79,7 @@ char webserver[MAXHOSTNAMELEN];
char proxyserver[MAXHOSTNAMELEN];
char debug_filename[MAXPATHLEN];
@@ -9,7 +9,7 @@
THREAD FILE *logfile;
THREAD stats_t timestat;
THREAD rqst_timer_t timerarray[MAXNUMOFFILES];
-@@ -691,7 +691,7 @@
+@@ -691,7 +691,7 @@ ParseCmdLine(int argc, char **argv )
}
}
@@ -18,7 +18,7 @@
main(int argc, char *argv[])
{
long fcount = 0;
-@@ -928,7 +928,7 @@
+@@ -928,7 +928,7 @@ main(int argc, char *argv[])
CloseHandle(hSemaphore);
#endif /* WIN32 */
diff --git a/www/webstone/files/patch-webmaster.c b/www/webstone/files/patch-src_webmaster.c
index 0f869e84a2fc..b33f2a171fc9 100644
--- a/www/webstone/files/patch-webmaster.c
+++ b/www/webstone/files/patch-src_webmaster.c
@@ -1,6 +1,6 @@
---- webmaster.c.orig 1998-07-25 09:50:18.000000000 +0200
-+++ webmaster.c 2011-12-20 19:14:07.911175579 +0100
-@@ -88,7 +88,7 @@
+--- src/webmaster.c.orig 1998-07-25 07:50:18 UTC
++++ src/webmaster.c
+@@ -88,7 +88,7 @@ int num_rexecs = 0;
SOCKET socknum[MAXCLIENTS];
SOCKET sockIO[MAXTOTALPROCS];
SOCKET sockErr[MAXTOTALPROCS];
@@ -9,7 +9,7 @@
struct hostent *master_phe; /* IP addresses for webmaster */
-@@ -1343,7 +1343,7 @@
+@@ -1343,7 +1343,7 @@ sock_cleanup(void)
}
#endif /* WIN32 */
@@ -18,7 +18,7 @@
main(const int argc, char *argv[])
{
-@@ -1385,6 +1385,7 @@
+@@ -1385,6 +1385,7 @@ main(const int argc, char *argv[])
/* Initalization of variables. */
/* debugfile = stdout; */
diff --git a/www/webstone/pkg-plist b/www/webstone/pkg-plist
index 59ebd3ec9da3..cec224edccfe 100644
--- a/www/webstone/pkg-plist
+++ b/www/webstone/pkg-plist
@@ -47,7 +47,3 @@ webstone/lgm/keepme
webstone/lgm/ws20_cgi
webstone/lgm/ws25_cgi
webstone/webstone
-@dirrm webstone/bin
-@dirrm webstone/conf
-@dirrm webstone/lgm
-@dirrm webstone