summaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-02-24 10:36:05 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-02-24 10:36:05 +0000
commit474b429209d1feada292ef85821ed0caad5dcc76 (patch)
tree9780838b90d51f37ef7ff80f855e3961f64b1bf9 /www
parent9d27ea5b39eadf91d6f45cdbf52892ec399469bb (diff)
downloadfreebsd-ports-474b429209d1feada292ef85821ed0caad5dcc76.zip
- Add HPACK option
Diffstat (limited to 'www')
-rw-r--r--www/nghttp2/Makefile6
-rw-r--r--www/nghttp2/pkg-plist2
2 files changed, 8 insertions, 0 deletions
diff --git a/www/nghttp2/Makefile b/www/nghttp2/Makefile
index 4712de06379a..9bcc48a31336 100644
--- a/www/nghttp2/Makefile
+++ b/www/nghttp2/Makefile
@@ -14,6 +14,9 @@ LICENSE= MIT
LIB_DEPENDS= libevent_openssl.so:${PORTSDIR}/devel/libevent2 \
libspdylay.so:${PORTSDIR}/www/spdylay
+OPTIONS_DEFINE= HPACK
+OPTIONS_SUB= yes
+
CONFIGURE_ARGS= --disable-python-bindings \
--enable-app \
--enable-examples
@@ -31,6 +34,9 @@ USES= compiler:c++11-lang pathfix pkgconfig
PORTDOCS= *
+HPACK_CONFIGURE_ARGS= --enable-hpack-tools
+HPACK_LIB_DEPENDS= libjansson.so:${PORTSDIR}/devel/jansson
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 1000000 && !defined(WITH_OPENSSL_PORT)
diff --git a/www/nghttp2/pkg-plist b/www/nghttp2/pkg-plist
index 2b293642eeda..2b89c6531eed 100644
--- a/www/nghttp2/pkg-plist
+++ b/www/nghttp2/pkg-plist
@@ -1,3 +1,5 @@
+%%HPACK%%bin/deflatehd
+%%HPACK%%bin/inflatehd
bin/nghttp
bin/nghttpd
bin/nghttpx