summaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-12-05 18:27:45 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-12-05 18:27:45 +0000
commit3e0d5f3a28d816d64f1526fcf192ecda3fc72405 (patch)
tree47cea172d48222b981e76a308d966521d9916a23 /www
parent05c124ff50f1c19d3aa18c0d1338fc25c2c618fc (diff)
downloadfreebsd-ports-3e0d5f3a28d816d64f1526fcf192ecda3fc72405.zip
www/squid: fix build on GCC architectures
Add --disable-strict-error-checking to CONFIGURE_ARGS for everyone. It adds -Werror, which is against ports tree policy and causes: Icmp6.cc: In member function 'virtual void Icmp6::SendEcho(Ip::Address&, int, const char*, int)': Icmp6.cc:165:72: error: converting a packed 'icmp6_hdr' pointer (alignment 1) to a 'short unsigned int' pointer (alignment 2) may result in an unaligned pointer value [-Werror=address-of-packed-member] 165 | icmp->icmp6_cksum = CheckSum((unsigned short *) icmp, icmp6_pktsize); | ^ In file included from Icmp6.h:20, from Icmp6.cc:18: /usr/include/netinet/icmp6.h:72:8: note: defined here 72 | struct icmp6_hdr { | ^~~~~~~~~ At global scope: cc1plus: error: unrecognized command line option '-Wno-deprecated-register' [-Werror] cc1plus: all warnings being treated as errors PR: 241804 Approved by: timp87@gmail.com (maintainer), mentors (implicit approval)
Diffstat (limited to 'www')
-rw-r--r--www/squid/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/www/squid/Makefile b/www/squid/Makefile
index da274aa97687..ca03ad6f0997 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -118,7 +118,6 @@ SSL_CRTD_IMPLIES= SSL
STACKTRACES_CONFIGURE_ENABLE= stacktraces
STACKTRACES_EXTRA_PATCHES= ${FILESDIR}/extra-patch-gen-stacktrace
STACKTRACES_LIB_DEPENDS= libunwind.so:devel/libunwind
-STACKTRACES_CONFIGURE_ON= --disable-strict-error-checking
STACKTRACES_CFLAGS= -g
STACKTRACES_LDFLAGS= -lunwind -L${LOCALBASE}/lib
STACKTRACES_VARS= STRIP=""
@@ -188,10 +187,6 @@ VIA_DB_DESC= Forward/Via database
WCCPV2_DESC= Web Cache Coordination Protocol v2
WCCP_DESC= Web Cache Coordination Protocol
-CFLAGS+= ${CFLAGS_${CHOSEN_COMPILER_TYPE}}
-CFLAGS+= -Wno-error=deprecated-declarations
-CFLAGS_gcc= -Wno-error=stringop-truncation
-
change_files= ChangeLog \
contrib/nextstep/makepkg \
contrib/nextstep/post_install \
@@ -234,7 +229,8 @@ CONFIGURE_ARGS= --with-default-user=squid \
--disable-linux-netfilter \
--disable-linux-tproxy \
--disable-translation \
- --disable-arch-native
+ --disable-arch-native \
+ --disable-strict-error-checking
.include <bsd.port.options.mk>