summaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2014-09-16 18:25:05 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2014-09-16 18:25:05 +0000
commit3b92db9566653364ec141359d09f15c543301c13 (patch)
treebdfc65a3cf76f962c94dd0083a23c53d15f8584b /www
parent9229cfb2fb43f1d691ea6994474fb4d7853e7ed5 (diff)
downloadfreebsd-ports-3b92db9566653364ec141359d09f15c543301c13.zip
New port: www/p5-Dancer-Plugin-Memcached:
This plugin gives Dancer the ability to get and store page content in a memcached server, which in specific configurations could give a performance boost - particulary on GET requests that incur significant database calls. WWW: http://search.cpan.org/dist/Dancer-Plugin-Memcached/
Diffstat (limited to 'www')
-rw-r--r--www/p5-Dancer-Plugin-Memcached/Makefile20
-rw-r--r--www/p5-Dancer-Plugin-Memcached/distinfo2
-rw-r--r--www/p5-Dancer-Plugin-Memcached/pkg-descr6
-rw-r--r--www/p5-Dancer-Plugin-Memcached/pkg-plist5
4 files changed, 33 insertions, 0 deletions
diff --git a/www/p5-Dancer-Plugin-Memcached/Makefile b/www/p5-Dancer-Plugin-Memcached/Makefile
new file mode 100644
index 000000000000..e6111c6b89cb
--- /dev/null
+++ b/www/p5-Dancer-Plugin-Memcached/Makefile
@@ -0,0 +1,20 @@
+# Created by: Ryan Steinmetz <zi@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Dancer-Plugin-Memcached
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:SQUEEK
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Cache response content to memcached
+
+RUN_DEPENDS= p5-Dancer>0:${PORTSDIR}/www/p5-Dancer
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure fixpacklist
+
+.include <bsd.port.mk>
diff --git a/www/p5-Dancer-Plugin-Memcached/distinfo b/www/p5-Dancer-Plugin-Memcached/distinfo
new file mode 100644
index 000000000000..56e003cd267c
--- /dev/null
+++ b/www/p5-Dancer-Plugin-Memcached/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Dancer-Plugin-Memcached-0.02.tar.gz) = 45201542cd80b479ef7800c924cdfc83d4022a94cb1fd67bb98c8d25e238552e
+SIZE (Dancer-Plugin-Memcached-0.02.tar.gz) = 10602
diff --git a/www/p5-Dancer-Plugin-Memcached/pkg-descr b/www/p5-Dancer-Plugin-Memcached/pkg-descr
new file mode 100644
index 000000000000..25c5b8f00b0a
--- /dev/null
+++ b/www/p5-Dancer-Plugin-Memcached/pkg-descr
@@ -0,0 +1,6 @@
+This plugin gives Dancer the ability to get and store page content in a
+memcached server, which in specific configurations could give a
+performance boost - particulary on GET requests that incur significant
+database calls.
+
+WWW: http://search.cpan.org/dist/Dancer-Plugin-Memcached/
diff --git a/www/p5-Dancer-Plugin-Memcached/pkg-plist b/www/p5-Dancer-Plugin-Memcached/pkg-plist
new file mode 100644
index 000000000000..6538642b9347
--- /dev/null
+++ b/www/p5-Dancer-Plugin-Memcached/pkg-plist
@@ -0,0 +1,5 @@
+%%PERL5_MAN3%%/Dancer::Plugin::Memcached.3.gz
+%%SITE_PERL%%/Dancer/Plugin/Memcached.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Plugin/Memcached/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Plugin/Memcached
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Plugin