summaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-12-08 16:49:43 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-12-08 16:49:43 +0000
commit31469ae5656e71f14de03b31cf71b809859573d2 (patch)
tree344b6abf61ea06069f5de2c1cdcb8209791ac07e /www
parent2625e8a3e3cca5d0659fb2fd36594a503ce698ca (diff)
downloadfreebsd-ports-31469ae5656e71f14de03b31cf71b809859573d2.zip
PyQt: Replace bsd.pyqt.mk with Uses/pyqt.mk.
In preparation for landing PyQt5 ports, generalize devel/py-qt4's bsd.pyqt.mk and make it a proper file in Uses/. Ports wishing to depend on PyQt4 ports can now do the following: USES= pyqt:4 USE_PYQT= foo bar_build baz_run Other changes include the renaming of the PYQT4_DIST variable to PYQT_DIST and the introduction of the PYQT_SIPDIR plist substitution variable. The rest of the contents of Uses/pyqt.mk are pretty much identical to what we had in bsd.pyqt.mk with additional processing of USE_PYQT. Even though this patch touches files in many different ports, the goal is for it to be a no-op from an end-user perspective (so that the basic infrastructure is landed before the other, riskier changes): no dependencies have been changed, PyQt/SIP/QScintilla have not been upgraded and the plists should remain exactly the same, since PYQT_SIPDIR currently contains the same value that used to be hardcoded in the plists. Huge thanks to Guido Falsi (madpilot@) for spearheading most of the work: he took the initiative to work on PyQt5 and sent D2910 to Phabricator with the original version of this patch. Tobias Berner (tcberner@gmail.com) later applied it to kde@'s experimental area51 repositories and did some more work on it.
Diffstat (limited to 'www')
-rw-r--r--www/py-qt4-webkit/Makefile9
-rw-r--r--www/py-qt4-webkit/pkg-plist30
2 files changed, 19 insertions, 20 deletions
diff --git a/www/py-qt4-webkit/Makefile b/www/py-qt4-webkit/Makefile
index 4dca88718590..40789f1c8878 100644
--- a/www/py-qt4-webkit/Makefile
+++ b/www/py-qt4-webkit/Makefile
@@ -7,11 +7,11 @@ CATEGORIES= www devel python
MAINTAINER= kde@FreeBSD.org
COMMENT= Python bindings for the Qt4 toolkit, QtWebKit module
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sip>=${SIP_VERSION}:${PORTSDIR}/devel/py-sip
-RUN_DEPENDS= ${PKGNAMEPREFIX}gui>=${PYQT4_VERSION}:${PORTSDIR}/x11-toolkits/py-qt4-gui
-
CONFIGURE_ARGS= --enable QtWebKit
-PYQT4_DIST= yes
+PYQT_DIST= yes
+
+USES= python pyqt:4
+USE_PYQT= sip_build gui_run
USE_QT4= qmake_build gui moc_build network webkit
OPTIONS_DEFINE= API DEBUG
@@ -24,5 +24,4 @@ API_CONFIGURE_OFF= --no-qsci-api
API_LIB_DEPENDS= libqscintilla2.so:${PORTSDIR}/devel/qscintilla2
DEBUG_CONFIGURE_ON= --debug --trace
-.include "${.CURDIR}/../../devel/py-qt4/bsd.pyqt.mk"
.include <bsd.port.mk>
diff --git a/www/py-qt4-webkit/pkg-plist b/www/py-qt4-webkit/pkg-plist
index 0f77649ebe61..4308e93c3096 100644
--- a/www/py-qt4-webkit/pkg-plist
+++ b/www/py-qt4-webkit/pkg-plist
@@ -1,17 +1,17 @@
%%PYTHON_SITELIBDIR%%/PyQt4/QtWebKit.so
-share/py-sip/QtWebKit/QtWebKitmod.sip
-share/py-sip/QtWebKit/qgraphicswebview.sip
-share/py-sip/QtWebKit/qwebdatabase.sip
-share/py-sip/QtWebKit/qwebelement.sip
-share/py-sip/QtWebKit/qwebframe.sip
-share/py-sip/QtWebKit/qwebhistory.sip
-share/py-sip/QtWebKit/qwebhistoryinterface.sip
-share/py-sip/QtWebKit/qwebinspector.sip
-share/py-sip/QtWebKit/qwebkitglobal.sip
-share/py-sip/QtWebKit/qwebkitversion.sip
-share/py-sip/QtWebKit/qwebpage.sip
-share/py-sip/QtWebKit/qwebpluginfactory.sip
-share/py-sip/QtWebKit/qwebsecurityorigin.sip
-share/py-sip/QtWebKit/qwebsettings.sip
-share/py-sip/QtWebKit/qwebview.sip
+%%PYQT_SIPDIR%%/QtWebKit/QtWebKitmod.sip
+%%PYQT_SIPDIR%%/QtWebKit/qgraphicswebview.sip
+%%PYQT_SIPDIR%%/QtWebKit/qwebdatabase.sip
+%%PYQT_SIPDIR%%/QtWebKit/qwebelement.sip
+%%PYQT_SIPDIR%%/QtWebKit/qwebframe.sip
+%%PYQT_SIPDIR%%/QtWebKit/qwebhistory.sip
+%%PYQT_SIPDIR%%/QtWebKit/qwebhistoryinterface.sip
+%%PYQT_SIPDIR%%/QtWebKit/qwebinspector.sip
+%%PYQT_SIPDIR%%/QtWebKit/qwebkitglobal.sip
+%%PYQT_SIPDIR%%/QtWebKit/qwebkitversion.sip
+%%PYQT_SIPDIR%%/QtWebKit/qwebpage.sip
+%%PYQT_SIPDIR%%/QtWebKit/qwebpluginfactory.sip
+%%PYQT_SIPDIR%%/QtWebKit/qwebsecurityorigin.sip
+%%PYQT_SIPDIR%%/QtWebKit/qwebsettings.sip
+%%PYQT_SIPDIR%%/QtWebKit/qwebview.sip
%%API%%share/qt4/qsci/api/python/QtWebKit.api