summaryrefslogtreecommitdiff
path: root/www/openvrml/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /www/openvrml/Makefile
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadfreebsd-ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Diffstat (limited to 'www/openvrml/Makefile')
-rw-r--r--www/openvrml/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/www/openvrml/Makefile b/www/openvrml/Makefile
index 4d8946e07abb..dfd833fc2868 100644
--- a/www/openvrml/Makefile
+++ b/www/openvrml/Makefile
@@ -30,8 +30,8 @@ USE_JAVA= yes
GNU_CONFIGURE= yes
LIBTOOLFILES= configure mozilla-plugin/configure lib/gtkglext/configure
CONFIGURE_ARGS= --enable-gecko-rpath
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include -I${JAVA_HOME}/include -I${JAVA_HOME}/include/${OPSYS:L}" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -L${JAVA_HOME}/jre/lib/${ARCH}/client ${PTHREAD_LIBS}" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${JAVA_HOME}/include -I${JAVA_HOME}/include/${OPSYS:L}" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${JAVA_HOME}/jre/lib/${ARCH}/client ${PTHREAD_LIBS}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" PTHREAD_LIBS="${PTHREAD_LIBS}" \
LIBS="-lm"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}