summaryrefslogtreecommitdiff
path: root/www/npm
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-07-30 14:11:42 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-07-30 14:11:42 +0000
commit366d52b8b74afcfabae6c1f0d297d85de85445dd (patch)
treeaa517d7e68cab5cfb0fe51aa80bbe079f4f20e00 /www/npm
parentbecf70c763ec05b48b629582065b2ee66764d7f1 (diff)
downloadfreebsd-ports-366d52b8b74afcfabae6c1f0d297d85de85445dd.zip
- Fix shebangs
Approved by: portmgr blanket MFH: 2015Q3 (blanket)
Diffstat (limited to 'www/npm')
-rw-r--r--www/npm/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/www/npm/Makefile b/www/npm/Makefile
index 1e9d57e394e5..8b9c380cebf0 100644
--- a/www/npm/Makefile
+++ b/www/npm/Makefile
@@ -3,6 +3,7 @@
PORTNAME= npm
PORTVERSION= 2.13.2
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= LOCAL/sunpoet
@@ -23,7 +24,13 @@ MAKE_ARGS= npm_config_prefix=${STAGEDIR}${PREFIX}
NO_ARCH= yes
NO_BUILD= yes
REINPLACE_ARGS= -i ''
-USES= cpe python:2 tar:xz
+SHEBANG_FILES= lib/utils/completion.sh \
+ node_modules/request/node_modules/node-uuid/benchmark/bench.sh \
+ scripts/clean-old.sh \
+ scripts/release.sh \
+ scripts/relocate.sh \
+ test/update-test.sh
+USES= cpe python:2 shebangfix tar:xz
MANPREFIX= ${PREFIX}/lib/node_modules/npm