summaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-10 14:35:48 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-10 14:35:48 +0000
commitac049e474e97db8d4ef9070c4dceb6a026d0eb16 (patch)
treeb0ab4c93c23aaa7ea50e9d60f61eea915680c712 /textproc
parent9828a7fc2283f0cb919614b645ee913d5fbc74b7 (diff)
downloadfreebsd-ports-ac049e474e97db8d4ef9070c4dceb6a026d0eb16.zip
- convert to the new perl5 framework
- trim Makefile header Approved by: portmgr (bapt@, blanket)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/p5-ElasticSearch-SearchBuilder/Makefile3
-rw-r--r--textproc/p5-ElasticSearch/Makefile3
-rw-r--r--textproc/p5-String-HexConvert/Makefile3
-rw-r--r--textproc/p5-String-Urandom/Makefile8
-rw-r--r--textproc/p5-texcount/Makefile3
-rw-r--r--textproc/yodl/Makefile9
6 files changed, 13 insertions, 16 deletions
diff --git a/textproc/p5-ElasticSearch-SearchBuilder/Makefile b/textproc/p5-ElasticSearch-SearchBuilder/Makefile
index ab6c93e327e4..4abca56fad78 100644
--- a/textproc/p5-ElasticSearch-SearchBuilder/Makefile
+++ b/textproc/p5-ElasticSearch-SearchBuilder/Makefile
@@ -16,7 +16,8 @@ TEST_DEPENDS= p5-Test-Deep>=:${PORTSDIR}/devel/p5-Test-Deep \
p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
p5-Data-Dump>=0:${PORTSDIR}/devel/p5-Data-Dump
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= ElasticSearch::SearchBuilder.3
diff --git a/textproc/p5-ElasticSearch/Makefile b/textproc/p5-ElasticSearch/Makefile
index 6d4f5e188b7e..b9df7d96d421 100644
--- a/textproc/p5-ElasticSearch/Makefile
+++ b/textproc/p5-ElasticSearch/Makefile
@@ -36,7 +36,8 @@ RUN_DEPENDS:= p5-ElasticSearch-SearchBuilder>=0:${PORTSDIR}/textproc/p5-ElasticS
TEST_DEPENDS= p5-Test-Differences>=0:${PORTSDIR}/devel/p5-Test-Differences \
p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= ElasticSearch.3 \
ElasticSearch::Error.3 \
diff --git a/textproc/p5-String-HexConvert/Makefile b/textproc/p5-String-HexConvert/Makefile
index 1bdad52eaf24..d0f9ff7f1426 100644
--- a/textproc/p5-String-HexConvert/Makefile
+++ b/textproc/p5-String-HexConvert/Makefile
@@ -13,7 +13,8 @@ COMMENT= String::HexConver - Converts ascii strings to hex and reverse
WRKSRC= ${WRKDIR}/${PORTNAME}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= String::HexConvert.3
diff --git a/textproc/p5-String-Urandom/Makefile b/textproc/p5-String-Urandom/Makefile
index 9ba8332b1eda..22816a9c0146 100644
--- a/textproc/p5-String-Urandom/Makefile
+++ b/textproc/p5-String-Urandom/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: String::Urandom
-# Date created: 31 Dec 2011
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= String-Urandom
PORTVERSION= 0.16
@@ -18,7 +13,8 @@ RUN_DEPENDS= \
p5-Params-Validate>0:${PORTSDIR}/devel/p5-Params-Validate
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= String::Urandom.3
diff --git a/textproc/p5-texcount/Makefile b/textproc/p5-texcount/Makefile
index 3d47a8cdf7ab..e14a746d2b37 100644
--- a/textproc/p5-texcount/Makefile
+++ b/textproc/p5-texcount/Makefile
@@ -16,7 +16,8 @@ COMMENT= Perl module for LaTeX statistics
NO_BUILD= yes
USE_ZIP= YES
-USE_PERL5_RUN= YES
+USES= perl5
+USE_PERL5= run
PLIST_FILES+= bin/texcount
diff --git a/textproc/yodl/Makefile b/textproc/yodl/Makefile
index 9e552c468bed..74283389b9d6 100644
--- a/textproc/yodl/Makefile
+++ b/textproc/yodl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: yodl
-# Date created: 22 Oct 1997
-# Whom: Donald Burr <dburr@FreeBSD.org>
-#
+# Created by: Donald Burr <dburr@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= yodl
PORTVERSION= 3.00.0
@@ -22,7 +18,8 @@ BUILD_DEPENDS= icmake:${PORTSDIR}/devel/icmake \
bash:${PORTSDIR}/shells/bash \
gsed:${PORTSDIR}/textproc/gsed
-USE_PERL5_BUILD= yes
+USES= perl5
+USE_PERL5= build
.if !defined(NO_INSTALL_MANPAGES)
MANCOMPRESSED= no