summaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-02-25 15:34:47 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-02-25 15:34:47 +0000
commit5c409b1650aae77f4c1b5511d3bf2d8deb796cb1 (patch)
tree9ea09e19c1a89e9d952841ba422f7a825f30c17c /textproc
parent63dd7e0ac0c6c39121e9e01e22d5a8d2662036bf (diff)
downloadfreebsd-ports-5c409b1650aae77f4c1b5511d3bf2d8deb796cb1.zip
- Fix LIB_DEPENDS
- Use USE_X_PREFIX - Use USE_GNOMELIBS PR: 25327 Submitted by: Ports Fury
Diffstat (limited to 'textproc')
-rw-r--r--textproc/gaspell/Makefile12
-rw-r--r--textproc/gaspell/files/patch-aa13
2 files changed, 14 insertions, 11 deletions
diff --git a/textproc/gaspell/Makefile b/textproc/gaspell/Makefile
index aa0350fd0e94..d07cd8283af3 100644
--- a/textproc/gaspell/Makefile
+++ b/textproc/gaspell/Makefile
@@ -7,20 +7,20 @@
PORTNAME= gaspell
PORTVERSION= 0.30
+PORTREVISION= 1
CATEGORIES= textproc gnome
MASTER_SITES= http://aspell.sourceforge.net/
-DISTNAME= ${PORTNAME}-.30
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/^0//}
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
- aspell.8:${PORTSDIR}/textproc/aspell
-RUN_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
+LIB_DEPENDS= aspell.9:${PORTSDIR}/textproc/aspell
+USE_X_PREFIX= yes
USE_NEWGCC= yes
-ALL_TARGET= gaspell
+USE_GNOMELIBS= yes
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/gaspell ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/gaspell ${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/textproc/gaspell/files/patch-aa b/textproc/gaspell/files/patch-aa
index 1648b90ddd98..cfd34daec759 100644
--- a/textproc/gaspell/files/patch-aa
+++ b/textproc/gaspell/files/patch-aa
@@ -1,16 +1,16 @@
---- Makefile.orig Sun Feb 6 00:26:12 2000
-+++ Makefile Tue Jun 13 16:56:02 2000
-@@ -1,21 +1,21 @@
+--- Makefile.orig Sun Feb 6 15:26:12 2000
++++ Makefile Wed Feb 21 05:03:13 2001
+@@ -1,22 +1,24 @@
# You will need to specify the absolute path if gnome-config is not in
# your path or if the one in your path is not the correct one
-GNOME_CONFIG = gnome-config
-+GNOME_CONFIG = ${X11BASE}/bin/gnome-config
++GNOME_CONFIG ?= gnome-config
# This should be set to where aspell was installed the default is
# /usr/local
-ASPELL_PREFIX = /usr/local
-+ASPELL_PREFIX = ${PREFIX}
++ASPELL_PREFIX = ${LOCALBASE}
-CXX = g++
-CXXFLAGS = -O2 -g
@@ -26,5 +26,8 @@
- -D VERSION=\"$(VERSION)\"
+ -DVERSION=\"$(VERSION)\"
LIBS = -L$(ASPELL_PREFIX)/lib -laspell `$(GNOME_CONFIG) --libs gnomeui`
++
++all: gaspell
gaspell: gaspell.o DICTClient.o
+ $(CXX) gaspell.o DICTClient.o $(LIBS) -o gaspell