summaryrefslogtreecommitdiff
path: root/textproc/scim-openvanilla
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-05-27 08:55:56 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-05-27 08:55:56 +0000
commitd907fad14d62ab041398d5503715645e1def8e4e (patch)
tree9e86444deae73d97252e5e9c4665cf663b841306 /textproc/scim-openvanilla
parent1f81a11d9c419719920349c5c6bb2b843fc7a285 (diff)
downloadfreebsd-ports-d907fad14d62ab041398d5503715645e1def8e4e.zip
- Update to 0.7.2.20070514
- Host distfiles at my place per request from maintainer - Kill reference to X11BASE, now everything in LOCALBASE - Rename patches to match our name convention, also update them if necessary openvanilla-modules: - Add Chewing module scim-openvanilla: - Remove pkg-plist, use PLIST_FILES for small # of files - Remove hack for objformat removal, no longer needed PR: ports/112721 Submitted by: Li-Lun Wang <llwang at infor.org> (maintainer)
Diffstat (limited to 'textproc/scim-openvanilla')
-rw-r--r--textproc/scim-openvanilla/Makefile19
-rw-r--r--textproc/scim-openvanilla/distinfo6
-rw-r--r--textproc/scim-openvanilla/files/patch-src-Makefile.in (renamed from textproc/scim-openvanilla/files/patch-src::Makefile.in)8
-rw-r--r--textproc/scim-openvanilla/pkg-plist4
4 files changed, 18 insertions, 19 deletions
diff --git a/textproc/scim-openvanilla/Makefile b/textproc/scim-openvanilla/Makefile
index f028004294f5..a238b7206934 100644
--- a/textproc/scim-openvanilla/Makefile
+++ b/textproc/scim-openvanilla/Makefile
@@ -6,29 +6,32 @@
#
PORTNAME= scim-openvanilla
-PORTVERSION= 0.7.2.b20060214
-PORTREVISION= 4
+PORTVERSION= 0.7.2.20070514
CATEGORIES= textproc
-MASTER_SITES= http://www.csie.org/~llwang/ \
- http://www.infor.org/~llwang/
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= rafan
DISTNAME= openvanilla-${PORTVERSION}
MAINTAINER= llwang@infor.org
COMMENT= SCIM OpenVanilla input method (IM)/output filter (OF) framework
BUILD_DEPENDS= scim:${PORTSDIR}/textproc/scim \
- ${X11BASE}/include/OpenVanilla/OpenVanilla.h:${PORTSDIR}/textproc/openvanilla-framework
+ ${LOCALBASE}/include/OpenVanilla/OpenVanilla.h:${PORTSDIR}/textproc/openvanilla-framework
RUN_DEPENDS= scim:${PORTSDIR}/textproc/scim
+LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
USE_AUTOTOOLS= libltdl:15
WRKSRC= ${WRKDIR}/${DISTNAME}/Loaders/SCIM
USE_GMAKE= yes
USE_GNOME= pkgconfig
+USE_GETTEXT= yes
+USE_ICONV= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CPPFLAGS=-I${X11BASE}/include \
+CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include \
OV_MODULEDIR=${PREFIX}/lib/openvanilla/
-post-patch:
- @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
+PLIST_FILES= lib/scim-1.0/1.4.0/IMEngine/OVLoader-SCIM.a \
+ lib/scim-1.0/1.4.0/IMEngine/OVLoader-SCIM.la \
+ lib/scim-1.0/1.4.0/IMEngine/OVLoader-SCIM.so
.include <bsd.port.mk>
diff --git a/textproc/scim-openvanilla/distinfo b/textproc/scim-openvanilla/distinfo
index 95c6b291033b..6db7d7486b5e 100644
--- a/textproc/scim-openvanilla/distinfo
+++ b/textproc/scim-openvanilla/distinfo
@@ -1,3 +1,3 @@
-MD5 (openvanilla-0.7.2.b20060214.tar.gz) = d15b76fd77022cc78b660b9a719d17e7
-SHA256 (openvanilla-0.7.2.b20060214.tar.gz) = 9761b42666676ecb5e590b242d09c4e6f538a23608c0262fc02d38821b1d128d
-SIZE (openvanilla-0.7.2.b20060214.tar.gz) = 16777986
+MD5 (openvanilla-0.7.2.20070514.tar.gz) = 1be55a6394a36c1a99158a147c7a2fda
+SHA256 (openvanilla-0.7.2.20070514.tar.gz) = 6dcbb824293c3220a3cf8df4565c371a310f9042f01e63e5c1bfc20ee3e4a4c7
+SIZE (openvanilla-0.7.2.20070514.tar.gz) = 21002095
diff --git a/textproc/scim-openvanilla/files/patch-src::Makefile.in b/textproc/scim-openvanilla/files/patch-src-Makefile.in
index fead3be45bcc..4157e5ed6972 100644
--- a/textproc/scim-openvanilla/files/patch-src::Makefile.in
+++ b/textproc/scim-openvanilla/files/patch-src-Makefile.in
@@ -1,11 +1,11 @@
---- src/Makefile.in.orig Sat Sep 3 12:22:13 2005
-+++ src/Makefile.in Sat Sep 3 13:44:22 2005
-@@ -202,7 +202,7 @@
+--- src/Makefile.in.orig Mon May 14 14:23:30 2007
++++ src/Makefile.in Tue May 15 20:50:22 2007
+@@ -222,7 +222,7 @@
#noinst_HEADERS = scim_chewing_imengine.h scim_chewing_config_entry.h
-moduledir = @SCIM_MODULEDIR@/IMEngine
-+moduledir = ${PREFIX}/lib/scim-1.0/IMEngine
++moduledir = ${PREFIX}/lib/scim-1.0/1.4.0/IMEngine
module_LTLIBRARIES = OVLoader-SCIM.la
OVLoader_SCIM_la_SOURCES = OVLoader-SCIM.cpp
OVLoader_SCIM_la_CFLAGS = @SCIM_CFLAGS@ @SCIM_DEBUG_FLAGS@
diff --git a/textproc/scim-openvanilla/pkg-plist b/textproc/scim-openvanilla/pkg-plist
deleted file mode 100644
index 666252e200d6..000000000000
--- a/textproc/scim-openvanilla/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-lib/scim-1.0/IMEngine/OVLoader-SCIM.a
-lib/scim-1.0/IMEngine/OVLoader-SCIM.la
-lib/scim-1.0/IMEngine/OVLoader-SCIM.so
-@dirrmtry lib/scim-1.0/IMEngine