summaryrefslogtreecommitdiff
path: root/textproc/scim-openvanilla
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-07-26 05:40:22 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-07-26 05:40:22 +0000
commit9346b215f04cc84bbb7125ff2fcf03978f859a21 (patch)
tree73bea5baa559b61c5e812c50ac96fad638950c75 /textproc/scim-openvanilla
parent49ac3accb4fc378c681317849f4ae94655a61423 (diff)
downloadfreebsd-ports-9346b215f04cc84bbb7125ff2fcf03978f859a21.zip
new devel/pkgconf added to replace devel/pkg-config. new version of pkg-config
are no more self hosting so we are stuck with 0.25 version while pkgconf provide the same set of features as 0.27 and a compatible frontend. A symlink to pkg-config has been added for convenience and compatibility This also introduces a new macro to use pkgconf in your ports: USE_PKGCONFIG it can take the following arguments: - yes (meaning build only dep) - build (meaning build only dep) - run (meaning run only dep) - both (meaning run and build dep) From now USE_GNOME= pkgconfig is deprecated in favour of USE_PKGCONFIG The old gnome macro has been modified to use pkgconf but still the sameway: run and build dep to avoid large breakage. While here fix some ports relying on pkg-config but not specifying it, fix some ports broken because testing wrong .pc files, and fix ports using pkg-config --version to determine pkg-config version instead of pkg-config --modversion pkg-config like recommanded by pkg-config With Hat: portmgr Exp-runs by: bapt (pointhat-west), beat (pointyhat)
Diffstat (limited to 'textproc/scim-openvanilla')
-rw-r--r--textproc/scim-openvanilla/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/textproc/scim-openvanilla/Makefile b/textproc/scim-openvanilla/Makefile
index b048ef24f636..3524cb8776c7 100644
--- a/textproc/scim-openvanilla/Makefile
+++ b/textproc/scim-openvanilla/Makefile
@@ -17,8 +17,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= SCIM OpenVanilla input method (IM)/output filter (OF) framework
BUILD_DEPENDS= scim:${PORTSDIR}/textproc/scim \
- ${LOCALBASE}/include/OpenVanilla/OpenVanilla.h:${PORTSDIR}/textproc/openvanilla-framework \
- pkg-config>0:${PORTSDIR}/devel/pkg-config
+ ${LOCALBASE}/include/OpenVanilla/OpenVanilla.h:${PORTSDIR}/textproc/openvanilla-framework
RUN_DEPENDS= scim:${PORTSDIR}/textproc/scim
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
@@ -27,6 +26,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/Loaders/SCIM
USE_GMAKE= yes
USE_GETTEXT= yes
USE_ICONV= yes
+USE_PKGCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= OV_MODULEDIR=${PREFIX}/lib/openvanilla/
CPPFLAGS+= -I${LOCALBASE}/include