summaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-05-15 10:41:21 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-05-15 10:41:21 +0000
commitb03107f88d31f245434fc148de5c69020e62f4ec (patch)
treeb6a409b9bb593b6095faf58489616fb0fb210d1b /sysutils
parent2a30cce248262e373a623d3ecb2eebb2b918124a (diff)
downloadfreebsd-ports-b03107f88d31f245434fc148de5c69020e62f4ec.zip
multimedia/libdvdcss:
- USES=gmake libtool pathfix tar:bzip2. - INSTALL_TARGET=install-strip. - Use options. - Staging. - Simplify post-patch commands. - This update changes the library version but this allows removing libdvdcss related patches from dependent ports. multimedia/libxine: [1] - Add USES=libtool:keepla and remove libtool related patches and post-patch commands. - Move bsd.port.pre.mk include down and remove WANT_GNOME. - Remove USE_XORG=sm. libxine doesn't link to it. - Remove CONFIGURE_ENV. Not needed. - Clean up CPPFLAGS and CFLAGS. - Rename the GTK2 option PIXBUF and depend on gdkpixbuf2 instead of gtk20. - Remove PATCH_DIST_ARGS. Leftover from when there were external patches. - Remove -fno-force-addr clang hack. Modern gcc does not support the flag either and it was only added in case the user has -fforce-addr in CFLAGS in make.conf. - Fix IMAGEMAGICK option. - Merge pre-configure with post-patch and remove most commands because they don't do anything. multimedia/libdvdread: - USES=libtool:oldver pathfix. - INSTALL_TARGET=install-strip. multimedia/handbrake: - Add build dependency on devel/libtool because configure script expects to find existing libtool program. - Turn dependency on libdvdcss into library dependency such that headers are available during build. - Add USES=libtool to patch libtool scripts in contrib code. - Remove run-autotools-aclocal target and replace USE_AUTOTOOLS=aclocal with "autoconf:env automake:env" to indicate only build dependencies are needed and the tools don't have to be run. Approved by: nox [1]
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/dvdvideo/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/sysutils/dvdvideo/Makefile b/sysutils/dvdvideo/Makefile
index 6df16f8eaceb..6a9222e91b1e 100644
--- a/sysutils/dvdvideo/Makefile
+++ b/sysutils/dvdvideo/Makefile
@@ -3,6 +3,7 @@
PORTNAME= dvdvideo
PORTVERSION= 20130117
+PORTREVISION= 1
CATEGORIES= sysutils multimedia
MASTER_SITES= http://contribs.martymac.org/FreeBSD-ports/distfiles/ \
LOCAL/martymac
@@ -24,13 +25,7 @@ OPTIONS_DEFINE= DVDCSS
.if !defined(PACKAGE_BUILDING)
OPTIONS_DEFAULT= DVDCSS
.endif
-DVDCSS_LIB_DEPENDS= libdvdcss.so:${PORTSDIR}/multimedia/libdvdcss
-
# DVDCSS version hardcoded in dvdvideo/libdvdcss.py
-DVDCSS_LIBVERSION= 3
-
-post-patch:
- @${REINPLACE_CMD} -E 's|(libdvdcss.so)\.2|\1.${DVDCSS_LIBVERSION}|' \
- ${WRKSRC}/dvdvideo/libdvdcss.py
+DVDCSS_LIB_DEPENDS= libdvdcss.so.2:${PORTSDIR}/multimedia/libdvdcss
.include <bsd.port.mk>