summaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2000-02-14 01:52:02 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2000-02-14 01:52:02 +0000
commit0a86fb398a4d3bc6192f1102a816e8b4f24e2203 (patch)
tree15ce45ebaeda4082690ef1bd87476a44e5f5986a /security
parente0a9c04a0c5634ad61c8a1d764ba8fed827ad488 (diff)
downloadfreebsd-ports-0a86fb398a4d3bc6192f1102a816e8b4f24e2203.zip
"gag" is a program to scan for "stacheldraht" agents, which are part
of an active "stacheldraht" network. It will not detect trinoo, the original Tribe Flood Network (TFN), or TFN2K agents.
Diffstat (limited to 'security')
-rw-r--r--security/gag/Makefile27
-rw-r--r--security/gag/distinfo1
-rw-r--r--security/gag/files/patch-Makefile12
-rw-r--r--security/gag/pkg-comment1
-rw-r--r--security/gag/pkg-descr13
-rw-r--r--security/gag/pkg-plist1
6 files changed, 55 insertions, 0 deletions
diff --git a/security/gag/Makefile b/security/gag/Makefile
new file mode 100644
index 000000000000..837cae1eb912
--- /dev/null
+++ b/security/gag/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# Ports collection makefile for: gag
+# Version required: 2.9
+# Date created: Sun Feb 12, 2000
+# Whom: David O'Brien (obrien@NUXI.com)
+#
+# $FreeBSD$
+#
+
+DISTNAME= sickenscan
+PKGNAME= gag-2.9
+CATEGORIES= security
+MASTER_SITES= http://staff.washington.edu/dittrich/misc/
+EXTRACT_SUFX= .tar
+
+MAINTAINER= obrien@FreeBSD.org
+
+ALL_TARGET= gag
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/gag ${PREFIX}/sbin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/gag
+ @${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/gag
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/gag/distinfo b/security/gag/distinfo
new file mode 100644
index 000000000000..56f0dc53145d
--- /dev/null
+++ b/security/gag/distinfo
@@ -0,0 +1 @@
+MD5 (sickenscan.tar) = 433feb3ce320b0447afc945fec3a5368
diff --git a/security/gag/files/patch-Makefile b/security/gag/files/patch-Makefile
new file mode 100644
index 000000000000..fae7cfcbeb9d
--- /dev/null
+++ b/security/gag/files/patch-Makefile
@@ -0,0 +1,12 @@
+--- Makefile.orig Mon Jan 10 13:13:12 2000
++++ Makefile Sun Feb 13 17:41:35 2000
+@@ -1,7 +1,7 @@
+-CFLAGS=
++#CFLAGS=
+
+ # For Solaris 2.5.1 and above, uncomment the following line.
+-LIBS=-lresolv -lsocket -lnsl
++#LIBS=-lresolv -lsocket -lnsl
+
+ default:
+ @clear
diff --git a/security/gag/pkg-comment b/security/gag/pkg-comment
new file mode 100644
index 000000000000..e7a441e23d8e
--- /dev/null
+++ b/security/gag/pkg-comment
@@ -0,0 +1 @@
+gag - a stacheldraht (DOS attack) agent detector
diff --git a/security/gag/pkg-descr b/security/gag/pkg-descr
new file mode 100644
index 000000000000..761a16a6613b
--- /dev/null
+++ b/security/gag/pkg-descr
@@ -0,0 +1,13 @@
+"gag" is a program to scan for "stacheldraht" agents, which are part
+of an active "stacheldraht" network. It will not detect trinoo,
+the original Tribe Flood Network (TFN), or TFN2K agents. For methods
+of detecting trinoo and Tribe Flood Network, see:
+
+ http://staff.washington.edu/dittrich/misc/trinoo.analysis
+ http://staff.washington.edu/dittrich/misc/tfn.analysis
+
+(Why "gag"? Its supposed to be a running joke I started in the trinoo
+analysis. trinoo/trinot, "tribe"/civilize, gag/sicken&gesundheit!.
+Read the ddos trilogy to find out!)
+
+WWW: http://www.washington.edu/People/dad/
diff --git a/security/gag/pkg-plist b/security/gag/pkg-plist
new file mode 100644
index 000000000000..bedc3495ed76
--- /dev/null
+++ b/security/gag/pkg-plist
@@ -0,0 +1 @@
+sbin/gag