summaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2020-01-30 14:17:44 +0000
committerSteve Wills <swills@FreeBSD.org>2020-01-30 14:17:44 +0000
commitfb44dca45d6339f4db377f788e4cc5e2bc263609 (patch)
treeba22d2b118e359466f52b8da4aef55f2b8d470fb /science
parentc272497917e602ddcd651a70cbe2520e894afb36 (diff)
downloadfreebsd-ports-fb44dca45d6339f4db377f788e4cc5e2bc263609.zip
Fix math/openblas and bump dependent ports
* Fix build on i386 [1] * Fix science/code_saturne build with new openblas [2] * Avoid installing private headers [3] * Prevent build from optimizing for host by correcting build confg [4] * Bump portrevision of dependent ports [5] This is correcting issues from r523749 [1][2][4] and r515970 [3] PR: 231371 Reported by: build cluster [1] Reported by: Dima Pasechnik <dimpase+freebsd@gmail.com> [2] Reported by: many [5] Reviewed by: mat, bapt Approved by: implicit, since this is a build fix
Diffstat (limited to 'science')
-rw-r--r--science/PETSc/Makefile2
-rw-r--r--science/berkeleygw/Makefile2
-rw-r--r--science/chemps2/Makefile2
-rw-r--r--science/code_saturne/Makefile6
-rw-r--r--science/dalton/Makefile1
-rw-r--r--science/dlib-cpp/Makefile2
-rw-r--r--science/elmerfem/Makefile1
-rw-r--r--science/erkale/Makefile1
-rw-r--r--science/fleur/Makefile2
-rw-r--r--science/gamess-us/Makefile2
-rw-r--r--science/gromacs/Makefile1
-rw-r--r--science/harminv/Makefile2
-rw-r--r--science/hypre/Makefile1
-rw-r--r--science/iboview/Makefile2
-rw-r--r--science/lammps/Makefile1
-rw-r--r--science/latte/Makefile2
-rw-r--r--science/libcint/Makefile1
-rw-r--r--science/mbdyn/Makefile1
-rw-r--r--science/mpqc/Makefile2
-rw-r--r--science/multiwfn/Makefile2
-rw-r--r--science/opensim-core/Makefile2
-rw-r--r--science/py-dlib/Makefile2
-rw-r--r--science/py-gpaw/Makefile2
-rw-r--r--science/py-phono3py/Makefile2
-rw-r--r--science/qmcpack/Makefile2
-rw-r--r--science/simbody/Makefile1
26 files changed, 28 insertions, 19 deletions
diff --git a/science/PETSc/Makefile b/science/PETSc/Makefile
index 628b413af4cc..207766ef16ca 100644
--- a/science/PETSc/Makefile
+++ b/science/PETSc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= PETSc
DISTVERSION= 3.10.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= science devel
MASTER_SITES= http://ftp.mcs.anl.gov/pub/petsc/release-snapshots/
DISTNAME= ${PORTNAME:tl}-${DISTVERSION}
diff --git a/science/berkeleygw/Makefile b/science/berkeleygw/Makefile
index 77103a4daa88..ff965b0fdf5d 100644
--- a/science/berkeleygw/Makefile
+++ b/science/berkeleygw/Makefile
@@ -2,7 +2,7 @@
PORTNAME= BerkeleyGW
DISTVERSION= 2.0.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= science
MASTER_SITES= https://berkeley.box.com/shared/static/
DISTFILES= wkqu37wu77tll53r8t1soe6ozqja67yy.gz
diff --git a/science/chemps2/Makefile b/science/chemps2/Makefile
index b9f94417ba65..b1f286f261de 100644
--- a/science/chemps2/Makefile
+++ b/science/chemps2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= CheMPS2
DISTVERSIONPREFIX= v
DISTVERSION= 1.8.9
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= science
MAINTAINER= yuri@FreeBSD.org
diff --git a/science/code_saturne/Makefile b/science/code_saturne/Makefile
index 4e41e470ec91..0af78afcaf48 100644
--- a/science/code_saturne/Makefile
+++ b/science/code_saturne/Makefile
@@ -4,7 +4,7 @@
PORTNAME= code_saturne
PORTVERSION= 6.0.1
DISTVERSIONPREFIX= v
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science parallel
MAINTAINER= thierry@FreeBSD.org
@@ -45,8 +45,8 @@ OPTIONS_DEFAULT= BATCH BLAS MPI METIS
OPTIONS_RADIO= METIS
OPTIONS_RADIO_METIS= METIS PARMETIS
BLAS_USES= blaslapack
-BLAS_CONFIGURE_ON= --with-blas=yes --with-blas-type=BLAS
-BLAS_LIB_DEPENDS= libcblas.so:math/cblas
+BLAS_CONFIGURE_ON= --with-blas=yes --with-blas-lib=${LOCALBASE}/lib --with-blas-libs=-lopenblas
+BLAS_LIB_DEPENDS= libopenblas.so:math/openblas
BATCH_DESC= Use Torque to submit batches
BATCH_RUN_DEPENDS= pbs-config:sysutils/torque
MPI_LIB_DEPENDS= libmpi.so:net/mpich
diff --git a/science/dalton/Makefile b/science/dalton/Makefile
index 4613ee367049..e1543e7c5586 100644
--- a/science/dalton/Makefile
+++ b/science/dalton/Makefile
@@ -2,6 +2,7 @@
PORTNAME= dalton
DISTVERSION= 2018.2
+PORTREVISION= 1
CATEGORIES= science
MAINTAINER= yuri@FreeBSD.org
diff --git a/science/dlib-cpp/Makefile b/science/dlib-cpp/Makefile
index 5f097dc6f7d8..7afe2d512d9d 100644
--- a/science/dlib-cpp/Makefile
+++ b/science/dlib-cpp/Makefile
@@ -2,7 +2,7 @@
PORTNAME= dlib
DISTVERSION= 19.17
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= science devel math
MASTER_SITES= http://dlib.net/files/
PKGNAMESUFFIX= -cpp
diff --git a/science/elmerfem/Makefile b/science/elmerfem/Makefile
index cc80fca585e5..ab043123fe77 100644
--- a/science/elmerfem/Makefile
+++ b/science/elmerfem/Makefile
@@ -3,6 +3,7 @@
PORTNAME= elmerfem
PORTVERSION= 8.4
+PORTREVISION= 1
DISTVERSIONPREFIX= release-
CATEGORIES= science
diff --git a/science/erkale/Makefile b/science/erkale/Makefile
index 844b8de1038c..85e62897f858 100644
--- a/science/erkale/Makefile
+++ b/science/erkale/Makefile
@@ -2,6 +2,7 @@
PORTNAME= erkale
DISTVERSION= g20200110
+PORTREVISION= 1
CATEGORIES= science
MAINTAINER= yuri@FreeBSD.org
diff --git a/science/fleur/Makefile b/science/fleur/Makefile
index 7b632e3d1f00..5884e3484994 100644
--- a/science/fleur/Makefile
+++ b/science/fleur/Makefile
@@ -2,7 +2,7 @@
PORTNAME= fleur
DISTVERSION= 0.27-3 # Release 3 of Version 0.27
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= science
MASTER_SITES= http://www.flapw.de/pm/uploads/FLEUR/
DISTNAME= fleurMaXR${DISTVERSION:C/.*-//}
diff --git a/science/gamess-us/Makefile b/science/gamess-us/Makefile
index f0b3676e5e7c..5cca0e999d96 100644
--- a/science/gamess-us/Makefile
+++ b/science/gamess-us/Makefile
@@ -2,7 +2,7 @@
PORTNAME= gamess
DISTVERSION= 20181013
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= science
PKGNAMESUFFIX= -us # "US" fork
DISTNAME= gamess-current
diff --git a/science/gromacs/Makefile b/science/gromacs/Makefile
index 332d4b2597ea..0c4154de20ef 100644
--- a/science/gromacs/Makefile
+++ b/science/gromacs/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gromacs
DISTVERSION= 2020
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= ftp://ftp.gromacs.org/pub/gromacs/
diff --git a/science/harminv/Makefile b/science/harminv/Makefile
index 9f1596972bfe..0b5f8e426e98 100644
--- a/science/harminv/Makefile
+++ b/science/harminv/Makefile
@@ -3,7 +3,7 @@
PORTNAME= harminv
PORTVERSION= 1.3.1
-PORTREVISION= 18
+PORTREVISION= 19
CATEGORIES= science
MASTER_SITES= http://ab-initio.mit.edu/harminv/
diff --git a/science/hypre/Makefile b/science/hypre/Makefile
index 9c784879ffd0..ebf6f021d7c3 100644
--- a/science/hypre/Makefile
+++ b/science/hypre/Makefile
@@ -4,6 +4,7 @@
PORTNAME= hypre
DISTVERSIONPREFIX= v
DISTVERSION= 2.18.2
+PORTREVISION= 1
CATEGORIES= science
MAINTAINER= yuri@FreeBSD.org
diff --git a/science/iboview/Makefile b/science/iboview/Makefile
index 324b48f61221..f80b210650e5 100644
--- a/science/iboview/Makefile
+++ b/science/iboview/Makefile
@@ -3,7 +3,7 @@
PORTNAME= iboview
PORTVERSION= 20150427
-PORTREVISION= 20
+PORTREVISION= 21
CATEGORIES= science
MASTER_SITES= http://www.iboview.org/bin/
DISTNAME= ibo-view.20150427
diff --git a/science/lammps/Makefile b/science/lammps/Makefile
index 3bc617fe1550..d7d8b11f45bf 100644
--- a/science/lammps/Makefile
+++ b/science/lammps/Makefile
@@ -2,6 +2,7 @@
PORTNAME= lammps
PORTVERSION= ${GH_TAGNAME:C/(stable|patch)_([0-9]{1,2})([A-Z][a-z][a-z])([0-9]{4})/\4.\3.\2/S/Jan/01/S/Feb/02/S/Mar/03/S/Apr/04/S/May/05/S/Jun/06/S/Jul/07/S/Aug/08/S/Sep/09/S/Oct/10/S/Nov/11/S/Dec/12/}
+PORTREVISION= 1
CATEGORIES= science
MAINTAINER= yuri@FreeBSD.org
diff --git a/science/latte/Makefile b/science/latte/Makefile
index e82b0c9c009b..75445cc95e69 100644
--- a/science/latte/Makefile
+++ b/science/latte/Makefile
@@ -3,7 +3,7 @@
PORTNAME= latte
DISTVERSIONPREFIX= v
DISTVERSION= 1.2.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= science
MAINTAINER= yuri@FreeBSD.org
diff --git a/science/libcint/Makefile b/science/libcint/Makefile
index 1138bd08345e..48ba5b525605 100644
--- a/science/libcint/Makefile
+++ b/science/libcint/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libcint
DISTVERSIONPREFIX= v
DISTVERSION= 3.0.19
+PORTREVISION= 1
CATEGORIES= science
MAINTAINER= yuri@FreeBSD.org
diff --git a/science/mbdyn/Makefile b/science/mbdyn/Makefile
index 3646df4a162f..6dcfe0dd5383 100644
--- a/science/mbdyn/Makefile
+++ b/science/mbdyn/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mbdyn
PORTVERSION= 1.7.3
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= https://www.mbdyn.org/userfiles/downloads/
diff --git a/science/mpqc/Makefile b/science/mpqc/Makefile
index 1af772193b59..d79b9bf271ab 100644
--- a/science/mpqc/Makefile
+++ b/science/mpqc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mpqc
PORTVERSION= 2.3.1
-PORTREVISION= 44
+PORTREVISION= 45
CATEGORIES= science parallel
MASTER_SITES= SF
diff --git a/science/multiwfn/Makefile b/science/multiwfn/Makefile
index 8ea0841221ce..af361041ac96 100644
--- a/science/multiwfn/Makefile
+++ b/science/multiwfn/Makefile
@@ -3,7 +3,7 @@
PORTNAME= multiwfn
DISTVERSIONPREFIX= v
DISTVERSION= 3.4.1-0-14
-PORTREVISION= 3
+PORTREVISION= 4
DISTVERSIONSUFFIX= -ge873677
CATEGORIES= science
diff --git a/science/opensim-core/Makefile b/science/opensim-core/Makefile
index 8571980d59c1..ef0f675ab171 100644
--- a/science/opensim-core/Makefile
+++ b/science/opensim-core/Makefile
@@ -3,7 +3,7 @@
PORTNAME= OpenSim
DISTVERSION= 4.0-601
DISTVERSIONSUFFIX= -ga2574fcda
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science
PKGNAMESUFFIX= -core
diff --git a/science/py-dlib/Makefile b/science/py-dlib/Makefile
index 57772200b0ea..704beac65971 100644
--- a/science/py-dlib/Makefile
+++ b/science/py-dlib/Makefile
@@ -2,7 +2,7 @@
PORTNAME= dlib
DISTVERSION= 19.17
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= science devel math python
MASTER_SITES= http://dlib.net/files/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/science/py-gpaw/Makefile b/science/py-gpaw/Makefile
index a22febd06743..1604f30a1a5d 100644
--- a/science/py-gpaw/Makefile
+++ b/science/py-gpaw/Makefile
@@ -2,7 +2,7 @@
PORTNAME= gpaw
DISTVERSION= 1.5.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/science/py-phono3py/Makefile b/science/py-phono3py/Makefile
index 9b776a9e42a3..febec89d1ff7 100644
--- a/science/py-phono3py/Makefile
+++ b/science/py-phono3py/Makefile
@@ -2,7 +2,7 @@
PORTNAME= phono3py
DISTVERSION= 1.13.3.27
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= science python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/science/qmcpack/Makefile b/science/qmcpack/Makefile
index 75dc621248fb..7fee8b9da918 100644
--- a/science/qmcpack/Makefile
+++ b/science/qmcpack/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qmcpack
DISTVERSIONPREFIX= v
DISTVERSION= 3.8.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= science
MAINTAINER= yuri@FreeBSD.org
diff --git a/science/simbody/Makefile b/science/simbody/Makefile
index 564b6cea86b7..de90dbf818fc 100644
--- a/science/simbody/Makefile
+++ b/science/simbody/Makefile
@@ -3,6 +3,7 @@
PORTNAME= simbody
DISTVERSIONPREFIX= Simbody-
DISTVERSION= 3.7
+PORTREVISION= 1
CATEGORIES= science biology
PATCH_SITES= https://github.com/${PORTNAME}/${PORTNAME}/commit/