summaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-10-13 05:36:02 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-10-13 05:36:02 +0000
commitf15894bbd82c5eda00bba8abc4eeaebbbc7354fb (patch)
tree9c2e8002f02fb1bce7e32cbb84bf339a598da468 /science
parent3839a8ac62a8c85cb658b571177aba5fd604998e (diff)
downloadfreebsd-ports-f15894bbd82c5eda00bba8abc4eeaebbbc7354fb.zip
science/octopus: Update 9.2 -> 10.1
Diffstat (limited to 'science')
-rw-r--r--science/octopus/Makefile18
-rw-r--r--science/octopus/distinfo6
-rw-r--r--science/octopus/files/patch-src_Makefile.in34
-rw-r--r--science/octopus/pkg-plist183
4 files changed, 204 insertions, 37 deletions
diff --git a/science/octopus/Makefile b/science/octopus/Makefile
index b2b58cc979f5..c466d69efa6f 100644
--- a/science/octopus/Makefile
+++ b/science/octopus/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= octopus
-DISTVERSION= 9.2
-PORTREVISION= 1
+DISTVERSION= 10.1
CATEGORIES= science
MASTER_SITES= https://octopus-code.org/download/${DISTVERSION}/
@@ -11,8 +10,6 @@ COMMENT= Scientific program aimed at the ab initio virtual experimentation
LICENSE= GPLv2
-BROKEN= fails to build
-
BUILD_DEPENDS= bash:shells/bash
LIB_DEPENDS= libarpack.so:math/arpack-ng \
libblas.so:math/blas \
@@ -26,25 +23,24 @@ LIB_DEPENDS= libarpack.so:math/arpack-ng \
libpng.so:graphics/png \
libsymspg.so:science/spglib \
libtiff.so:graphics/tiff \
+ libvdwxcfort.so:science/libvdwxc \
libwebp.so:graphics/webp \
- libxc.so:science/libxc
+ libxc.so:science/libxc \
+ libyaml.so:textproc/libyaml
-USES= compiler:c++11-lang fortran gmake jpeg localbase:ldflags perl5 shebangfix
-SHEBANG_FILES= src/fdep/fortran_dependencies.pl
+USES= compiler:c++11-lang fortran gmake jpeg localbase:ldflags perl5 python shebangfix
+SHEBANG_FILES= src/fdep/fortran_dependencies.pl testsuite/performance/create_combinations.py
GNU_CONFIGURE= yes
CONFIGURE_SHELL= ${PREFIX}/bin/bash
USE_CXXSTD= c++11
+LDFLAGS+= -lsymspg
FCFLAGS+= -I${LOCALBASE}/include -ffree-line-length-none
OPTIONS_DEFINE= OPENMP
OPTIONS_DEFAULT= OPENMP
OPENMP_CONFIGURE_ENABLE= openmp
-post-extract: # unbundle spglib, see https://gitlab.com/octopus-code/octopus/issues/124
- @${RM} -r ${WRKSRC}/external_libs/spglib-*
- @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} 's|$$(top_builddir)/external_libs/spglib-1\.9\.9/src/libsymspg\.a|${LOCALBASE}/lib/libsymspg.so|'
-
post-stage: # https://gitlab.com/octopus-code/octopus/issues/108
@${RM} ${STAGEDIR}${PREFIX}/include/yaml.h
diff --git a/science/octopus/distinfo b/science/octopus/distinfo
index cbb2693fd83e..dcc3b94915b2 100644
--- a/science/octopus/distinfo
+++ b/science/octopus/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1586043435
-SHA256 (octopus-9.2.tar.gz) = 85ff24944de5bafdee98acc6fc0b74c80d37b29ab245da6ccc749ab9cc66601a
-SIZE (octopus-9.2.tar.gz) = 49783044
+TIMESTAMP = 1602561729
+SHA256 (octopus-10.1.tar.gz) = b6a660a99ed593c1d491e2d11cfff9ce87f0d80d527d9ff47fd983533d45adc6
+SIZE (octopus-10.1.tar.gz) = 50077848
diff --git a/science/octopus/files/patch-src_Makefile.in b/science/octopus/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..f0bf04bd7d95
--- /dev/null
+++ b/science/octopus/files/patch-src_Makefile.in
@@ -0,0 +1,34 @@
+--- src/Makefile.in.orig 2020-10-13 04:32:13 UTC
++++ src/Makefile.in
+@@ -269,7 +269,6 @@ oct_casida_spectrum_OBJECTS = $(am_oct_casida_spectrum
+ am__DEPENDENCIES_1 =
+ @COMPILE_OPENCL_TRUE@am__DEPENDENCIES_2 = $(top_builddir)/external_libs/fortrancl/libfortrancl.a
+ am__DEPENDENCIES_3 = $(top_builddir)/external_libs/qshep/libqshep.a \
+- $(top_builddir)/external_libs/spglib-1.9.9/src/libsymspg.a \
+ $(top_builddir)/external_libs/bpdn/libbpdn.a \
+ $(top_builddir)/external_libs/dftd3/libdftd3.a \
+ $(am__DEPENDENCIES_2) $(am__append_3) $(am__append_5)
+@@ -852,7 +851,6 @@ top_srcdir = @top_srcdir@
+ # we should not have libyaml here if we used an external one...
+ FCFLAGS_MODS = @F90_MODULE_FLAG@$(top_builddir)/external_libs/bpdn \
+ @F90_MODULE_FLAG@$(top_builddir)/external_libs/dftd3 \
+- @F90_MODULE_FLAG@$(top_builddir)/external_libs/spglib-1.9.9/src/ \
+ @FCFLAGS_LIBXC@ @FCFLAGS_PSPIO@ @FCFLAGS_PSOLVER@ \
+ @FCFLAGS_ISF@ @FCFLAGS_FUTILE@ @FCFLAGS_FFTW@ @FCFLAGS_PFFT@ \
+ @FCFLAGS_PNFFT@ @FCFLAGS_NETCDF@ @FCFLAGS_ETSF_IO@ \
+@@ -861,7 +859,6 @@ FCFLAGS_MODS = @F90_MODULE_FLAG@$(top_builddir)/extern
+ $(am__append_2)
+ AM_CPPFLAGS = -I$(top_srcdir)/src/include \
+ -I$(top_builddir)/src/include \
+- -I$(top_srcdir)/external_libs/spglib-1.9.9/src \
+ -I$(top_srcdir)/liboct_parser $(GSL_CFLAGS) $(GD_CFLAGS) \
+ @METIS_CFLAGS@ @PARMETIS_CFLAGS@ @CFLAGS_NFFT@ @CFLAGS_FFTW@ \
+ @CFLAGS_CUDA@ -DSHARE_DIR='"$(pkgdatadir)"' $(am__append_4)
+@@ -881,7 +878,6 @@ core_LIBS = \
+ @GSL_LIBS@ @LIBS_LIBXC@ @FCEXTRALIBS@
+
+ external_LIBS = $(top_builddir)/external_libs/qshep/libqshep.a \
+- $(top_builddir)/external_libs/spglib-1.9.9/src/libsymspg.a \
+ $(top_builddir)/external_libs/bpdn/libbpdn.a \
+ $(top_builddir)/external_libs/dftd3/libdftd3.a $(am__append_1) \
+ $(am__append_3) $(am__append_5)
diff --git a/science/octopus/pkg-plist b/science/octopus/pkg-plist
index 26d6ce379afd..f31e69f87bb6 100644
--- a/science/octopus/pkg-plist
+++ b/science/octopus/pkg-plist
@@ -1,3 +1,4 @@
+bin/create_combinations.py
bin/oct-analyze_projections
bin/oct-atomic_occupations
bin/oct-casida_spectrum
@@ -15,11 +16,15 @@ bin/oct-local_multipoles
bin/oct-oscillator-strength
bin/oct-photoelectron_spectrum
bin/oct-propagation_spectrum
+bin/oct-run_performance_testsuite.sh
bin/oct-run_periodic_table
bin/oct-run_regression_test.pl
bin/oct-run_testsuite.sh
+bin/oct-spin_susceptibility
+bin/oct-unfold
bin/oct-vdW_c6
bin/oct-vibrational_spectrum
+bin/oct-wannier90
bin/oct-xyz-anim
bin/octopus
include/liboct_parser.h
@@ -37,11 +42,14 @@ man/man1/oct-vibrational_spectrum.1.gz
man/man1/oct-xyz-anim.1.gz
man/man1/octopus.1.gz
%%DATADIR%%/dftd3/pars.dat
+%%DATADIR%%/doc/vars/Atomic_Orbitals.html
%%DATADIR%%/doc/vars/Calculation_Modes.html
+%%DATADIR%%/doc/vars/ClassicalParticles.html
%%DATADIR%%/doc/vars/Execution.html
%%DATADIR%%/doc/vars/Hamiltonian.html
%%DATADIR%%/doc/vars/Linear_Response.html
%%DATADIR%%/doc/vars/Math.html
+%%DATADIR%%/doc/vars/MaxwellStates.html
%%DATADIR%%/doc/vars/Mesh.html
%%DATADIR%%/doc/vars/Output.html
%%DATADIR%%/doc/vars/SCF.html
@@ -83,20 +91,26 @@ man/man1/octopus.1.gz
%%DATADIR%%/opencl/convert.cl
%%DATADIR%%/opencl/copy.cl
%%DATADIR%%/opencl/cuda_compat.h
+%%DATADIR%%/opencl/curl.cl
%%DATADIR%%/opencl/density.cl
%%DATADIR%%/opencl/forces.cl
%%DATADIR%%/opencl/mesh_batch.cl
+%%DATADIR%%/opencl/mesh_batch_single.cl
%%DATADIR%%/opencl/mesh_to_cube.cl
+%%DATADIR%%/opencl/mod_sqr.cl
%%DATADIR%%/opencl/mul.cl
%%DATADIR%%/opencl/operate.cl
%%DATADIR%%/opencl/pack.cl
%%DATADIR%%/opencl/phase.cl
+%%DATADIR%%/opencl/phase_spiral.cl
%%DATADIR%%/opencl/points.cl
%%DATADIR%%/opencl/projector.cl
%%DATADIR%%/opencl/rotate.cl
+%%DATADIR%%/opencl/set_one.cl
%%DATADIR%%/opencl/set_zero.cl
%%DATADIR%%/opencl/subarray.cl
%%DATADIR%%/opencl/trsm.cl
+%%DATADIR%%/opencl/uvw_to_xyz.cl
%%DATADIR%%/opencl/vpsi.cl
%%DATADIR%%/pseudopotentials/HGH/lda/Ag.hgh
%%DATADIR%%/pseudopotentials/HGH/lda/Al.hgh
@@ -1011,6 +1025,8 @@ man/man1/octopus.1.gz
%%DATADIR%%/testsuite/components/02-derivatives_2d.01.inp
%%DATADIR%%/testsuite/components/02-derivatives_2d.test
%%DATADIR%%/testsuite/components/03-derivatives_3d.01.inp
+%%DATADIR%%/testsuite/components/03-derivatives_3d.02-non-orthogonal.inp
+%%DATADIR%%/testsuite/components/03-derivatives_3d.02-non-orthogonal_unpacked.inp
%%DATADIR%%/testsuite/components/03-derivatives_3d.test
%%DATADIR%%/testsuite/components/04-hartree_3d_cg.01-cg_corrected.inp
%%DATADIR%%/testsuite/components/04-hartree_3d_cg.test
@@ -1044,9 +1060,9 @@ man/man1/octopus.1.gz
%%DATADIR%%/testsuite/components/15-cholesky_parallel.01-real.inp
%%DATADIR%%/testsuite/components/15-cholesky_parallel.02-complex.inp
%%DATADIR%%/testsuite/components/15-cholesky_parallel.test
-%%DATADIR%%/testsuite/components/16-hartree_3d_libisf.01-libisf.inp
-%%DATADIR%%/testsuite/components/16-hartree_3d_libisf.02-libisf.inp
-%%DATADIR%%/testsuite/components/16-hartree_3d_libisf.test
+%%DATADIR%%/testsuite/components/16-hartree_3d_psolver.01-psolver.inp
+%%DATADIR%%/testsuite/components/16-hartree_3d_psolver.02-psolver.inp
+%%DATADIR%%/testsuite/components/16-hartree_3d_psolver.test
%%DATADIR%%/testsuite/components/17-recipe.inp
%%DATADIR%%/testsuite/components/17-recipe.test
%%DATADIR%%/testsuite/components/18-interpolation.01-1d.inp
@@ -1059,6 +1075,20 @@ man/man1/octopus.1.gz
%%DATADIR%%/testsuite/components/20-dft_u.test
%%DATADIR%%/testsuite/components/21-hamiltonian_apply.01-Si.inp
%%DATADIR%%/testsuite/components/21-hamiltonian_apply.test
+%%DATADIR%%/testsuite/components/22-density_calc.01-Si.inp
+%%DATADIR%%/testsuite/components/22-density_calc.test
+%%DATADIR%%/testsuite/components/23-exponential_apply.01-jellium.inp
+%%DATADIR%%/testsuite/components/23-exponential_apply.test
+%%DATADIR%%/testsuite/components/24-boundaries.01-jellium.inp
+%%DATADIR%%/testsuite/components/24-boundaries.test
+%%DATADIR%%/testsuite/components/25-subspace.01-jellium.inp
+%%DATADIR%%/testsuite/components/25-subspace.test
+%%DATADIR%%/testsuite/components/26-batch_ops.01-jellium.inp
+%%DATADIR%%/testsuite/components/26-batch_ops.02-jellium-complex.inp
+%%DATADIR%%/testsuite/components/26-batch_ops.03-jellium-spinor.inp
+%%DATADIR%%/testsuite/components/26-batch_ops.test
+%%DATADIR%%/testsuite/components/27-clock.01.inp
+%%DATADIR%%/testsuite/components/27-clock.test
%%DATADIR%%/testsuite/finite_systems_1d/01-hydrogen.01-ground_state.inp
%%DATADIR%%/testsuite/finite_systems_1d/01-hydrogen.02-excited_state.inp
%%DATADIR%%/testsuite/finite_systems_1d/01-hydrogen.03-dummy.inp
@@ -1067,6 +1097,8 @@ man/man1/octopus.1.gz
%%DATADIR%%/testsuite/finite_systems_1d/02-neon_mpi.02-ground_state-kli_par_domains.inp
%%DATADIR%%/testsuite/finite_systems_1d/02-neon_mpi.03-td_calc-kli_par_states.inp
%%DATADIR%%/testsuite/finite_systems_1d/02-neon_mpi.test
+%%DATADIR%%/testsuite/finite_systems_1d/03-He-Hartree-Fock.01-gs.inp
+%%DATADIR%%/testsuite/finite_systems_1d/03-He-Hartree-Fock.test
%%DATADIR%%/testsuite/finite_systems_1d/09-morse.01-gs.inp
%%DATADIR%%/testsuite/finite_systems_1d/09-morse.02-unocc.inp
%%DATADIR%%/testsuite/finite_systems_1d/09-morse.03-td.inp
@@ -1097,6 +1129,8 @@ man/man1/octopus.1.gz
%%DATADIR%%/testsuite/finite_systems_3d/01-carbon_atom.01-psf_l0.inp
%%DATADIR%%/testsuite/finite_systems_3d/01-carbon_atom.02-psf_l1.inp
%%DATADIR%%/testsuite/finite_systems_3d/01-carbon_atom.03-ground_state_double_grid.inp
+%%DATADIR%%/testsuite/finite_systems_3d/01-carbon_atom.04-static_field.inp
+%%DATADIR%%/testsuite/finite_systems_3d/01-carbon_atom.05-smear.inp
%%DATADIR%%/testsuite/finite_systems_3d/01-carbon_atom.test
%%DATADIR%%/testsuite/finite_systems_3d/02-curvilinear_coordinates.01-gygi.inp
%%DATADIR%%/testsuite/finite_systems_3d/02-curvilinear_coordinates.test
@@ -1145,6 +1179,8 @@ man/man1/octopus.1.gz
%%DATADIR%%/testsuite/finite_systems_3d/13-full_potential_hydrogen.02-gs-cg.inp
%%DATADIR%%/testsuite/finite_systems_3d/13-full_potential_hydrogen.test
%%DATADIR%%/testsuite/finite_systems_3d/14-fullerene_unpacked.01-gs.inp
+%%DATADIR%%/testsuite/finite_systems_3d/14-fullerene_unpacked.02-td-unpacked.inp
+%%DATADIR%%/testsuite/finite_systems_3d/14-fullerene_unpacked.03-td-packed.inp
%%DATADIR%%/testsuite/finite_systems_3d/14-fullerene_unpacked.test
%%DATADIR%%/testsuite/finite_systems_3d/15-fullerene_stdlcao.01-gs.inp
%%DATADIR%%/testsuite/finite_systems_3d/15-fullerene_stdlcao.test
@@ -1163,6 +1199,7 @@ man/man1/octopus.1.gz
%%DATADIR%%/testsuite/finite_systems_3d/20-eigensolver.05-evolution.inp
%%DATADIR%%/testsuite/finite_systems_3d/20-eigensolver.06-rmmdiis.inp
%%DATADIR%%/testsuite/finite_systems_3d/20-eigensolver.07-psd.inp
+%%DATADIR%%/testsuite/finite_systems_3d/20-eigensolver.08-rmmdiis-noscalapack.inp
%%DATADIR%%/testsuite/finite_systems_3d/20-eigensolver.test
%%DATADIR%%/testsuite/finite_systems_3d/21-lobpcg.01-spin_polarized.inp
%%DATADIR%%/testsuite/finite_systems_3d/21-lobpcg.02-spinors.inp
@@ -1184,8 +1221,10 @@ man/man1/octopus.1.gz
%%DATADIR%%/testsuite/finite_systems_3d/25-multiresolution.test
%%DATADIR%%/testsuite/finite_systems_3d/27-fine_mesh.01-gs.inp
%%DATADIR%%/testsuite/finite_systems_3d/27-fine_mesh.test
-%%DATADIR%%/testsuite/finite_systems_3d/29-pcm_chlorine_anion.01-ground_state.inp
-%%DATADIR%%/testsuite/finite_systems_3d/29-pcm_chlorine_anion.02-td_prop.inp
+%%DATADIR%%/testsuite/finite_systems_3d/29-pcm_chlorine_anion.01-ground_state-n60.inp
+%%DATADIR%%/testsuite/finite_systems_3d/29-pcm_chlorine_anion.02-td_prop-n60.inp
+%%DATADIR%%/testsuite/finite_systems_3d/29-pcm_chlorine_anion.03-ground_state-n60-poisson.inp
+%%DATADIR%%/testsuite/finite_systems_3d/29-pcm_chlorine_anion.04-ground_state-n240.inp
%%DATADIR%%/testsuite/finite_systems_3d/29-pcm_chlorine_anion.test
%%DATADIR%%/testsuite/finite_systems_3d/30-local_multipoles.01-gs.inp
%%DATADIR%%/testsuite/finite_systems_3d/30-local_multipoles.02-multipoles.inp
@@ -1193,13 +1232,21 @@ man/man1/octopus.1.gz
%%DATADIR%%/testsuite/finite_systems_3d/31-acetylene_b3lyp.01-gs.inp
%%DATADIR%%/testsuite/finite_systems_3d/31-acetylene_b3lyp.test
%%DATADIR%%/testsuite/finite_systems_3d/32-tdpcm_methane.01-ground_state.inp
-%%DATADIR%%/testsuite/finite_systems_3d/32-tdpcm_methane.02-td_prop_noneq.inp
+%%DATADIR%%/testsuite/finite_systems_3d/32-tdpcm_methane.02-td_prop_neq.inp
%%DATADIR%%/testsuite/finite_systems_3d/32-tdpcm_methane.03-td_prop_eom.inp
%%DATADIR%%/testsuite/finite_systems_3d/32-tdpcm_methane.test
%%DATADIR%%/testsuite/finite_systems_3d/33-cg.01-orthogonalize_all.inp
%%DATADIR%%/testsuite/finite_systems_3d/33-cg.02-additional_terms.inp
%%DATADIR%%/testsuite/finite_systems_3d/33-cg.03-cg_direction.inp
%%DATADIR%%/testsuite/finite_systems_3d/33-cg.test
+%%DATADIR%%/testsuite/finite_systems_3d/34-walltime.01-gs_walltime.inp
+%%DATADIR%%/testsuite/finite_systems_3d/34-walltime.02-restart_gs.inp
+%%DATADIR%%/testsuite/finite_systems_3d/34-walltime.03-td_walltime.inp
+%%DATADIR%%/testsuite/finite_systems_3d/34-walltime.04-restart_td.inp
+%%DATADIR%%/testsuite/finite_systems_3d/34-walltime.test
+%%DATADIR%%/testsuite/finite_systems_3d/35-slater_x.01-gs.inp
+%%DATADIR%%/testsuite/finite_systems_3d/35-slater_x.02-gs_spinors.inp
+%%DATADIR%%/testsuite/finite_systems_3d/35-slater_x.test
%%DATADIR%%/testsuite/functionals/01-xc_1d.01-wfs-lda.inp
%%DATADIR%%/testsuite/functionals/01-xc_1d.02-wfs-hf.inp
%%DATADIR%%/testsuite/functionals/01-xc_1d.lda_csc.inp
@@ -1283,9 +1330,11 @@ man/man1/octopus.1.gz
%%DATADIR%%/testsuite/functionals/03-xc.lda_c_xalpha.inp
%%DATADIR%%/testsuite/functionals/03-xc.lda_x.inp
%%DATADIR%%/testsuite/functionals/03-xc.lda_xc_teter93.inp
+%%DATADIR%%/testsuite/functionals/03-xc.mvorb_hse06_fock.inp
%%DATADIR%%/testsuite/functionals/03-xc.pbe0_fock.inp
%%DATADIR%%/testsuite/functionals/03-xc.pbe0_oep.inp
%%DATADIR%%/testsuite/functionals/03-xc.sic_pz.inp
+%%DATADIR%%/testsuite/functionals/03-xc.slater.inp
%%DATADIR%%/testsuite/functionals/03-xc.test
%%DATADIR%%/testsuite/functionals/04-oep.01-jellium-lsda.inp
%%DATADIR%%/testsuite/functionals/04-oep.02-jellium-exx_kli.inp
@@ -1295,8 +1344,8 @@ man/man1/octopus.1.gz
%%DATADIR%%/testsuite/functionals/05-ks_inversion.02-two_particle.inp
%%DATADIR%%/testsuite/functionals/05-ks_inversion.03-inversion.inp
%%DATADIR%%/testsuite/functionals/05-ks_inversion.test
-%%DATADIR%%/testsuite/functionals/06-rdmft.01-lda.inp
-%%DATADIR%%/testsuite/functionals/06-rdmft.02-gs.inp
+%%DATADIR%%/testsuite/functionals/06-rdmft.01-ip.inp
+%%DATADIR%%/testsuite/functionals/06-rdmft.02-gs_basis.inp
%%DATADIR%%/testsuite/functionals/06-rdmft.03-gs_grid.inp
%%DATADIR%%/testsuite/functionals/06-rdmft.test
%%DATADIR%%/testsuite/functionals/07-sic.01-gs.inp
@@ -1318,7 +1367,21 @@ man/man1/octopus.1.gz
%%DATADIR%%/testsuite/functionals/13-libvdwxc_h2o.test
%%DATADIR%%/testsuite/functionals/14-libvdwxc_Be_hcp.01-vdwdfcx.inp
%%DATADIR%%/testsuite/functionals/14-libvdwxc_Be_hcp.test
+%%DATADIR%%/testsuite/functionals/15-oep-CG.01-kli.inp
+%%DATADIR%%/testsuite/functionals/15-oep-CG.02-oep-bb.inp
+%%DATADIR%%/testsuite/functionals/15-oep-CG.test
+%%DATADIR%%/testsuite/functionals/16-dressed-rdmft.01-ip.inp
+%%DATADIR%%/testsuite/functionals/16-dressed-rdmft.02-hf.inp
+%%DATADIR%%/testsuite/functionals/16-dressed-rdmft.03-rdmft.inp
+%%DATADIR%%/testsuite/functionals/16-dressed-rdmft.test
+%%DATADIR%%/testsuite/functionals/17-oep-photons.01-kli-spinpolarized.inp
+%%DATADIR%%/testsuite/functionals/17-oep-photons.02-kli.inp
+%%DATADIR%%/testsuite/functionals/17-oep-photons.03-oep.inp
+%%DATADIR%%/testsuite/functionals/17-oep-photons.test
+%%DATADIR%%/testsuite/functionals/18-mgga.01-br89.inp
+%%DATADIR%%/testsuite/functionals/18-mgga.test
%%DATADIR%%/testsuite/lda_u/01-nio.01-U5-gs.inp
+%%DATADIR%%/testsuite/lda_u/01-nio.02-unocc.inp
%%DATADIR%%/testsuite/lda_u/01-nio.test
%%DATADIR%%/testsuite/lda_u/02-ACBN0.01-nio.inp
%%DATADIR%%/testsuite/lda_u/02-ACBN0.02-lif.inp
@@ -1340,11 +1403,16 @@ man/man1/octopus.1.gz
%%DATADIR%%/testsuite/lda_u/07-noncollinear.02-acbn0.inp
%%DATADIR%%/testsuite/lda_u/07-noncollinear.test
%%DATADIR%%/testsuite/lda_u/08-loewdin.01-Si.inp
+%%DATADIR%%/testsuite/lda_u/08-loewdin.02-intersite.inp
+%%DATADIR%%/testsuite/lda_u/08-loewdin.03-intersite_domains.inp
%%DATADIR%%/testsuite/lda_u/08-loewdin.test
%%DATADIR%%/testsuite/lda_u/09-basis_from_states.01-lda.inp
%%DATADIR%%/testsuite/lda_u/09-basis_from_states.02-acbn0.inp
%%DATADIR%%/testsuite/lda_u/09-basis_from_states.fhi
%%DATADIR%%/testsuite/lda_u/09-basis_from_states.test
+%%DATADIR%%/testsuite/lda_u/10-intersite.01-Na2.inp
+%%DATADIR%%/testsuite/lda_u/10-intersite.02-graphite.inp
+%%DATADIR%%/testsuite/lda_u/10-intersite.test
%%DATADIR%%/testsuite/linear_response/01-casida.01-gs.inp
%%DATADIR%%/testsuite/linear_response/01-casida.012-vib_modes.inp
%%DATADIR%%/testsuite/linear_response/01-casida.02-unocc.inp
@@ -1373,6 +1441,29 @@ man/man1/octopus.1.gz
%%DATADIR%%/testsuite/linear_response/06-vib_modes_fd.01-ground_state.inp
%%DATADIR%%/testsuite/linear_response/06-vib_modes_fd.01-vib_modes_fd.inp
%%DATADIR%%/testsuite/linear_response/06-vib_modes_fd.test
+%%DATADIR%%/testsuite/maxwell/01-free-propagation.01-1_pulse_td.inp
+%%DATADIR%%/testsuite/maxwell/01-free-propagation.02-2_pulses_td.inp
+%%DATADIR%%/testsuite/maxwell/01-free-propagation.test
+%%DATADIR%%/testsuite/multisystem/01-nested_systems.01-two_levels.inp
+%%DATADIR%%/testsuite/multisystem/01-nested_systems.02-three_levels.inp
+%%DATADIR%%/testsuite/multisystem/01-nested_systems.03-four_levels.inp
+%%DATADIR%%/testsuite/multisystem/01-nested_systems.test
+%%DATADIR%%/testsuite/multisystem/02-interaction_graph.01-three_body.inp
+%%DATADIR%%/testsuite/multisystem/02-interaction_graph.test
+%%DATADIR%%/testsuite/multisystem/03-propagation_verlet.01-two_body.inp
+%%DATADIR%%/testsuite/multisystem/03-propagation_verlet.02-three_body.inp
+%%DATADIR%%/testsuite/multisystem/03-propagation_verlet.03-two_body_different_time_steps.inp
+%%DATADIR%%/testsuite/multisystem/03-propagation_verlet.04-three_body_different_time_steps.inp
+%%DATADIR%%/testsuite/multisystem/03-propagation_verlet.test
+%%DATADIR%%/testsuite/multisystem/04-propagation_beeman.01-two_body.inp
+%%DATADIR%%/testsuite/multisystem/04-propagation_beeman.02-three_body.inp
+%%DATADIR%%/testsuite/multisystem/04-propagation_beeman.03-two_body_different_time_steps.inp
+%%DATADIR%%/testsuite/multisystem/04-propagation_beeman.04-three_body_different_time_steps.inp
+%%DATADIR%%/testsuite/multisystem/04-propagation_beeman.test
+%%DATADIR%%/testsuite/multisystem/99-carbon_hydrogen.01-gs.inp
+%%DATADIR%%/testsuite/multisystem/99-carbon_hydrogen.02-td.inp
+%%DATADIR%%/testsuite/multisystem/99-carbon_hydrogen.03-td_restart.inp
+%%DATADIR%%/testsuite/multisystem/99-carbon_hydrogen.test
%%DATADIR%%/testsuite/optimal_control/01-asym_doublewell.01-ground_state.inp
%%DATADIR%%/testsuite/optimal_control/01-asym_doublewell.02-unocc.inp
%%DATADIR%%/testsuite/optimal_control/01-asym_doublewell.03-oct_run.inp
@@ -1421,6 +1512,7 @@ man/man1/octopus.1.gz
%%DATADIR%%/testsuite/optimal_control/10-current.test
%%DATADIR%%/testsuite/optimal_control/11-classical.01-ground_state.inp
%%DATADIR%%/testsuite/optimal_control/11-classical.02-oct.inp
+%%DATADIR%%/testsuite/optimal_control/11-classical.03-oct_taylor.inp
%%DATADIR%%/testsuite/optimal_control/11-classical.test
%%DATADIR%%/testsuite/optimal_control/12-spintarget.01-ground_state.inp
%%DATADIR%%/testsuite/optimal_control/12-spintarget.02-oct.inp
@@ -1428,6 +1520,22 @@ man/man1/octopus.1.gz
%%DATADIR%%/testsuite/optimal_control/13-box-nlopt.03-bobyqa.inp
%%DATADIR%%/testsuite/optimal_control/13-box-nlopt.04-lbfgs.inp
%%DATADIR%%/testsuite/optimal_control/13-box-nlopt.test
+%%DATADIR%%/testsuite/performance/Makefile.performance
+%%DATADIR%%/testsuite/performance/compare_results.py
+%%DATADIR%%/testsuite/performance/tests/batch_ops.combinations.yaml
+%%DATADIR%%/testsuite/performance/tests/batch_ops.inp
+%%DATADIR%%/testsuite/performance/tests/boundaries.combinations.yaml
+%%DATADIR%%/testsuite/performance/tests/boundaries.inp
+%%DATADIR%%/testsuite/performance/tests/density_calc.combinations.yaml
+%%DATADIR%%/testsuite/performance/tests/density_calc.inp
+%%DATADIR%%/testsuite/performance/tests/exponential_apply.combinations.yaml
+%%DATADIR%%/testsuite/performance/tests/exponential_apply.inp
+%%DATADIR%%/testsuite/performance/tests/hamiltonian_apply.combinations.yaml
+%%DATADIR%%/testsuite/performance/tests/hamiltonian_apply.inp
+%%DATADIR%%/testsuite/performance/tests/orthogonalization.combinations.yaml
+%%DATADIR%%/testsuite/performance/tests/orthogonalization.inp
+%%DATADIR%%/testsuite/performance/tests/subspace_diag.combinations.yaml
+%%DATADIR%%/testsuite/performance/tests/subspace_diag.inp
%%DATADIR%%/testsuite/periodic_systems/01-free_electrons.01-ground_state.inp
%%DATADIR%%/testsuite/periodic_systems/01-free_electrons.02-unocc.inp
%%DATADIR%%/testsuite/periodic_systems/01-free_electrons.test
@@ -1475,14 +1583,20 @@ man/man1/octopus.1.gz
%%DATADIR%%/testsuite/periodic_systems/12-boron_nitride.test
%%DATADIR%%/testsuite/periodic_systems/13-primitive.01-diamond.inp
%%DATADIR%%/testsuite/periodic_systems/13-primitive.02-graphene.inp
+%%DATADIR%%/testsuite/periodic_systems/13-primitive.03-bcc_iron.inp
%%DATADIR%%/testsuite/periodic_systems/13-primitive.test
%%DATADIR%%/testsuite/periodic_systems/14-silicon_shifts.01-gs.inp
%%DATADIR%%/testsuite/periodic_systems/14-silicon_shifts.02-td.inp
-%%DATADIR%%/testsuite/periodic_systems/14-silicon_shifts.03-delayed_kick.inp
-%%DATADIR%%/testsuite/periodic_systems/14-silicon_shifts.04-dielectric_function.inp
+%%DATADIR%%/testsuite/periodic_systems/14-silicon_shifts.03-td_parstates.inp
+%%DATADIR%%/testsuite/periodic_systems/14-silicon_shifts.04-delayed_kick.inp
+%%DATADIR%%/testsuite/periodic_systems/14-silicon_shifts.05-dielectric_function.inp
%%DATADIR%%/testsuite/periodic_systems/14-silicon_shifts.test
%%DATADIR%%/testsuite/periodic_systems/15-bandstructure.01-gs.inp
%%DATADIR%%/testsuite/periodic_systems/15-bandstructure.02-unocc.inp
+%%DATADIR%%/testsuite/periodic_systems/15-bandstructure.03-wannier90_setup.inp
+%%DATADIR%%/testsuite/periodic_systems/15-bandstructure.04-wannier90.nnkp
+%%DATADIR%%/testsuite/periodic_systems/15-bandstructure.04-wannier90.win
+%%DATADIR%%/testsuite/periodic_systems/15-bandstructure.04-wannier90_output.inp
%%DATADIR%%/testsuite/periodic_systems/15-bandstructure.test
%%DATADIR%%/testsuite/periodic_systems/16-sodium_chain_cylinder.01-ground_state.inp
%%DATADIR%%/testsuite/periodic_systems/16-sodium_chain_cylinder.02-unocc.inp
@@ -1491,7 +1605,20 @@ man/man1/octopus.1.gz
%%DATADIR%%/testsuite/periodic_systems/16-sodium_chain_cylinder.test
%%DATADIR%%/testsuite/periodic_systems/17-aluminium.01-gs.inp
%%DATADIR%%/testsuite/periodic_systems/17-aluminium.02-td.inp
+%%DATADIR%%/testsuite/periodic_systems/17-aluminium.03-conductivity.inp
%%DATADIR%%/testsuite/periodic_systems/17-aluminium.test
+%%DATADIR%%/testsuite/periodic_systems/18-TiO2.01-gs.inp
+%%DATADIR%%/testsuite/periodic_systems/18-TiO2.test
+%%DATADIR%%/testsuite/periodic_systems/19-unfolding.01-gs.inp
+%%DATADIR%%/testsuite/periodic_systems/19-unfolding.02-setup.inp
+%%DATADIR%%/testsuite/periodic_systems/19-unfolding.03-unocc.inp
+%%DATADIR%%/testsuite/periodic_systems/19-unfolding.04-run.inp
+%%DATADIR%%/testsuite/periodic_systems/19-unfolding.test
+%%DATADIR%%/testsuite/periodic_systems/20-masked_periodic_boundaries.01-graphene.inp
+%%DATADIR%%/testsuite/periodic_systems/20-masked_periodic_boundaries.test
+%%DATADIR%%/testsuite/periodic_systems/21-magnon.01-gs.inp
+%%DATADIR%%/testsuite/periodic_systems/21-magnon.02-td.inp
+%%DATADIR%%/testsuite/periodic_systems/21-magnon.test
%%DATADIR%%/testsuite/photo_electron/01-h1d_lin.01-mask.inp
%%DATADIR%%/testsuite/photo_electron/01-h1d_lin.02-ba.inp
%%DATADIR%%/testsuite/photo_electron/01-h1d_lin.test
@@ -1514,7 +1641,6 @@ man/man1/octopus.1.gz
%%DATADIR%%/testsuite/pseudopotentials/01-sg15-h.test
%%DATADIR%%/testsuite/pseudopotentials/02-cu2_hgh.01_gs.inp
%%DATADIR%%/testsuite/pseudopotentials/02-cu2_hgh.02_gs_current.inp
-%%DATADIR%%/testsuite/pseudopotentials/02-cu2_hgh.03_gs_current_fast.inp
%%DATADIR%%/testsuite/pseudopotentials/02-cu2_hgh.test
%%DATADIR%%/testsuite/pseudopotentials/03-nlcc.01-Fatom.inp
%%DATADIR%%/testsuite/pseudopotentials/03-nlcc.F.UPF
@@ -1542,8 +1668,8 @@ man/man1/octopus.1.gz
%%DATADIR%%/testsuite/pseudopotentials/11-isotopes.01-deuterium.inp
%%DATADIR%%/testsuite/pseudopotentials/11-isotopes.02-tritium.inp
%%DATADIR%%/testsuite/pseudopotentials/11-isotopes.test
-%%DATADIR%%/testsuite/pseudopotentials/12_mix_and_match.01-mgo.inp
-%%DATADIR%%/testsuite/pseudopotentials/12_mix_and_match.test
+%%DATADIR%%/testsuite/pseudopotentials/12-mix_and_match.01-mgo.inp
+%%DATADIR%%/testsuite/pseudopotentials/12-mix_and_match.test
%%DATADIR%%/testsuite/pseudopotentials/13-U235.01-gs.inp
%%DATADIR%%/testsuite/pseudopotentials/13-U235.test
%%DATADIR%%/testsuite/pseudopotentials/14-carbon_dojo_psp8.01-gs.inp
@@ -1560,13 +1686,15 @@ man/man1/octopus.1.gz
%%DATADIR%%/testsuite/pseudopotentials/17-lithium_automatic.test
%%DATADIR%%/testsuite/real_time/01-propagators.01-gs.inp
%%DATADIR%%/testsuite/real_time/01-propagators.02-expmid.inp
-%%DATADIR%%/testsuite/real_time/01-propagators.03-etrs.inp
-%%DATADIR%%/testsuite/real_time/01-propagators.04-aetrs.inp
-%%DATADIR%%/testsuite/real_time/01-propagators.05-caetrs.inp
-%%DATADIR%%/testsuite/real_time/01-propagators.06-cn.inp
-%%DATADIR%%/testsuite/real_time/01-propagators.07-magnus.inp
-%%DATADIR%%/testsuite/real_time/01-propagators.08-exprk4.inp
-%%DATADIR%%/testsuite/real_time/01-propagators.09-cfmagnus4.inp
+%%DATADIR%%/testsuite/real_time/01-propagators.03-etrs_taylor.inp
+%%DATADIR%%/testsuite/real_time/01-propagators.04-etrs_lanczos.inp
+%%DATADIR%%/testsuite/real_time/01-propagators.05-etrs_chebyshev.inp
+%%DATADIR%%/testsuite/real_time/01-propagators.06-aetrs.inp
+%%DATADIR%%/testsuite/real_time/01-propagators.07-caetrs.inp
+%%DATADIR%%/testsuite/real_time/01-propagators.08-cn.inp
+%%DATADIR%%/testsuite/real_time/01-propagators.09-magnus.inp
+%%DATADIR%%/testsuite/real_time/01-propagators.10-exprk4.inp
+%%DATADIR%%/testsuite/real_time/01-propagators.11-cfmagnus4.inp
%%DATADIR%%/testsuite/real_time/01-propagators.test
%%DATADIR%%/testsuite/real_time/02-propagators.01-gs.inp
%%DATADIR%%/testsuite/real_time/02-propagators.02-cnsparskit.inp
@@ -1579,8 +1707,9 @@ man/man1/octopus.1.gz
%%DATADIR%%/testsuite/real_time/05-time_propagation.01-gs.inp
%%DATADIR%%/testsuite/real_time/05-time_propagation.02-td_domains.inp
%%DATADIR%%/testsuite/real_time/05-time_propagation.03-td_domains_states.inp
-%%DATADIR%%/testsuite/real_time/05-time_propagation.04-td_md.inp
-%%DATADIR%%/testsuite/real_time/05-time_propagation.05-td_fast_md.inp
+%%DATADIR%%/testsuite/real_time/05-time_propagation.04-td_domains_states-reorder_ranks.inp
+%%DATADIR%%/testsuite/real_time/05-time_propagation.05-td_md.inp
+%%DATADIR%%/testsuite/real_time/05-time_propagation.06-td_fast_md.inp
%%DATADIR%%/testsuite/real_time/05-time_propagation.test
%%DATADIR%%/testsuite/real_time/06-caetrs.01-gs.inp
%%DATADIR%%/testsuite/real_time/06-caetrs.02-kick.inp
@@ -1649,6 +1778,13 @@ man/man1/octopus.1.gz
%%DATADIR%%/testsuite/real_time/19-td_move_ions.02-td.inp
%%DATADIR%%/testsuite/real_time/19-td_move_ions.03-td_restart.inp
%%DATADIR%%/testsuite/real_time/19-td_move_ions.test
+%%DATADIR%%/testsuite/real_time/20-pcm-local-field-absorption.01-gs.inp
+%%DATADIR%%/testsuite/real_time/20-pcm-local-field-absorption.02-td_prop_eom.inp
+%%DATADIR%%/testsuite/real_time/20-pcm-local-field-absorption.test
+%%DATADIR%%/testsuite/real_time/21-scissor.01-gs.inp
+%%DATADIR%%/testsuite/real_time/21-scissor.02-td.inp
+%%DATADIR%%/testsuite/real_time/21-scissor.03-spectrum.inp
+%%DATADIR%%/testsuite/real_time/21-scissor.test
%%DATADIR%%/testsuite/symmetries/01-triclinic.01-spg1.inp
%%DATADIR%%/testsuite/symmetries/01-triclinic.02-spg2.inp
%%DATADIR%%/testsuite/symmetries/01-triclinic.test
@@ -1891,7 +2027,8 @@ man/man1/octopus.1.gz
%%DATADIR%%/testsuite/symmetries/07-symmetrization_lda.test
%%DATADIR%%/testsuite/symmetries/08-symmetrization_mgga.01-spg3_sym.inp
%%DATADIR%%/testsuite/symmetries/08-symmetrization_mgga.test
-%%DATADIR%%/testsuite/symmetries/09-symmetrization_gga.01-spg143_sym.inp
+%%DATADIR%%/testsuite/symmetries/09-symmetrization_gga.01-spg143_nosym.inp
+%%DATADIR%%/testsuite/symmetries/09-symmetrization_gga.02-spg143_sym.inp
%%DATADIR%%/testsuite/symmetries/09-symmetrization_gga.test
%%DATADIR%%/testsuite/tutorials/01-octopus_basics-getting_started.01-H_atom.inp
%%DATADIR%%/testsuite/tutorials/01-octopus_basics-getting_started.02-H_atom_spin.inp