summaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-10-09 03:42:21 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-10-09 03:42:21 +0000
commitef8baab3dcbd142a3afacacd4a57b63d5668b39a (patch)
treef0ff081cb98535e248ecb3c138b89b911a018edb /science
parent6333a1e357ff528da57c6fc81d50dfc5ee2b12f9 (diff)
downloadfreebsd-ports-ef8baab3dcbd142a3afacacd4a57b63d5668b39a.zip
New port: science/axom: Infrastructure for development of multi-physics applications and tools
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/axom/Makefile36
-rw-r--r--science/axom/distinfo7
-rw-r--r--science/axom/files/patch-CMakeLists.txt12
-rw-r--r--science/axom/pkg-descr4
-rw-r--r--science/axom/pkg-plist217
6 files changed, 277 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 4acbc13eb091..882a9845d8bb 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -31,6 +31,7 @@
SUBDIR += atompaw
SUBDIR += avogadro2
SUBDIR += avogadrolibs
+ SUBDIR += axom
SUBDIR += bagel
SUBDIR += bddsolve
SUBDIR += berkeleygw
diff --git a/science/axom/Makefile b/science/axom/Makefile
new file mode 100644
index 000000000000..5247d27c3a8d
--- /dev/null
+++ b/science/axom/Makefile
@@ -0,0 +1,36 @@
+# $FreeBSD$
+
+PORTNAME= axom
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.4.0
+CATEGORIES= science
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Infrastructure for development of multi-physics applications and tools
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/../LICENSE
+
+LIB_DEPENDS= libconduit.so:science/conduit
+RUN_DEPENDS= sparsehash>0:devel/sparsehash
+
+USES= cmake compiler:c++11-lang
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= LLNL
+GH_TUPLE= LLNL:blt:095becb5af6af5c2a2290d2fbcb5246cc01e7345:LLNL_blt/cmake/blt \
+ LLNL:axom_data:c434d0723843b4013a922771ef2cf3cc73fb32d8:LLNL_axom_data/../data
+
+CMAKE_OFF= AXOM_ENABLE_DOCS AXOM_ENABLE_EXAMPLES AXOM_ENABLE_TESTS FREEBSD_ENABLE_EXAMPLES
+CMAKE_ON= BUILD_SHARED_LIBS
+CMAKE_ARGS= -DCONDUIT_DIR=${LOCALBASE}
+
+LDFLAGS+= -lexecinfo
+
+WRKSRC_SUBDIR= src
+
+post-install: # installs headers of a third party library sparsehash: https://github.com/LLNL/axom/issues/365
+ @${RM} -r ${STAGEDIR}${PREFIX}/include/sparsehash
+
+.include <bsd.port.mk>
diff --git a/science/axom/distinfo b/science/axom/distinfo
new file mode 100644
index 000000000000..2929b434b286
--- /dev/null
+++ b/science/axom/distinfo
@@ -0,0 +1,7 @@
+TIMESTAMP = 1602186422
+SHA256 (LLNL-axom-v0.4.0_GH0.tar.gz) = a1bde0a278e8b29ad47b78444c5026cb0508278113ec87d4c25965be71d6e92e
+SIZE (LLNL-axom-v0.4.0_GH0.tar.gz) = 11435232
+SHA256 (LLNL-blt-095becb5af6af5c2a2290d2fbcb5246cc01e7345_GH0.tar.gz) = ecf4f3f420a485ddc6e13f617702b016496538dc988b031d29835611ec4f277b
+SIZE (LLNL-blt-095becb5af6af5c2a2290d2fbcb5246cc01e7345_GH0.tar.gz) = 1180812
+SHA256 (LLNL-axom_data-c434d0723843b4013a922771ef2cf3cc73fb32d8_GH0.tar.gz) = 87acbfec82aee5866d5fa405ccf78b3a6857d887ffd8a21461155d5af6bcf9e3
+SIZE (LLNL-axom_data-c434d0723843b4013a922771ef2cf3cc73fb32d8_GH0.tar.gz) = 35980392
diff --git a/science/axom/files/patch-CMakeLists.txt b/science/axom/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..b5f8fa7e586e
--- /dev/null
+++ b/science/axom/files/patch-CMakeLists.txt
@@ -0,0 +1,12 @@
+--- CMakeLists.txt.orig 2020-10-08 19:49:25 UTC
++++ CMakeLists.txt
+@@ -88,7 +88,9 @@ include(cmake/AxomVersion.cmake)
+ add_subdirectory(axom)
+
+ add_subdirectory(tools)
++if (FREEBSD_ENABLE_EXAMPLES)
+ add_subdirectory(examples)
++endif()
+
+ if (AXOM_ENABLE_DOCS)
+ if (SPHINX_FOUND)
diff --git a/science/axom/pkg-descr b/science/axom/pkg-descr
new file mode 100644
index 000000000000..6e9ee51e07a5
--- /dev/null
+++ b/science/axom/pkg-descr
@@ -0,0 +1,4 @@
+Axom provides robust, flexible software infrastructure for the development of
+multi-physics applications and computational tools.
+
+WWW: https://github.com/LLNL/axom
diff --git a/science/axom/pkg-plist b/science/axom/pkg-plist
new file mode 100644
index 000000000000..c4200548ff67
--- /dev/null
+++ b/science/axom/pkg-plist
@@ -0,0 +1,217 @@
+bin/mesh_tester
+include/CLI11/CLI11.hpp
+include/axom/config.hpp
+include/axom/core.hpp
+include/axom/core/Array.hpp
+include/axom/core/Macros.hpp
+include/axom/core/StackArray.hpp
+include/axom/core/Types.hpp
+include/axom/core/execution/execution_space.hpp
+include/axom/core/execution/for_all.hpp
+include/axom/core/execution/internal/cuda_exec.hpp
+include/axom/core/execution/internal/omp_exec.hpp
+include/axom/core/execution/internal/seq_exec.hpp
+include/axom/core/execution/synchronize.hpp
+include/axom/core/memory_management.hpp
+include/axom/core/numerics/Determinants.hpp
+include/axom/core/numerics/LU.hpp
+include/axom/core/numerics/Matrix.hpp
+include/axom/core/numerics/eigen_solve.hpp
+include/axom/core/numerics/eigen_sort.hpp
+include/axom/core/numerics/floating_point_limits.hpp
+include/axom/core/numerics/internal/matrix_norms.hpp
+include/axom/core/numerics/jacobi_eigensolve.hpp
+include/axom/core/numerics/linear_solve.hpp
+include/axom/core/numerics/matvecops.hpp
+include/axom/core/numerics/polynomial_solvers.hpp
+include/axom/core/utilities/About.hpp
+include/axom/core/utilities/AnnotationMacros.hpp
+include/axom/core/utilities/FileUtilities.hpp
+include/axom/core/utilities/StringUtilities.hpp
+include/axom/core/utilities/Timer.hpp
+include/axom/core/utilities/Utilities.hpp
+include/axom/core/utilities/nvtx/Macros.hpp
+include/axom/core/utilities/nvtx/Range.hpp
+include/axom/core/utilities/nvtx/interface.hpp
+include/axom/inlet.hpp
+include/axom/inlet/DocWriter.hpp
+include/axom/inlet/Field.hpp
+include/axom/inlet/Inlet.hpp
+include/axom/inlet/Reader.hpp
+include/axom/inlet/SchemaCreator.hpp
+include/axom/inlet/SphinxDocWriter.hpp
+include/axom/inlet/Table.hpp
+include/axom/inlet/inlet_utils.hpp
+include/axom/mint.hpp
+include/axom/mint/config.hpp
+include/axom/mint/execution/interface.hpp
+include/axom/mint/execution/internal/for_all_cells.hpp
+include/axom/mint/execution/internal/for_all_faces.hpp
+include/axom/mint/execution/internal/for_all_nodes.hpp
+include/axom/mint/execution/internal/helpers.hpp
+include/axom/mint/execution/internal/structured_exec.hpp
+include/axom/mint/execution/xargs.hpp
+include/axom/mint/fem/FEBasis.hpp
+include/axom/mint/fem/FEBasisTypes.hpp
+include/axom/mint/fem/FiniteElement.hpp
+include/axom/mint/fem/shape_functions/Lagrange.hpp
+include/axom/mint/fem/shape_functions/ShapeFunction.hpp
+include/axom/mint/fem/shape_functions/lagrange/lagrange_hexa_27.hpp
+include/axom/mint/fem/shape_functions/lagrange/lagrange_hexa_8.hpp
+include/axom/mint/fem/shape_functions/lagrange/lagrange_prism_6.hpp
+include/axom/mint/fem/shape_functions/lagrange/lagrange_pyra_5.hpp
+include/axom/mint/fem/shape_functions/lagrange/lagrange_quad_4.hpp
+include/axom/mint/fem/shape_functions/lagrange/lagrange_quad_9.hpp
+include/axom/mint/fem/shape_functions/lagrange/lagrange_tetra_4.hpp
+include/axom/mint/fem/shape_functions/lagrange/lagrange_tri_3.hpp
+include/axom/mint/mesh/CellTypes.hpp
+include/axom/mint/mesh/ConnectivityArray.hpp
+include/axom/mint/mesh/CurvilinearMesh.hpp
+include/axom/mint/mesh/Field.hpp
+include/axom/mint/mesh/FieldAssociation.hpp
+include/axom/mint/mesh/FieldData.hpp
+include/axom/mint/mesh/FieldTypes.hpp
+include/axom/mint/mesh/FieldVariable.hpp
+include/axom/mint/mesh/Mesh.hpp
+include/axom/mint/mesh/MeshCoordinates.hpp
+include/axom/mint/mesh/MeshTypes.hpp
+include/axom/mint/mesh/ParticleMesh.hpp
+include/axom/mint/mesh/RectilinearMesh.hpp
+include/axom/mint/mesh/StructuredMesh.hpp
+include/axom/mint/mesh/UniformMesh.hpp
+include/axom/mint/mesh/UnstructuredMesh.hpp
+include/axom/mint/mesh/blueprint.hpp
+include/axom/mint/mesh/internal/ConnectivityArrayHelpers.hpp
+include/axom/mint/mesh/internal/ConnectivityArray_indirection.hpp
+include/axom/mint/mesh/internal/ConnectivityArray_typed_indirection.hpp
+include/axom/mint/mesh/internal/MeshHelpers.hpp
+include/axom/mint/utils/su2_utils.hpp
+include/axom/mint/utils/vtk_utils.hpp
+include/axom/primal.hpp
+include/axom/primal/geometry/BezierCurve.hpp
+include/axom/primal/geometry/BoundingBox.hpp
+include/axom/primal/geometry/NumericArray.hpp
+include/axom/primal/geometry/OrientationResult.hpp
+include/axom/primal/geometry/OrientedBoundingBox.hpp
+include/axom/primal/geometry/Plane.hpp
+include/axom/primal/geometry/Point.hpp
+include/axom/primal/geometry/Polygon.hpp
+include/axom/primal/geometry/Ray.hpp
+include/axom/primal/geometry/Segment.hpp
+include/axom/primal/geometry/Sphere.hpp
+include/axom/primal/geometry/Tetrahedron.hpp
+include/axom/primal/geometry/Triangle.hpp
+include/axom/primal/geometry/Vector.hpp
+include/axom/primal/operators/clip.hpp
+include/axom/primal/operators/closest_point.hpp
+include/axom/primal/operators/compute_bounding_box.hpp
+include/axom/primal/operators/detail/clip_impl.hpp
+include/axom/primal/operators/detail/intersect_bezier_impl.hpp
+include/axom/primal/operators/detail/intersect_bounding_box_impl.hpp
+include/axom/primal/operators/detail/intersect_impl.hpp
+include/axom/primal/operators/detail/intersect_ray_impl.hpp
+include/axom/primal/operators/in_sphere.hpp
+include/axom/primal/operators/intersect.hpp
+include/axom/primal/operators/orientation.hpp
+include/axom/primal/operators/squared_distance.hpp
+include/axom/quest.hpp
+include/axom/quest/AllNearestNeighbors.hpp
+include/axom/quest/InOutOctree.hpp
+include/axom/quest/MeshTester.hpp
+include/axom/quest/PointInCell.hpp
+include/axom/quest/SignedDistance.hpp
+include/axom/quest/detail/AllNearestNeighbors_detail.hpp
+include/axom/quest/detail/PointFinder.hpp
+include/axom/quest/detail/PointInCellMeshWrapper_mfem.hpp
+include/axom/quest/interface/inout.hpp
+include/axom/quest/interface/internal/QuestHelpers.hpp
+include/axom/quest/interface/internal/mpicomm_wrapper.hpp
+include/axom/quest/interface/signed_distance.hpp
+include/axom/quest/stl/STLReader.hpp
+include/axom/sidre.hpp
+include/axom/sidre/core/Array.hpp
+include/axom/sidre/core/AttrValues.hpp
+include/axom/sidre/core/Attribute.hpp
+include/axom/sidre/core/Buffer.hpp
+include/axom/sidre/core/DataStore.hpp
+include/axom/sidre/core/Group.hpp
+include/axom/sidre/core/ItemCollection.hpp
+include/axom/sidre/core/Iterator.hpp
+include/axom/sidre/core/ListCollection.hpp
+include/axom/sidre/core/MapCollection.hpp
+include/axom/sidre/core/SidreDataTypeIds.h
+include/axom/sidre/core/SidreTypes.hpp
+include/axom/sidre/core/View.hpp
+include/axom/sidre/core/sidre.hpp
+include/axom/slam.hpp
+include/axom/slam/BitSet.hpp
+include/axom/slam/BivariateMap.hpp
+include/axom/slam/BivariateSet.hpp
+include/axom/slam/DynamicConstantRelation.hpp
+include/axom/slam/DynamicMap.hpp
+include/axom/slam/DynamicSet.hpp
+include/axom/slam/DynamicVariableRelation.hpp
+include/axom/slam/FieldRegistry.hpp
+include/axom/slam/IndirectionSet.hpp
+include/axom/slam/IteratorBase.hpp
+include/axom/slam/Map.hpp
+include/axom/slam/MapBase.hpp
+include/axom/slam/ModularInt.hpp
+include/axom/slam/NullSet.hpp
+include/axom/slam/OrderedSet.hpp
+include/axom/slam/ProductSet.hpp
+include/axom/slam/RangeSet.hpp
+include/axom/slam/Relation.hpp
+include/axom/slam/RelationSet.hpp
+include/axom/slam/Set.hpp
+include/axom/slam/StaticRelation.hpp
+include/axom/slam/SubMap.hpp
+include/axom/slam/Utilities.hpp
+include/axom/slam/internal/BitTwiddle.hpp
+include/axom/slam/policies/CardinalityPolicies.hpp
+include/axom/slam/policies/IndirectionPolicies.hpp
+include/axom/slam/policies/OffsetPolicies.hpp
+include/axom/slam/policies/PolicyTraits.hpp
+include/axom/slam/policies/SizePolicies.hpp
+include/axom/slam/policies/StridePolicies.hpp
+include/axom/slam/policies/SubsettingPolicies.hpp
+include/axom/slic.hpp
+include/axom/slic/core/LogStream.hpp
+include/axom/slic/core/Logger.hpp
+include/axom/slic/core/MessageLevel.hpp
+include/axom/slic/core/UnitTestLogger.hpp
+include/axom/slic/interface/slic.hpp
+include/axom/slic/interface/slic_macros.hpp
+include/axom/slic/internal/stacktrace.hpp
+include/axom/slic/streams/GenericOutputStream.hpp
+include/axom/spin.hpp
+include/axom/spin/BVHTree.hpp
+include/axom/spin/Brood.hpp
+include/axom/spin/DenseOctreeLevel.hpp
+include/axom/spin/ImplicitGrid.hpp
+include/axom/spin/MortonIndex.hpp
+include/axom/spin/OctreeBase.hpp
+include/axom/spin/OctreeLevel.hpp
+include/axom/spin/RectangularLattice.hpp
+include/axom/spin/SparseOctreeLevel.hpp
+include/axom/spin/SpatialOctree.hpp
+include/axom/spin/UniformGrid.hpp
+include/fmt/LICENSE
+include/fmt/README
+include/fmt/chrono.h
+include/fmt/color.h
+include/fmt/core.h
+include/fmt/fmt.hpp
+include/fmt/format-inl.h
+include/fmt/format.cc
+include/fmt/format.h
+include/fmt/locale.h
+include/fmt/ostream.h
+include/fmt/printf.h
+include/fmt/ranges.h
+include/fmt/time.h
+lib/cmake/axom-config-version.cmake
+lib/cmake/axom-config.cmake
+lib/cmake/axom-targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/axom-targets.cmake
+lib/libaxom.so