summaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorRainer Hurling <rhurlin@FreeBSD.org>2020-10-31 15:59:08 +0000
committerRainer Hurling <rhurlin@FreeBSD.org>2020-10-31 15:59:08 +0000
commite4cddaff021616ae4ebf117c597dfa8bfe5cbc27 (patch)
tree10f30ea358be215568cc98f84d22f1ddd424a173 /science
parent3dcac3f77513a7b545b94a9b0805f1a58741f5c7 (diff)
downloadfreebsd-ports-e4cddaff021616ae4ebf117c597dfa8bfe5cbc27.zip
science/libctl: Update to 4.5.0
Update science/libctl from 3.2.2 to 4.5.0. Over several minor and a major version release there have been important bugfixes and enhancements [1]. [1] https://github.com/NanoComp/libctl/blob/master/NEWS.md What this patch should do: - Update from 3.2.2 to 4.5.0 - Change MASTER_SITES to the Github releases URL - Add LIB_DEPENDS=devel/boehm-gc-threaded and libguile-2.2.so:lang/guile2 - 'Bump' library version - Set option NLOPT default (needed by science/mpb) - Reorder some Makefile entries - Update URL in pkg-descr - Update pkg-plist PR: 249007 Submitted by: (maintainer timeout) Approved by: arrowd (mentor) Differential Revision: https://reviews.freebsd.org/D26992
Diffstat (limited to 'science')
-rw-r--r--science/libctl/Makefile23
-rw-r--r--science/libctl/distinfo5
-rw-r--r--science/libctl/pkg-descr2
-rw-r--r--science/libctl/pkg-plist29
4 files changed, 33 insertions, 26 deletions
diff --git a/science/libctl/Makefile b/science/libctl/Makefile
index 2a92aed65c2d..5bc0bab81c1d 100644
--- a/science/libctl/Makefile
+++ b/science/libctl/Makefile
@@ -2,28 +2,29 @@
# $FreeBSD$
PORTNAME= libctl
-PORTVERSION= 3.2.2
-PORTREVISION= 9
+DISTVERSION= 4.5.0
CATEGORIES= science math
-MASTER_SITES= http://ab-initio.mit.edu/libctl/
+MASTER_SITES= https://github.com/NanoComp/libctl/releases/download/v${DISTVERSION}/
MAINTAINER= devel@stasyan.com
COMMENT= Control Language Library
LICENSE= GPLv2
-LIB_DEPENDS= libguile-2.2.so:lang/guile2
+BROKEN_sparc64= does not build
+
+LIB_DEPENDS= libgc-threaded.so:devel/boehm-gc-threaded \
+ libguile-2.2.so:lang/guile2
+USES= fortran libtool pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared
-USES= fortran libtool pkgconfig
USE_LDCONFIG= yes
LDFLAGS+= -L${LOCALBASE}/lib -lm
-BROKEN_sparc64= does not build
-
-OPTIONS_DEFINE= NLOPT DOCS EXAMPLES
-NLOPT_DESC= Use NLopt, an external NonLinear OPTimizer
+OPTIONS_DEFINE= NLOPT DOCS EXAMPLES
+OPTIONS_DEFAULT= NLOPT
+NLOPT_DESC= Use NLopt, an external NonLinear OPTimizer
NLOPT_LIB_DEPENDS= libnlopt.so:math/nlopt
@@ -32,8 +33,8 @@ post-install:
${CP} -R ${WRKSRC}/doc/ ${STAGEDIR}${DOCSDIR}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${CP} -R ${WRKSRC}/examples/ ${STAGEDIR}${EXAMPLESDIR}
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libctl.so.5.0.2
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libctlgeom.so.5.0.2
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libctl.so.7.3.0
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libctlgeom.so.7.3.0
@${STRIP_CMD} ${STAGEDIR}${EXAMPLESDIR}/.libs/example
.include <bsd.port.mk>
diff --git a/science/libctl/distinfo b/science/libctl/distinfo
index ea554f235601..3e11d941c10d 100644
--- a/science/libctl/distinfo
+++ b/science/libctl/distinfo
@@ -1,2 +1,3 @@
-SHA256 (libctl-3.2.2.tar.gz) = 8abd8b58bc60e84e16d25b56f71020e0cb24d75b28bc5db86d50028197c7efbc
-SIZE (libctl-3.2.2.tar.gz) = 505796
+TIMESTAMP = 1603827648
+SHA256 (libctl-4.5.0.tar.gz) = 621e46a238c4d5e8ce0866183f8e04abac6e1a94d90932af0d56ee61370ea153
+SIZE (libctl-4.5.0.tar.gz) = 557698
diff --git a/science/libctl/pkg-descr b/science/libctl/pkg-descr
index a4a26925c6a5..5ff404d14a9e 100644
--- a/science/libctl/pkg-descr
+++ b/science/libctl/pkg-descr
@@ -11,4 +11,4 @@ control files end with ".ctl" and are referred to as ctl files). Thus,
libctl is the Control Language Library (where the "lib" prefix follows the
Unix idiom).
-WWW: http://ab-initio.mit.edu/libctl/
+WWW: https://libctl.readthedocs.io/en/latest/
diff --git a/science/libctl/pkg-plist b/science/libctl/pkg-plist
index 7c5e20de8ed7..e19787c24bb2 100644
--- a/science/libctl/pkg-plist
+++ b/science/libctl/pkg-plist
@@ -1,24 +1,29 @@
bin/gen-ctl-io
+include/ctl-math.h
include/ctl.h
include/ctlgeom-types.h
include/ctlgeom.h
lib/libctl.a
lib/libctl.so
-lib/libctl.so.5
-lib/libctl.so.5.0.2
+lib/libctl.so.7
+lib/libctl.so.7.3.0
lib/libctlgeom.a
lib/libctlgeom.so
-lib/libctlgeom.so.5
-lib/libctlgeom.so.5.0.2
+lib/libctlgeom.so.7
+lib/libctlgeom.so.7.3.0
man/man1/gen-ctl-io.1.gz
-%%PORTDOCS%%%%DOCSDIR%%/advanced-user.html
-%%PORTDOCS%%%%DOCSDIR%%/basic-user.html
-%%PORTDOCS%%%%DOCSDIR%%/developer.html
-%%PORTDOCS%%%%DOCSDIR%%/guile-links.html
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/introduction.html
-%%PORTDOCS%%%%DOCSDIR%%/license.html
-%%PORTDOCS%%%%DOCSDIR%%/user-ref.html
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/docs/Advanced_User_Experience.md
+%%PORTDOCS%%%%DOCSDIR%%/docs/Basic_User_Experience.md
+%%PORTDOCS%%%%DOCSDIR%%/docs/Developer_Experience.md
+%%PORTDOCS%%%%DOCSDIR%%/docs/Guile_and_Scheme_Information.md
+%%PORTDOCS%%%%DOCSDIR%%/docs/Installation.md
+%%PORTDOCS%%%%DOCSDIR%%/docs/Introduction.md
+%%PORTDOCS%%%%DOCSDIR%%/docs/License_and_Copyright.md
+%%PORTDOCS%%%%DOCSDIR%%/docs/User_Reference.md
+%%PORTDOCS%%%%DOCSDIR%%/docs/images/libctl-logo.png
+%%PORTDOCS%%%%DOCSDIR%%/docs/index.md
+%%PORTDOCS%%%%DOCSDIR%%/requirements.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/.deps/example-ctl-io.Po
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/.deps/example-example.Po
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/.deps/example-geom.Po