summaryrefslogtreecommitdiff
path: root/science/hdf5-18
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-04-23 13:25:16 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-04-23 13:25:16 +0000
commitaad09bc5e23eb75a7a865a8b0002fbc6e13d4659 (patch)
tree69c07cdc4812f0f8be0cc44c38513f540c058778 /science/hdf5-18
parent5c818b158c5b9479669f8322b4da8c48f5c30ef9 (diff)
downloadfreebsd-ports-aad09bc5e23eb75a7a865a8b0002fbc6e13d4659.zip
When linking a library libA with a library libB using libtool, if libB.la
exists, libtool will add all libraries libB.la refers to (dependency_libs field) to the linker command line and store them in the dependency_libs field of libA.la. So everything that subsequently links with libA will also link to these extra libraries. This causes too much overlinking. This commit modifies Mk/Uses/libtool.mk so it empties the dependency_libs field in .la libraries during staging. However, because .la libraries have very limited use when dependency_libs is empty it makes sense to completely remove them during staging. So with this commit USES=libtool is modified to remove .la libraries and a new form (USES=libtool:keepla) is introduced in case they need to be kept (dependency_libs is still emptied). PORTREVISION is bumped on all ports with USES=libtool that install .la libraries. Most ports are also changed to add :keepla because .la libraries have to be kept around as long as there are dependent ports with .la libraries that refer to them in their dependency_libs field. In most cases :keepla can be removed again as soon as all dependent ports that install .la libraries have some form of USES=libtool added to their Makefile. PR: ports/188759 Exp-run: bdrewery Approved by: portmgr (bdrewery)
Diffstat (limited to 'science/hdf5-18')
-rw-r--r--science/hdf5-18/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/science/hdf5-18/Makefile b/science/hdf5-18/Makefile
index 7a19fcdbb125..902a7371e03c 100644
--- a/science/hdf5-18/Makefile
+++ b/science/hdf5-18/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hdf5
PORTVERSION= 1.8.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science archivers graphics
MASTER_SITES= http://www.hdfgroup.org/ftp/HDF5/current/src/ \
ftp://ftp.hdfgroup.org/HDF5/current/src/ \
@@ -19,7 +19,7 @@ OPTIONS_DEFINE= DEBUG EXAMPLES FORTRAN SZIP
CONFLICTS_INSTALL= hdf-4.[0-9]* hdf5-1.6.[0-9]*
-USES= libtool tar:bzip2
+USES= libtool:keepla tar:bzip2
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-cxx \