summaryrefslogtreecommitdiff
path: root/science/code_saturne
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-08-17 15:33:42 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-08-17 15:33:42 +0000
commit9fbd9bcd26163aed65f05040616f8abe171ec543 (patch)
tree01e20fa5f11c7b72d92b606ef6d5b258063e1d8e /science/code_saturne
parent76070a7964d317de545fa455702bc84d6aec369e (diff)
downloadfreebsd-ports-9fbd9bcd26163aed65f05040616f8abe171ec543.zip
science/code_saturne: fix build on GCC architectures
Use C++11 compiler: cs_paramedmem_remapper.cxx:124: error: ISO C++ forbids initialization of member '_sphere_cen' Define __XSI_VISIBLE to make gettimeofday() available. MFH: 2020Q3 (fix build blanket)
Diffstat (limited to 'science/code_saturne')
-rw-r--r--science/code_saturne/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/science/code_saturne/Makefile b/science/code_saturne/Makefile
index 2ab9839cec3e..9ef14fc1660d 100644
--- a/science/code_saturne/Makefile
+++ b/science/code_saturne/Makefile
@@ -25,12 +25,13 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR}
USE_GITHUB= yes
GH_ACCOUNT= code-saturne
-USES= autoreconf bison fortran gettext gnome gmake iconv libtool \
- pyqt:5 python:3.6+ shebangfix
+USES= autoreconf bison compiler:c11 fortran gettext gnome gmake \
+ iconv libtool pyqt:5 python:3.6+ shebangfix
USE_GNOME= libxml2
USE_PYQT= core gui sip widgets xml_build
SHEBANG_FILES= install_saturne.py tests/unittests.py bin/*.py build-aux/*.py
+CFLAGS+= -D__XSI_VISIBLE
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libxml2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-salome --without-salome-yacs --without-salome-kernel \