summaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2024-03-02 00:29:48 +0100
committerTobias C. Berner <tcberner@FreeBSD.org>2024-03-02 00:54:14 +0100
commit163e26d8c6d7cb8f70f3e69d968518d2a4120ae9 (patch)
treec0d98ee3d1665992d57bfabbc85a6436ed5a870e /print
parent6f57c57089b275dc1366adc5d219b6d723594e40 (diff)
downloadfreebsd-ports-163e26d8c6d7cb8f70f3e69d968518d2a4120ae9.zip
KDE: Update KDE Plasma 6 to 6.0.0
This updates KDE Plasma 6 to the first stable release. Update plan for the rest of KDE: * The KDE Applications will be updated to 24.02 at the beginning of the next quarter in the tree. They will be mostly Qt6 based. To test them beforehand, one can use the overlay [1]. * The idea is to wait out the first patch-release for the applications, which should hopefully get rid of most of the new bugs. * The Qt5 bases KDE Frameworks 5 and Plasma 5 ports should remain in the tree for the next quarter -- Frameworks as long as it is required by other ports. The Plasma 5 ports will likely be removed at some point in the future however -- as there is no apparent benefit in having multiple Plasma versions at the moment. * The Qt6 based KDE applications will replace the current Qt5 based ports. As the maintenance overhead for duplicate is not manageable. * For co-instability the KDE Frameworks 5 ports will be adapted to depend on the KDE Frameworks 6 ports as described in [2]. * This plan is not fixed in stone, but will be adapted when it seems reasonable to do so. Announcement: https://kde.org/announcements/megarelease/6/ [1] https://github.com/tcberner/kde6-overlay [2] https://community.kde.org/Frameworks/6.0_Release_notes#Coinstallability
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/plasma6-print-manager/Makefile24
-rw-r--r--print/plasma6-print-manager/distinfo3
-rw-r--r--print/plasma6-print-manager/pkg-descr3
-rw-r--r--print/plasma6-print-manager/pkg-plist173
5 files changed, 204 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index c7ca2ec18c6e..0627f27b1662 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -152,6 +152,7 @@
SUBDIR += pkfonts360
SUBDIR += pkfonts400
SUBDIR += pkfonts600
+ SUBDIR += plasma6-print-manager
SUBDIR += pnm2ppa
SUBDIR += posterazor
SUBDIR += print-manager
diff --git a/print/plasma6-print-manager/Makefile b/print/plasma6-print-manager/Makefile
new file mode 100644
index 000000000000..d1a3ecc9d91b
--- /dev/null
+++ b/print/plasma6-print-manager/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= print-manager
+DISTVERSION= ${KDE_PLASMA_VERSION}
+CATEGORIES= print kde kde-plasma
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Printer manager for KDE
+WWW= https://www.kde.org
+
+LIB_DEPENDS= libcups.so:print/cups
+
+USES= cmake compiler:c++11-lang gettext kde:6 pkgconfig qt:6 tar:xz \
+ xorg
+USE_KDE= completion config configwidgets coreaddons dbusaddons i18n \
+ iconthemes jobwidgets kio kirigami-addons libplasma \
+ notifications service solid widgetsaddons windowsystem \
+ ecm:build
+USE_QT= base declarative
+USE_XORG= x11
+
+post-patch:
+ ${REINPLACE_CMD} '/CUPS_DATADIR/s|/usr/share/cups|${LOCALBASE}/share/cups|' \
+ ${PATCH_WRKSRC}/src/libkcups/KCupsRequest.cpp
+
+.include <bsd.port.mk>
diff --git a/print/plasma6-print-manager/distinfo b/print/plasma6-print-manager/distinfo
new file mode 100644
index 000000000000..cefe6a4f0abf
--- /dev/null
+++ b/print/plasma6-print-manager/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1708670270
+SHA256 (KDE/plasma/6.0.0/print-manager-6.0.0.tar.xz) = bd90578b91e6c90a13c5afcf94bc16d57bc7a3b7de89445bfa015f0c4e7814fd
+SIZE (KDE/plasma/6.0.0/print-manager-6.0.0.tar.xz) = 336560
diff --git a/print/plasma6-print-manager/pkg-descr b/print/plasma6-print-manager/pkg-descr
new file mode 100644
index 000000000000..2d87df9739d1
--- /dev/null
+++ b/print/plasma6-print-manager/pkg-descr
@@ -0,0 +1,3 @@
+printer-manager is a configuration module for printers. It
+replaces KDE 3's kjobviewer and kprint-applet of previous
+KDE 4 versions.
diff --git a/print/plasma6-print-manager/pkg-plist b/print/plasma6-print-manager/pkg-plist
new file mode 100644
index 000000000000..e0547bb49302
--- /dev/null
+++ b/print/plasma6-print-manager/pkg-plist
@@ -0,0 +1,173 @@
+bin/configure-printer
+bin/kde-add-printer
+bin/kde-print-queue
+lib/libkcupslib.so.%%KDE_PLASMA_VERSION%%
+%%QT_PLUGINDIR%%/kf6/kded/printmanager.so
+%%QT_PLUGINDIR%%/plasma/kcms/systemsettings/kcm_printer_manager.so
+%%QT_QMLDIR%%/org/kde/plasma/printmanager/kcupslib.qmltypes
+%%QT_QMLDIR%%/org/kde/plasma/printmanager/kde-qmlmodule.version
+%%QT_QMLDIR%%/org/kde/plasma/printmanager/libkcupslibplugin.so
+%%QT_QMLDIR%%/org/kde/plasma/printmanager/qmldir
+share/applications/kcm_printer_manager.desktop
+share/applications/org.kde.ConfigurePrinter.desktop
+share/applications/org.kde.PrintQueue.desktop
+share/applications/org.kde.kde-add-printer.desktop
+share/knotifications6/printmanager.notifyrc
+share/locale/ar/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/ar/LC_MESSAGES/print-manager.mo
+share/locale/ast/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/ast/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/ast/LC_MESSAGES/print-manager.mo
+share/locale/az/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/az/LC_MESSAGES/print-manager.mo
+share/locale/be/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/be/LC_MESSAGES/print-manager.mo
+share/locale/bg/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/bg/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/bg/LC_MESSAGES/print-manager.mo
+share/locale/bs/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/bs/LC_MESSAGES/print-manager.mo
+share/locale/ca/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/ca/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/ca/LC_MESSAGES/print-manager.mo
+share/locale/ca@valencia/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/ca@valencia/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/ca@valencia/LC_MESSAGES/print-manager.mo
+share/locale/cs/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/cs/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/cs/LC_MESSAGES/print-manager.mo
+share/locale/da/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/da/LC_MESSAGES/print-manager.mo
+share/locale/de/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/de/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/de/LC_MESSAGES/print-manager.mo
+share/locale/el/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/el/LC_MESSAGES/print-manager.mo
+share/locale/en_GB/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/en_GB/LC_MESSAGES/print-manager.mo
+share/locale/eo/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/eo/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/eo/LC_MESSAGES/print-manager.mo
+share/locale/es/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/es/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/es/LC_MESSAGES/print-manager.mo
+share/locale/et/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/et/LC_MESSAGES/print-manager.mo
+share/locale/eu/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/eu/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/eu/LC_MESSAGES/print-manager.mo
+share/locale/fi/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/fi/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/fi/LC_MESSAGES/print-manager.mo
+share/locale/fr/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/fr/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/fr/LC_MESSAGES/print-manager.mo
+share/locale/ga/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/ga/LC_MESSAGES/print-manager.mo
+share/locale/gl/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/gl/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/gl/LC_MESSAGES/print-manager.mo
+share/locale/he/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/he/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/he/LC_MESSAGES/print-manager.mo
+share/locale/hsb/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/hu/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/hu/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/hu/LC_MESSAGES/print-manager.mo
+share/locale/ia/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/ia/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/ia/LC_MESSAGES/print-manager.mo
+share/locale/id/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/id/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/id/LC_MESSAGES/print-manager.mo
+share/locale/is/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/is/LC_MESSAGES/print-manager.mo
+share/locale/it/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/it/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/it/LC_MESSAGES/print-manager.mo
+share/locale/ja/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/ja/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/ja/LC_MESSAGES/print-manager.mo
+share/locale/ka/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/ka/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/ka/LC_MESSAGES/print-manager.mo
+share/locale/kk/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/kk/LC_MESSAGES/print-manager.mo
+share/locale/km/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/km/LC_MESSAGES/print-manager.mo
+share/locale/ko/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/ko/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/ko/LC_MESSAGES/print-manager.mo
+share/locale/lt/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/lt/LC_MESSAGES/print-manager.mo
+share/locale/mr/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/mr/LC_MESSAGES/print-manager.mo
+share/locale/nb/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/nb/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/nb/LC_MESSAGES/print-manager.mo
+share/locale/nds/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/nds/LC_MESSAGES/print-manager.mo
+share/locale/nl/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/nl/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/nl/LC_MESSAGES/print-manager.mo
+share/locale/nn/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/nn/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/nn/LC_MESSAGES/print-manager.mo
+share/locale/pa/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/pa/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/pa/LC_MESSAGES/print-manager.mo
+share/locale/pl/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/pl/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/pl/LC_MESSAGES/print-manager.mo
+share/locale/pt/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/pt/LC_MESSAGES/print-manager.mo
+share/locale/pt_BR/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/pt_BR/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/pt_BR/LC_MESSAGES/print-manager.mo
+share/locale/ro/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/ro/LC_MESSAGES/print-manager.mo
+share/locale/ru/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/ru/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/ru/LC_MESSAGES/print-manager.mo
+share/locale/sk/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/sk/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/sk/LC_MESSAGES/print-manager.mo
+share/locale/sl/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/sl/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/sl/LC_MESSAGES/print-manager.mo
+share/locale/sr/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/sr/LC_MESSAGES/print-manager.mo
+share/locale/sr@ijekavian/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/sr@ijekavian/LC_MESSAGES/print-manager.mo
+share/locale/sr@ijekavianlatin/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/sr@ijekavianlatin/LC_MESSAGES/print-manager.mo
+share/locale/sr@latin/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/sr@latin/LC_MESSAGES/print-manager.mo
+share/locale/sv/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/sv/LC_MESSAGES/print-manager.mo
+share/locale/ta/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/ta/LC_MESSAGES/print-manager.mo
+share/locale/tg/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/tg/LC_MESSAGES/print-manager.mo
+share/locale/tr/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/tr/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/tr/LC_MESSAGES/print-manager.mo
+share/locale/ug/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/ug/LC_MESSAGES/print-manager.mo
+share/locale/uk/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/uk/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/uk/LC_MESSAGES/print-manager.mo
+share/locale/zh_CN/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/zh_CN/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/zh_CN/LC_MESSAGES/print-manager.mo
+share/locale/zh_TW/LC_MESSAGES/kcm_printer_manager.mo
+share/locale/zh_TW/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo
+share/locale/zh_TW/LC_MESSAGES/print-manager.mo
+share/metainfo/org.kde.plasma.printmanager.appdata.xml
+share/metainfo/org.kde.print-manager.metainfo.xml
+share/plasma/plasmoids/org.kde.plasma.printmanager/contents/config/main.xml
+share/plasma/plasmoids/org.kde.plasma.printmanager/contents/ui/FullRepresentation.qml
+share/plasma/plasmoids/org.kde.plasma.printmanager/contents/ui/PrinterDelegate.qml
+share/plasma/plasmoids/org.kde.plasma.printmanager/contents/ui/main.qml
+share/plasma/plasmoids/org.kde.plasma.printmanager/metadata.json
+share/qlogging-categories6/pmlogs.categories