summaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2013-10-23 09:33:10 +0000
committerMathieu Arnold <mat@FreeBSD.org>2013-10-23 09:33:10 +0000
commit921548c6e22017fed80c2530c8758b3007da7800 (patch)
tree50a40fade9ba45a47f343098f7ee19f700cec5eb /ports-mgmt
parent491392b2e4fbdd5381cbcc166dc2f1024d0328fe (diff)
downloadfreebsd-ports-921548c6e22017fed80c2530c8758b3007da7800.zip
Support staging.
PR: ports/183185 Submitted by: mat Approved by: maintainer
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/pkg_cutleaves/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/ports-mgmt/pkg_cutleaves/Makefile b/ports-mgmt/pkg_cutleaves/Makefile
index 5a0617ce01f5..b797a71b5564 100644
--- a/ports-mgmt/pkg_cutleaves/Makefile
+++ b/ports-mgmt/pkg_cutleaves/Makefile
@@ -15,16 +15,13 @@ USES= perl5
WRKSRC= ${WRKDIR}
-MAN1= pkg_cutleaves.1
-
-PLIST_FILES= sbin/pkg_cutleaves
+PLIST_FILES= sbin/pkg_cutleaves man/man1/pkg_cutleaves.1.gz
.if defined(WITH_PKGNG)
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-pkg_cutleaves \
${FILESDIR}/extra-patch-pkg_cutleaves.1
.endif
-NO_STAGE= yes
do-extract:
${MKDIR} ${WRKSRC}
${CP} ${FILESDIR}/pkg_cutleaves ${FILESDIR}/pkg_cutleaves.1 ${WRKSRC}
@@ -51,7 +48,7 @@ post-patch:
.endif
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/pkg_cutleaves ${PREFIX}/sbin/pkg_cutleaves
- ${INSTALL_MAN} ${WRKSRC}/pkg_cutleaves.1 ${MAN1PREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKSRC}/pkg_cutleaves ${STAGEDIR}${PREFIX}/sbin/pkg_cutleaves
+ ${INSTALL_MAN} ${WRKSRC}/pkg_cutleaves.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
.include <bsd.port.mk>