summaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2020-05-01 17:14:45 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2020-05-01 17:14:45 +0000
commit2cd0c2fab2a351b8d765f6787e574e6ca45bd05c (patch)
tree061a7c0c9631ec82f612aa9e1c927ec1e0a2c348 /net
parentfef36d51ea64812a6bd9015480f6f2442c834752 (diff)
downloadfreebsd-ports-2cd0c2fab2a351b8d765f6787e574e6ca45bd05c.zip
- Remove bashisms from configure script which can cause wrong options
being passed to bundled pjproject configure script - Prevent pjproject build from trying to touch, calculate checksum and download the pjproject distribution file itself. This can cause build failures in poudriere Reported by: cmt Tested by: cmt
Diffstat (limited to 'net')
-rw-r--r--net/asterisk13/Makefile1
-rw-r--r--net/asterisk13/files/patch-configure49
-rw-r--r--net/asterisk13/files/patch-third-party_pjproject_Makefile21
3 files changed, 60 insertions, 11 deletions
diff --git a/net/asterisk13/Makefile b/net/asterisk13/Makefile
index 9c21ad91f8d7..5ce9a0498c5c 100644
--- a/net/asterisk13/Makefile
+++ b/net/asterisk13/Makefile
@@ -2,6 +2,7 @@
PORTNAME= asterisk
PORTVERSION= 13.33.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= https://downloads.asterisk.org/pub/telephony/%SUBDIR%/:DEFAULT,g729 \
http://www.pjsip.org/release/${PJSIP_VERSION}/:PJSIP
diff --git a/net/asterisk13/files/patch-configure b/net/asterisk13/files/patch-configure
index 40b24ea9de96..0e9a93dd5280 100644
--- a/net/asterisk13/files/patch-configure
+++ b/net/asterisk13/files/patch-configure
@@ -1,15 +1,46 @@
---- configure.orig 2018-04-19 18:29:01 UTC
+--- configure.orig 2020-04-30 14:04:41 UTC
+++ configure
-@@ -4640,8 +4640,6 @@ case "${host_os}" in
+@@ -4667,8 +4667,6 @@ case "${host_os}" in
;;
- freebsd*)
+ dragonfly*|freebsd*)
ac_default_prefix=/usr/local
- CPPFLAGS=-I/usr/local/include
- LDFLAGS=-L/usr/local/lib
;;
openbsd*)
ac_default_prefix=/usr/local
-@@ -20421,6 +20419,8 @@ $as_echo_n "checking for getifaddrs() support... " >&6
+@@ -9207,25 +9205,25 @@ $as_echo "configuring" >&6; }
+
+ this_host=$(./config.sub $(./config.guess))
+ if test "$build" != "$this_host" ; then
+- PJPROJECT_CONFIGURE_OPTS+=" --build=$build_alias"
++ PJPROJECT_CONFIGURE_OPTS="${PJPROJECT_CONFIGURE_OPTS} --build=$build_alias"
+ fi
+ if test "$host" != "$this_host" ; then
+- PJPROJECT_CONFIGURE_OPTS+=" --host=$host_alias"
++ PJPROJECT_CONFIGURE_OPTS="${PJPROJECT_CONFIGURE_OPTS} --host=$host_alias"
+ fi
+ # This was a copy of the autoconf generated code from the root ./configure.
+ # Hopefully, when you read this, the code is still the same.
+ if test "${with_ssl+set}" = set; then :
+ case $with_ssl in
+ n|no)
+- PJPROJECT_CONFIGURE_OPTS+=" --disable-ssl"
++ PJPROJECT_CONFIGURE_OPTS="${PJPROJECT_CONFIGURE_OPTS} --disable-ssl"
+ ;;
+ y|ye|yes)
+ # Not to mention SSL is the default in PJProject and means "autodetect".
+ # In Asterisk, "./configure --with-ssl" means "must be present".
+- PJPROJECT_CONFIGURE_OPTS+=""
++ #PJPROJECT_CONFIGURE_OPTS+=""
+ ;;
+ *)
+- PJPROJECT_CONFIGURE_OPTS+=" --with-ssl=${with_ssl}"
++ PJPROJECT_CONFIGURE_OPTS+="${PJPROJECT_CONFIGURE_OPTS} --with-ssl=${with_ssl}"
+ ;;
+ esac
+ fi
+@@ -20566,6 +20564,8 @@ $as_echo_n "checking for getifaddrs() support... " >&6
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
@@ -18,7 +49,7 @@
#include <ifaddrs.h>
int
main ()
-@@ -28701,6 +28701,8 @@ fi
+@@ -29281,6 +29281,8 @@ fi
for ver in 5.3 5.2 5.1; do
@@ -27,7 +58,7 @@
if test "x${PBX_LUA}" != "x1" -a "${USE_LUA}" != "no"; then
pbxlibdir=""
# if --with-LUA=DIR has been specified, use it.
-@@ -28716,12 +28718,12 @@ if test "x${PBX_LUA}" != "x1" -a "${USE_LUA}" != "no";
+@@ -29296,12 +29298,12 @@ if test "x${PBX_LUA}" != "x1" -a "${USE_LUA}" != "no";
CFLAGS="${CFLAGS} "
as_ac_Lib=`$as_echo "ac_cv_lib_lua${ver}''_luaL_newstate" | $as_tr_sh`
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for luaL_newstate in -llua${ver}" >&5
@@ -42,7 +73,7 @@
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
-@@ -28763,7 +28765,7 @@ fi
+@@ -29343,7 +29345,7 @@ fi
# now check for the header.
if test "${AST_LUA_FOUND}" = "yes"; then
@@ -51,7 +82,7 @@
# if --with-LUA=DIR has been specified, use it.
if test "x${LUA_DIR}" != "x"; then
LUA_INCLUDE="-I${LUA_DIR}/include"
-@@ -28774,7 +28776,7 @@ fi
+@@ -29354,7 +29356,7 @@ fi
ast_ext_lib_check_saved_CPPFLAGS="${CPPFLAGS}"
CPPFLAGS="${CPPFLAGS} ${LUA_INCLUDE}"
as_ac_Header=`$as_echo "ac_cv_header_lua${ver}/lua.h" | $as_tr_sh`
@@ -60,7 +91,7 @@
if eval test \"x\$"$as_ac_Header"\" = x"yes"; then :
LUA_HEADER_FOUND=1
else
-@@ -28801,9 +28803,9 @@ fi
+@@ -29381,9 +29383,9 @@ fi
if test "x${PBX_LUA}" = "x1" ; then
if test x"${LUA_DIR}" = x; then
diff --git a/net/asterisk13/files/patch-third-party_pjproject_Makefile b/net/asterisk13/files/patch-third-party_pjproject_Makefile
index f74ae6c04693..c6c2da016933 100644
--- a/net/asterisk13/files/patch-third-party_pjproject_Makefile
+++ b/net/asterisk13/files/patch-third-party_pjproject_Makefile
@@ -1,6 +1,23 @@
---- third-party/pjproject/Makefile.orig 2020-03-12 14:37:03 UTC
+--- third-party/pjproject/Makefile.orig 2020-04-30 14:04:41 UTC
+++ third-party/pjproject/Makefile
-@@ -157,7 +157,7 @@ $(PJSIP_LIB_FILES): $(PJLIB_UTIL_LIB_FILES)
+@@ -90,14 +90,10 @@ _all: $(TARGETS)
+
+ .DELETE_ON_ERROR:
+
+-$(DOWNLOAD_DIR)/$(TARBALL_FILE): ../versions.mak
+- $(CMD_PREFIX) ($(TARBALL_EXISTS) && $(TARBALL_VERIFY) && touch $@) || (rm -rf $@ ;\
+- $(TARBALL_DOWNLOAD)) || (rm -rf $@ ;\
+- $(SHELL_ECHO_PREFIX) Retrying download ; $(TARBALL_DOWNLOAD))
++$(DOWNLOAD_DIR)/$(TARBALL_FILE):
++ @true
+
+ source/.unpacked: $(DOWNLOAD_DIR)/$(TARBALL_FILE)
+- $(CMD_PREFIX) $(TARBALL_VERIFY) || (rm -rf $@ ;\
+- $(SHELL_ECHO_PREFIX) Retrying download ; $(TARBALL_DOWNLOAD))
+ $(ECHO_PREFIX) Unpacking $<
+ -@rm -rf source pjproject-*/ >/dev/null 2>&1
+ $(CMD_PREFIX) $(TAR) -xjf $<
+@@ -157,7 +153,7 @@ $(PJSIP_LIB_FILES): $(PJLIB_UTIL_LIB_FILES)
pjproject.symbols: $(ALL_LIB_FILES)
$(ECHO_PREFIX) Generating symbols