summaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorJohn Hixson <jhixson@FreeBSD.org>2019-01-29 14:52:08 +0000
committerJohn Hixson <jhixson@FreeBSD.org>2019-01-29 14:52:08 +0000
commit27ab62adac903eb276678a3971ac6f08bcce3c0c (patch)
treeab0255e574fc8fa4024c02bb7170e38af24ecc63 /net
parent76e803f2cf1f2e879a55685549b7724a83bea83f (diff)
downloadfreebsd-ports-27ab62adac903eb276678a3971ac6f08bcce3c0c.zip
[New port] net/py-ifaddr: Python library to enumerate all network interfaces
Approved by: araujo (mentor), miwi (mentor) Differential Revision: https://reviews.freebsd.org/D19013
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/py-ifaddr/Makefile27
-rw-r--r--net/py-ifaddr/distinfo3
-rw-r--r--net/py-ifaddr/pkg-descr4
4 files changed, 35 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index dccf9e6635ca..5826eefbff0f 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1036,6 +1036,7 @@
SUBDIR += py-haproxy-log-analysis
SUBDIR += py-haproxyctl
SUBDIR += py-httpstat
+ SUBDIR += py-ifaddr
SUBDIR += py-impacket
SUBDIR += py-ipaddress
SUBDIR += py-iplib
diff --git a/net/py-ifaddr/Makefile b/net/py-ifaddr/Makefile
new file mode 100644
index 000000000000..71f4a2fba388
--- /dev/null
+++ b/net/py-ifaddr/Makefile
@@ -0,0 +1,27 @@
+# Created by: John Hixson<jhixson@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= ifaddr
+PORTVERSION= 0.1.6
+CATEGORIES= net python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= jhixson@FreeBSD.org
+COMMENT= Python Library to enumerate all network interfaces
+
+LICENSE= MIT
+
+USES= python:2.7+
+
+USE_PYTHON= autoplist distutils
+
+USE_GITHUB= yes
+GH_ACCOUNT= pydron
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_MAJOR_VER} < 3
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ipaddress>0:net/py-ipaddress
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/py-ifaddr/distinfo b/net/py-ifaddr/distinfo
new file mode 100644
index 000000000000..3dfb79f70bb9
--- /dev/null
+++ b/net/py-ifaddr/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1548734875
+SHA256 (pydron-ifaddr-0.1.6_GH0.tar.gz) = fb42188de577aa3acf14b06e9fcd770e755c7ced137db49191411956b75786ec
+SIZE (pydron-ifaddr-0.1.6_GH0.tar.gz) = 10157
diff --git a/net/py-ifaddr/pkg-descr b/net/py-ifaddr/pkg-descr
new file mode 100644
index 000000000000..4ec55223a4ed
--- /dev/null
+++ b/net/py-ifaddr/pkg-descr
@@ -0,0 +1,4 @@
+ifaddr is a small Python library that allows you to find all the IP
+addresses of the computer.
+
+WWW: https://github.com/pydron/ifaddr