summaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-08-31 04:02:14 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-08-31 04:02:17 +0000
commit0a22085145817b5cabaf71578a389795bf2239e3 (patch)
tree7ce5e1a7addd593afc3dd8de5eb5eb33c089807e /net
parent02c1848e3e32c0cb78eb0b11217216499cf81d32 (diff)
downloadfreebsd-ports-0a22085145817b5cabaf71578a389795bf2239e3.zip
Cleanup: for ports under n* categories, drop redundant GH_* knobs.
Diffstat (limited to 'net')
-rw-r--r--net/csync2/Makefile2
-rw-r--r--net/file2pcap/Makefile2
-rw-r--r--net/h323plus/Makefile8
-rw-r--r--net/knxd/Makefile12
-rw-r--r--net/nats-top/Makefile1
-rw-r--r--net/ptpd2/Makefile11
-rw-r--r--net/wakeonlan/Makefile1
-rw-r--r--net/xrdp-devel/Makefile1
-rw-r--r--net/xrdp/Makefile1
9 files changed, 12 insertions, 27 deletions
diff --git a/net/csync2/Makefile b/net/csync2/Makefile
index ac3ad7256063..0d62acff04d0 100644
--- a/net/csync2/Makefile
+++ b/net/csync2/Makefile
@@ -14,10 +14,8 @@ LIB_DEPENDS= libgnutls.so:security/gnutls \
libsqlite3.so:databases/sqlite3
USES= autoreconf pkgconfig shebangfix
-
USE_GITHUB= yes
GH_ACCOUNT= LINBIT
-GH_PROJECT= csync2
GH_TAGNAME= a8d38eb
USE_RC_SUBR= csync2
diff --git a/net/file2pcap/Makefile b/net/file2pcap/Makefile
index 048baee1d509..acf028f4068d 100644
--- a/net/file2pcap/Makefile
+++ b/net/file2pcap/Makefile
@@ -11,9 +11,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
USE_GITHUB= yes
-
GH_ACCOUNT= Cisco-Talos
-GH_PROJECT= file2pcap
ALL_TARGET= file2pcap
diff --git a/net/h323plus/Makefile b/net/h323plus/Makefile
index 5d47a4ded53f..17524f33f974 100644
--- a/net/h323plus/Makefile
+++ b/net/h323plus/Makefile
@@ -11,14 +11,12 @@ LICENSE_COMB= multi
LIB_DEPENDS= libpt.so:devel/ptlib
-USE_GITHUB= yes
-GH_ACCOUNT= willamowius
-GH_PROJECT= h323plus
-
USES= gmake ssl
+GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+USE_GITHUB= yes
+GH_ACCOUNT= willamowius
-GNU_CONFIGURE= yes
# ptlib-config --libs returns bogus dependencies on expat and SDL-1.2
CFLAGS+= -DH323_H46017 -DH323_TLS
LDFLAGS+= -Wl,--as-needed
diff --git a/net/knxd/Makefile b/net/knxd/Makefile
index 1f2b686a73ab..221e779b0ff5 100644
--- a/net/knxd/Makefile
+++ b/net/knxd/Makefile
@@ -16,18 +16,16 @@ LIB_DEPENDS= libargp.so:devel/argp-standalone \
libfmt.so:devel/libfmt
USES= autoreconf compiler:c11 gmake libtool pkgconfig
-USE_RC_SUBR= knxd
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-systemd --disable-usb \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-I${LOCALBASE}/include -L/${LOCALBASE}/lib"
USE_GITHUB= yes
USE_LDCONFIG= yes
+USE_RC_SUBR= knxd
INSTALL_TARGET= install-strip
-GH_ACCOUNT= knxd
-GH_PROJECT= knxd
GH_TAGNAME= 746a8d85dfdc4c456a9b832eca358a062a2b351d
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS?=--disable-systemd --disable-usb \
- CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-I${LOCALBASE}/include -L/${LOCALBASE}/lib"
post-patch:
# Replace script for version detection with PORTREVISION as the repository does not have a .git repo and therefor the script fails
diff --git a/net/nats-top/Makefile b/net/nats-top/Makefile
index b558fba66ae9..41ebb3ed49a0 100644
--- a/net/nats-top/Makefile
+++ b/net/nats-top/Makefile
@@ -12,7 +12,6 @@ LICENSE= MIT
USES= go:modules
USE_GITHUB= yes
GH_ACCOUNT= nats-io
-GH_PROJECT= nats-top
GH_TUPLE= davecgh:go-spew:v1.1.1:davecgh_go_spew/vendor/github.com/davecgh/go-spew \
gizak:termui:e62b5929642a:gizak_termui/vendor/gopkg.in/gizak/termui.v1 \
golang:crypto:0ec3e9974c59:golang_crypto/vendor/golang.org/x/crypto \
diff --git a/net/ptpd2/Makefile b/net/ptpd2/Makefile
index 0655c9d42d8b..729f1c50f0a9 100644
--- a/net/ptpd2/Makefile
+++ b/net/ptpd2/Makefile
@@ -10,21 +10,18 @@ COMMENT= Implementation of the precision time protocol IEEE 1588-2008
LICENSE= BSD2CLAUSE
-USE_GITHUB= yes
-GH_ACCOUNT= ptpd
-GH_TAGNAME= d27a6e0
-
CONFLICTS= ptpd2-devel.*
ETCDIR= ${PREFIX}/etc/${PORTNAME}${PKGNAMESUFFIX}
-GNU_CONFIGURE= yes
USES= autoreconf gmake libtool
+GNU_CONFIGURE= yes
+USE_GITHUB= yes
+GH_TAGNAME= d27a6e0
+USE_RC_SUBR= ptpd2
PORTDOCS= *
-USE_RC_SUBR= ptpd2
-
OPTIONS_DEFINE= DOCS SNMP
OPTIONS_DEFAULT=SNMP
diff --git a/net/wakeonlan/Makefile b/net/wakeonlan/Makefile
index 385aab44b0e8..9d104d9110ef 100644
--- a/net/wakeonlan/Makefile
+++ b/net/wakeonlan/Makefile
@@ -12,7 +12,6 @@ LICENSE= ART20
USE_GITHUB= yes
GH_ACCOUNT= jpoliv
-GH_PROJECT= wakeonlan
GH_TAGNAME= 4beb45d
USES= perl5
diff --git a/net/xrdp-devel/Makefile b/net/xrdp-devel/Makefile
index f1b46709fe08..41950734d887 100644
--- a/net/xrdp-devel/Makefile
+++ b/net/xrdp-devel/Makefile
@@ -29,7 +29,6 @@ USE_GITHUB= yes
GNU_CONFIGURE= yes
GH_ACCOUNT= neutrinolabs
-GH_PROJECT= xrdp
GH_TUPLE= neutrinolabs:librfxcodec:v0.1.5:librfxcodec/librfxcodec \
neutrinolabs:libpainter:v0.1.1:libpainter/libpainter
diff --git a/net/xrdp/Makefile b/net/xrdp/Makefile
index f919df4411fb..984793774484 100644
--- a/net/xrdp/Makefile
+++ b/net/xrdp/Makefile
@@ -28,7 +28,6 @@ USE_GITHUB= yes
GNU_CONFIGURE= yes
GH_ACCOUNT= neutrinolabs
-GH_PROJECT= xrdp
GH_TUPLE= neutrinolabs:librfxcodec:v0.1.5:librfxcodec/librfxcodec \
neutrinolabs:libpainter:v0.1.1:libpainter/libpainter