summaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2014-08-19 15:35:35 +0000
committerSteve Wills <swills@FreeBSD.org>2014-08-19 15:35:35 +0000
commitf64d9973793a9276d2552aa0e13dcb33bbfb61dc (patch)
tree09c2d656aaba0bcc376e74ce56d845f491a8ffa7 /net
parentc14a472bf60c9ab3d6accf2f58243c81cc3a4d3b (diff)
downloadfreebsd-ports-f64d9973793a9276d2552aa0e13dcb33bbfb61dc.zip
many ruby/rubygem ports: death of rubyforge.org
rubyforge.org shutdown on May 15, 2014. This commit accounts for that by doing several things: - Deprecate ruby that had only rubyforge.org as MASTER_SITES (and so are now only fetchable via our cache) - Deprecate ports that depend on those - Update the WWW pkg-descr line that points to rubyforge.org for rubygem ports (which are still fetchable from rubygems.org) The next step will be to remove rubyforge.org from bsd.sites.mk, after these deprecated ports are deleted. Phabric: D591 With hat: ruby Approved by: portmgr (because of committing to unstaged graphics/mingplot port)
Diffstat (limited to 'net')
-rw-r--r--net/ruby-growl/Makefile3
-rw-r--r--net/ruby-ldap/Makefile3
-rw-r--r--net/rubygem-aws-s3/pkg-descr2
-rw-r--r--net/rubygem-httpauth/pkg-descr2
-rw-r--r--net/rubygem-net-ldap/pkg-descr2
-rw-r--r--net/rubygem-net-netrc/pkg-descr2
-rw-r--r--net/rubygem-oauth/pkg-descr2
-rw-r--r--net/rubygem-openid/pkg-descr2
-rw-r--r--net/rubygem-rightaws/pkg-descr2
-rw-r--r--net/rubygem-rightflexiscale/pkg-descr2
-rw-r--r--net/rubygem-rightgogrid/pkg-descr2
-rw-r--r--net/rubygem-righthttpconnection/pkg-descr2
-rw-r--r--net/rubygem-rightslicehost/pkg-descr2
-rw-r--r--net/rubygem-twitter4r/pkg-descr2
14 files changed, 18 insertions, 12 deletions
diff --git a/net/ruby-growl/Makefile b/net/ruby-growl/Makefile
index a0c258a9d01b..c37cd3273959 100644
--- a/net/ruby-growl/Makefile
+++ b/net/ruby-growl/Makefile
@@ -24,6 +24,9 @@ PLIST_FILES= bin/growl \
PORTDOCS= History.txt README.txt
DOCSDIR= ${RUBY_MODDOCDIR}
+DEPRECATED= RubyForge shutdown May 15 2014
+EXPIRATION_DATE= 2014-09-20
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/bin/growl ${STAGEDIR}${PREFIX}/bin/
${MKDIR} ${STAGEDIR}${RUBY_SITELIBDIR}/
diff --git a/net/ruby-ldap/Makefile b/net/ruby-ldap/Makefile
index 5a9658df2d5f..d8e31690f7fc 100644
--- a/net/ruby-ldap/Makefile
+++ b/net/ruby-ldap/Makefile
@@ -28,6 +28,9 @@ USES= tar:bzip2
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
+DEPRECATED= RubyForge shutdown May 15 2014
+EXPIRATION_DATE= 2014-09-20
+
.include <bsd.port.pre.mk>
# Configure options:
diff --git a/net/rubygem-aws-s3/pkg-descr b/net/rubygem-aws-s3/pkg-descr
index e67de0d88662..5af18240b294 100644
--- a/net/rubygem-aws-s3/pkg-descr
+++ b/net/rubygem-aws-s3/pkg-descr
@@ -1,3 +1,3 @@
Client library for Amazon's Simple Storage Service's REST API
-WWW: http://amazon.rubyforge.org/
+WWW: http://rubygems.org/gems/aws-s3/
diff --git a/net/rubygem-httpauth/pkg-descr b/net/rubygem-httpauth/pkg-descr
index 7b8d4a22d02c..87112f24004d 100644
--- a/net/rubygem-httpauth/pkg-descr
+++ b/net/rubygem-httpauth/pkg-descr
@@ -1,5 +1,5 @@
HTTPauth is a library supporting the full HTTP Authentication protocol as
specified in RFC 2617; both Digest Authentication and Basic Authentication.
-WWW: http://httpauth.rubyforge.org/
+WWW: http://rubygems.org/gems/httpauth/
RG: https://rubygems.org/gems/httpauth
diff --git a/net/rubygem-net-ldap/pkg-descr b/net/rubygem-net-ldap/pkg-descr
index 17f40d2a350a..13d93011a0f6 100644
--- a/net/rubygem-net-ldap/pkg-descr
+++ b/net/rubygem-net-ldap/pkg-descr
@@ -4,4 +4,4 @@ LDAP client features and a subset of server features as well.
* Standards-based (going for RFC 4511)
* Portable: 100% Ruby
-WWW: http://net-ldap.rubyforge.org/
+WWW: http://rubygems.org/gems/net-ldap/
diff --git a/net/rubygem-net-netrc/pkg-descr b/net/rubygem-net-netrc/pkg-descr
index 68caf0c9df0a..93638254e7e9 100644
--- a/net/rubygem-net-netrc/pkg-descr
+++ b/net/rubygem-net-netrc/pkg-descr
@@ -1,4 +1,4 @@
Net::Netrc is a pure-Ruby module providing ftp(1)-style .netrc
parsing. It is inspired by Graham Barr's Perl Net::Netrc module.
-WWW: http://net-netrc.rubyforge.org
+WWW: http://rubygems.org/gems/net-netrc/
diff --git a/net/rubygem-oauth/pkg-descr b/net/rubygem-oauth/pkg-descr
index 3c587192a99d..67b864c5e0b0 100644
--- a/net/rubygem-oauth/pkg-descr
+++ b/net/rubygem-oauth/pkg-descr
@@ -1,4 +1,4 @@
Rubygem-oauth is a RubyGem for implementing both OAuth clients and
servers in Ruby applications.
-WWW: http://oauth.rubyforge.org/
+WWW: http://rubygems.org/gems/oauth/
diff --git a/net/rubygem-openid/pkg-descr b/net/rubygem-openid/pkg-descr
index 529c77133aa3..d587647df116 100644
--- a/net/rubygem-openid/pkg-descr
+++ b/net/rubygem-openid/pkg-descr
@@ -18,4 +18,4 @@ This library is a port of the Python OpenID library, and features:
for authentication
o ActiveRecord adapter for using an SQL store in rails
-WWW: http://openid.rubyforge.org/
+WWW: http://rubygems.org/gems/openid/
diff --git a/net/rubygem-rightaws/pkg-descr b/net/rubygem-rightaws/pkg-descr
index 10fa11a7d142..2c1e65648963 100644
--- a/net/rubygem-rightaws/pkg-descr
+++ b/net/rubygem-rightaws/pkg-descr
@@ -4,4 +4,4 @@ Amazon's REST and query interfaces to provide full programmatic
control. An optional robust HTTP layer retries and clears transient
errors.
-WWW: http://rightaws.rubyforge.org/
+WWW: http://rubygems.org/gems/rightaws/
diff --git a/net/rubygem-rightflexiscale/pkg-descr b/net/rubygem-rightflexiscale/pkg-descr
index 5b6699854adf..67e45a4753e6 100644
--- a/net/rubygem-rightflexiscale/pkg-descr
+++ b/net/rubygem-rightflexiscale/pkg-descr
@@ -1,4 +1,4 @@
The RightScale Flexiscale gem has been designed to provide a robust
interface to Flexiscale's existing API.
-WWW: http://rightaws.rubyforge.org/
+WWW: http://rubygems.org/gems/rightflexiscale/
diff --git a/net/rubygem-rightgogrid/pkg-descr b/net/rubygem-rightgogrid/pkg-descr
index 5f3730238af1..3aecba36cc81 100644
--- a/net/rubygem-rightgogrid/pkg-descr
+++ b/net/rubygem-rightgogrid/pkg-descr
@@ -1,4 +1,4 @@
The RightScale GoGrid gem has been designed to provide a robust
interface to GoGrid's existing API.
-WWW: http://rightaws.rubyforge.org/
+WWW: http://rubygems.org/gems/rightgogrid/
diff --git a/net/rubygem-righthttpconnection/pkg-descr b/net/rubygem-righthttpconnection/pkg-descr
index 10fa11a7d142..c2d562d40bf5 100644
--- a/net/rubygem-righthttpconnection/pkg-descr
+++ b/net/rubygem-righthttpconnection/pkg-descr
@@ -4,4 +4,4 @@ Amazon's REST and query interfaces to provide full programmatic
control. An optional robust HTTP layer retries and clears transient
errors.
-WWW: http://rightaws.rubyforge.org/
+WWW: http://rubygems.org/gems/righthttpconnection/
diff --git a/net/rubygem-rightslicehost/pkg-descr b/net/rubygem-rightslicehost/pkg-descr
index 810e7f28317d..3abe4c8bf0e7 100644
--- a/net/rubygem-rightslicehost/pkg-descr
+++ b/net/rubygem-rightslicehost/pkg-descr
@@ -1,4 +1,4 @@
The RightScale Slicehost gem has been designed to provide a robust
interface to Slicehost's existing API.
-WWW: http://rightaws.rubyforge.org/
+WWW: http://rubygems.org/gems/rightslicehost/
diff --git a/net/rubygem-twitter4r/pkg-descr b/net/rubygem-twitter4r/pkg-descr
index 232f04f62798..47f1465d861b 100644
--- a/net/rubygem-twitter4r/pkg-descr
+++ b/net/rubygem-twitter4r/pkg-descr
@@ -1,4 +1,4 @@
Twitter4R provides an object based API to query or update your Twitter
account via pure Ruby. It hides the ugly HTTP/REST code from your code.
-WWW: http://twitter4r.rubyforge.org
+WWW: http://rubygems.org/gems/twitter4r/