summaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorKarsten Schmidt <git@guggemand.dk>2023-02-26 19:38:37 +0100
committerKurt Jaeger <pi@FreeBSD.org>2023-02-26 19:38:37 +0100
commite2bb42ebb0765df9dd1b86d7eb145de993f6a418 (patch)
tree5d204e02cac2e1505a28f62a6b0789b4b31091f9 /net
parent4e5eaf3bc1f8880ffebcab0f8030460034ff9eab (diff)
downloadfreebsd-ports-e2bb42ebb0765df9dd1b86d7eb145de993f6a418.zip
net/openbgpd7: update 7.6 -> 7.7, and check_process fix
- Upgrade from 7.6 to 7.7 - Fix check_process, "bgpd: parent" no longer matches anything - Remove unused IPV6LLPEER option Pull-Request: https://github.com/freebsd/freebsd-ports/pull/141 Author: Karsten Schmidt <git@guggemand.dk>
Diffstat (limited to 'net')
-rw-r--r--net/openbgpd7/Makefile7
-rw-r--r--net/openbgpd7/distinfo6
-rw-r--r--net/openbgpd7/files/openbgpd.in2
3 files changed, 5 insertions, 10 deletions
diff --git a/net/openbgpd7/Makefile b/net/openbgpd7/Makefile
index b75c897143e8..dbd756ce35fc 100644
--- a/net/openbgpd7/Makefile
+++ b/net/openbgpd7/Makefile
@@ -1,5 +1,5 @@
PORTNAME= openbgpd
-PORTVERSION= 7.6
+PORTVERSION= 7.7
CATEGORIES= net
MASTER_SITES= OPENBSD/OpenBGPD
PKGNAMESUFFIX= 7
@@ -25,9 +25,4 @@ GROUPS= _bgpd
CONFLICTS= zebra quagga
-OPTIONS_DEFINE= IPV6LLPEER
-OPTIONS_DEFAULT= IPV6LLPEER
-IPV6LLPEER_DESC= Support nexthop using IPv6 link-local address
-IPV6LLPEER_MAKE_ARGS= -DIPV6_LINKLOCAL_PEER
-
.include <bsd.port.mk>
diff --git a/net/openbgpd7/distinfo b/net/openbgpd7/distinfo
index be67b265f748..cb224bf34b1e 100644
--- a/net/openbgpd7/distinfo
+++ b/net/openbgpd7/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1664555890
-SHA256 (openbgpd-7.6.tar.gz) = b91152106c6450aa56df7bc3a6ea6b283088ca83ee138cc8bbbb14ced60c1417
-SIZE (openbgpd-7.6.tar.gz) = 787038
+TIMESTAMP = 1670888338
+SHA256 (openbgpd-7.7.tar.gz) = cbdfcc6a1e5d71ad105a2398a7af28ad09d5bfed191963f169fa213a72863c62
+SIZE (openbgpd-7.7.tar.gz) = 787996
diff --git a/net/openbgpd7/files/openbgpd.in b/net/openbgpd7/files/openbgpd.in
index 9f17d0032365..ccf78428ebd0 100644
--- a/net/openbgpd7/files/openbgpd.in
+++ b/net/openbgpd7/files/openbgpd.in
@@ -25,7 +25,7 @@ required_files="%%PREFIX%%/etc/bgpd.conf"
check_process()
{
- /bin/pgrep -f 'bgpd: parent.*'
+ /bin/pgrep -j none -U 0 -f %%PREFIX%%/sbin/bgpd
}
load_rc_config $name