summaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2007-08-26 18:09:51 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2007-08-26 18:09:51 +0000
commitdf77b38ec1d6225f7b7efa6a5cc0fd48cac4770c (patch)
treea1864c0bfb7f8e363170882557ea7ec60121520e /net
parent2d8f8c98389f8d9577bcf22a2e88396491e3fdad (diff)
downloadfreebsd-ports-df77b38ec1d6225f7b7efa6a5cc0fd48cac4770c.zip
Refine OSVERSION logic to inform the user about the kmod counterparts.
Diffstat (limited to 'net')
-rw-r--r--net/ipw-firmware/Makefile5
-rw-r--r--net/iwi-firmware/Makefile3
2 files changed, 5 insertions, 3 deletions
diff --git a/net/ipw-firmware/Makefile b/net/ipw-firmware/Makefile
index 63b87c7490eb..6828ab7dccd4 100644
--- a/net/ipw-firmware/Makefile
+++ b/net/ipw-firmware/Makefile
@@ -8,7 +8,7 @@
PORTNAME?= ipw-firmware
RELNAME?= ipw2100
PORTVERSION?= 1.3
-PORTREVISION?= 8
+PORTREVISION?= 9
CATEGORIES= net sysutils kld
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= flz/ipw
@@ -29,6 +29,7 @@ FIRMWARES?= ${RELNAME}-${PORTVERSION}-i.fw:${DRIVERNAME}-i.fw \
# Dummy OSVERSION for ipw.
MIN7OSVERSION?= 999999
+MAX6OSVERSION?= 700000
# Try to guess sensible defaults.
.if ${OSVERSION} > ${MIN7OSVERSION}
@@ -75,7 +76,7 @@ IS_INTERACTIVE= yes
IGNORE= needs at least FreeBSD 5.3-RELEASE
.endif
-.if ( ${OSVERSION} >= 700014 )
+.if ( ${OSVERSION} >= 700014 || ( ${OSVERSION} < 700000 && ${OSVERSION} >= ${MAX6OSVERSION} ) )
IGNORE= is now obsolete, install net/${DRIVERNAME}-firmware-kmod instead
.endif
diff --git a/net/iwi-firmware/Makefile b/net/iwi-firmware/Makefile
index f8c1111aaf7f..5e019a38bb81 100644
--- a/net/iwi-firmware/Makefile
+++ b/net/iwi-firmware/Makefile
@@ -8,7 +8,7 @@
PORTNAME= iwi-firmware
RELNAME= ipw2200
PORTVERSION= 2.4
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= net sysutils kld
MAINTAINER= flz@FreeBSD.org
@@ -31,5 +31,6 @@ FIRMWARES= ipw-${PORTVERSION}-boot.fw:${DRIVERNAME}-boot.fw \
ipw-${PORTVERSION}-sniffer_ucode.fw:${DRIVERNAME}-ucode-sniffer.fw
MIN7OSVERSION= 700006
+MAX6OSVERSION= 602105
.include "${MASTERDIR}/Makefile"