summaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-03-24 22:15:59 +0000
committerWill Andrews <will@FreeBSD.org>2001-03-24 22:15:59 +0000
commitcd5ac27b080695645adeb97642ae92ac8987ddc3 (patch)
tree02f05001735d741a4930238201a081a66e0609f8 /net
parentfce35d76d86005c078b7e52929a04856f64425c7 (diff)
downloadfreebsd-ports-cd5ac27b080695645adeb97642ae92ac8987ddc3.zip
Bring in my fixes for KDE2 for users of XFree86 4.0.x. Basically, what
this involves is this: Cull GL from Qt by default, but still provide a Qt+GL library that may or may not have threads. Then also provide a Qt library that has threads but not GL. This allows us to make KDE2 depend on a library that will *not* have threads, ever. Threads will be revisited at a later date. Ports that require GL support need to be updated to use the hacked library, libqtgl.so.4. The net result is that we bloat our qt2 package by 1.5-2.5MB for compatability. Also, static qt will not have GL support. Introduce bsd.kde.mk, which will be tested on bento before becoming fully activated. Replace qt22-static with qt2-static, since it's just a proxy. Update qt-designer to depend on qt23. Also make the old hack to package the correct lib obsolete by using PLIST_SUB instead. Miscellaneous changes: remove LIBQTFILE from CONFIGURE_ENV, it's not used anymore. Solve namespace pollution problems with the devel/pth and devel/libgnugetopt ports. Hopefully. Suggested by: ade, asami, sobomax (bsd.kde.mk) Repocopied by: asami (qt22-static --> qt2-static)
Diffstat (limited to 'net')
-rw-r--r--net/kdenetwork2/Makefile5
-rw-r--r--net/kdenetwork3/Makefile5
-rw-r--r--net/kdenetwork4/Makefile5
3 files changed, 9 insertions, 6 deletions
diff --git a/net/kdenetwork2/Makefile b/net/kdenetwork2/Makefile
index 1847c939eb92..77dba4dc9b97 100644
--- a/net/kdenetwork2/Makefile
+++ b/net/kdenetwork2/Makefile
@@ -24,12 +24,13 @@ USE_AUTOCONF= yes
CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
--with-qt-libraries=${X11BASE}/lib \
--with-extra-libs=${LOCALBASE}/lib
-CONFIGURE_ENV+= LIBQT="-lqt2" MOC="${MOC}" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H -D_XOPEN_UNIX" \
+CONFIGURE_ENV+= LIBQT="-lqt2" MOC="${MOC}" \
+ CPPFLAGS="-I/usr/include -D_PTH_H_ -D_PTH_PTHREAD_H_ -D_GETOPT_H -D_XOPEN_UNIX -I${LOCALBASE}/include" \
LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lgcc -lstdc++"
USE_GMAKE= yes
pre-configure:
${PERL} -pi -e "s:-lpthread:-pthread:g" ${WRKSRC}/knode/Makefile.in
+ ${PERL} -pi -e "s@all_includes=\"@all_includes=\"-I/usr/include @g" ${WRKSRC}/acinclude.m4 ${WRKSRC}/aclocal.m4
.include <bsd.port.mk>
diff --git a/net/kdenetwork3/Makefile b/net/kdenetwork3/Makefile
index 1847c939eb92..77dba4dc9b97 100644
--- a/net/kdenetwork3/Makefile
+++ b/net/kdenetwork3/Makefile
@@ -24,12 +24,13 @@ USE_AUTOCONF= yes
CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
--with-qt-libraries=${X11BASE}/lib \
--with-extra-libs=${LOCALBASE}/lib
-CONFIGURE_ENV+= LIBQT="-lqt2" MOC="${MOC}" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H -D_XOPEN_UNIX" \
+CONFIGURE_ENV+= LIBQT="-lqt2" MOC="${MOC}" \
+ CPPFLAGS="-I/usr/include -D_PTH_H_ -D_PTH_PTHREAD_H_ -D_GETOPT_H -D_XOPEN_UNIX -I${LOCALBASE}/include" \
LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lgcc -lstdc++"
USE_GMAKE= yes
pre-configure:
${PERL} -pi -e "s:-lpthread:-pthread:g" ${WRKSRC}/knode/Makefile.in
+ ${PERL} -pi -e "s@all_includes=\"@all_includes=\"-I/usr/include @g" ${WRKSRC}/acinclude.m4 ${WRKSRC}/aclocal.m4
.include <bsd.port.mk>
diff --git a/net/kdenetwork4/Makefile b/net/kdenetwork4/Makefile
index 1847c939eb92..77dba4dc9b97 100644
--- a/net/kdenetwork4/Makefile
+++ b/net/kdenetwork4/Makefile
@@ -24,12 +24,13 @@ USE_AUTOCONF= yes
CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
--with-qt-libraries=${X11BASE}/lib \
--with-extra-libs=${LOCALBASE}/lib
-CONFIGURE_ENV+= LIBQT="-lqt2" MOC="${MOC}" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H -D_XOPEN_UNIX" \
+CONFIGURE_ENV+= LIBQT="-lqt2" MOC="${MOC}" \
+ CPPFLAGS="-I/usr/include -D_PTH_H_ -D_PTH_PTHREAD_H_ -D_GETOPT_H -D_XOPEN_UNIX -I${LOCALBASE}/include" \
LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lgcc -lstdc++"
USE_GMAKE= yes
pre-configure:
${PERL} -pi -e "s:-lpthread:-pthread:g" ${WRKSRC}/knode/Makefile.in
+ ${PERL} -pi -e "s@all_includes=\"@all_includes=\"-I/usr/include @g" ${WRKSRC}/acinclude.m4 ${WRKSRC}/aclocal.m4
.include <bsd.port.mk>