summaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2014-08-21 22:50:29 +0000
committerMatthias Andree <mandree@FreeBSD.org>2014-08-21 22:50:29 +0000
commitb50a4b0708948c5766fb92a70bfc082efa53857b (patch)
tree5f9e6219e9207f083ae5e2fff1302ed5967538ef /net
parent6724089b21de676c367bbc41cca5651958d1b0f3 (diff)
downloadfreebsd-ports-b50a4b0708948c5766fb92a70bfc082efa53857b.zip
Berkeley DB cleanup, remove versions 4.0 ... 4.7.
- Mk/bsd.database.mk rewrite, new default to db5. - db6 is eligible by default only if installed on the system. - Bump PORTREVISION of all ports that directly depend on BerkeleyDB or where USE_BDB is found in the port's directory - Patch a few ports such that they will pick up or work with newer versions. - Add UPDATING entry - Drive-by format fix for pks - Drop BerkeleyDB option from mail/popular for now, requires more work. - Exp-run logs linked from the PR below. - Ports that do not build (IGNORE, BROKEN, etc.) have pro-forma changes for new Berkeley DB, but are untested. NOTE: please read UPDATING and the Wiki page before proceeding! Announcement: http://lists.freebsd.org/pipermail/freebsd-ports-announce/2014-August/000090.html Wiki reference: https://wiki.freebsd.org/Ports/BerkeleyDBCleanup PR: 192690 Approved by: portmgr (implicit, PORTREVISION bump on unstaged ports)
Diffstat (limited to 'net')
-rw-r--r--net/freeswitch-core-devel/Makefile2
-rw-r--r--net/netatalk/Makefile2
-rw-r--r--net/netatalk3/Makefile2
-rw-r--r--net/openldap24-server/Makefile18
4 files changed, 5 insertions, 19 deletions
diff --git a/net/freeswitch-core-devel/Makefile b/net/freeswitch-core-devel/Makefile
index fb84047c9473..19a7c1ff414f 100644
--- a/net/freeswitch-core-devel/Makefile
+++ b/net/freeswitch-core-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= freeswitch
-PORTREVISION= 2
+PORTREVISION= 3
DISTVERSION= 1.2.3
CATEGORIES= net
MASTER_SITES= http://files.freeswitch.org/ \
diff --git a/net/netatalk/Makefile b/net/netatalk/Makefile
index 430c9a860cfa..baf85818dddd 100644
--- a/net/netatalk/Makefile
+++ b/net/netatalk/Makefile
@@ -3,7 +3,7 @@
PORTNAME= netatalk
PORTVERSION= 2.2.5
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= net print
MASTER_SITES= SF
diff --git a/net/netatalk3/Makefile b/net/netatalk3/Makefile
index 14b07939f93a..6adb61baa49b 100644
--- a/net/netatalk3/Makefile
+++ b/net/netatalk3/Makefile
@@ -3,7 +3,7 @@
PORTNAME= netatalk
PORTVERSION= 3.1.3
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= SF
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index 13499cabc4fa..b5214523c8d7 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openldap
DISTVERSION= 2.4.39
-PORTREVISION= ${OPENLDAP_PORTREVISION}
+1P1O1R1T1R1E1V1I1S1I1O1N1=1 1 1$1{1O1P1E1N1L1D1A1P1_1P1O1R1T1R1E1V1I1S1I1O1N1}1
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
ftp://gd.tuwien.ac.at/infosys/network/OpenLDAP/%SUBDIR%/ \
@@ -351,26 +351,12 @@ PLIST_SUB+= BACK_BDB="@comment " \
BACK_HDB="@comment "
.else
-WITH_BDB_VER?= 46
-USE_BDB= 44+
+USE_BDB= 48+
-# XXX Can BDB 5.x use XY instead of X as version?
-.if ${WITH_BDB_VER} >= 43 || ${WITH_BDB_VER} == 5 || ${WITH_BDB_VER} == 6
CONFIGURE_ARGS+= --enable-bdb=${BACKEND_ENABLE} \
--enable-hdb=${BACKEND_ENABLE}
PLIST_SUB+= BACK_BDB=${BACKEND_PLIST} \
BACK_HDB=${BACKEND_PLIST}
-.elif ${WITH_BDB_VER} >= 4
-CONFIGURE_ARGS+= --disable-bdb \
- --enable-hdb=${BACKEND_ENABLE}
-PLIST_SUB+= BACK_BDB="@comment " \
- BACK_HDB=${BACKEND_PLIST}
-.elif ${WITH_BDB_VER} == 3
-CONFIGURE_ARGS+= --disable-bdb \
- --disable-hdb
-PLIST_SUB+= BACK_BDB="@comment " \
- BACK_HDB="@comment "
-.endif
CPPFLAGS+= -I${BDB_INCLUDE_DIR}
LDFLAGS+= -L${BDB_LIB_DIR}