summaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorChris Hutchinson <portmaster@bsdforge.com>2024-02-07 09:09:17 +0100
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2024-02-08 17:52:41 +0100
commitab417bbaf11caff58297599ca2e5e6fec23fa533 (patch)
tree298ec70d52dcb458927785c0fa7b2d71f8b14832 /net
parent7171c7f8895a63f5863cb5577bee936b1fef86fe (diff)
downloadfreebsd-ports-ab417bbaf11caff58297599ca2e5e6fec23fa533.zip
net/delegate: fix source
Recent building on 15-CURRENT uncovered a problem with the source. PR: 276847 Reported by: portmaster@bsdforge.com (maintainer)
Diffstat (limited to 'net')
-rw-r--r--net/delegate/Makefile2
-rw-r--r--net/delegate/files/patch-src_spinach.c27
2 files changed, 28 insertions, 1 deletions
diff --git a/net/delegate/Makefile b/net/delegate/Makefile
index 6da498805f1b..52b2d3ce9261 100644
--- a/net/delegate/Makefile
+++ b/net/delegate/Makefile
@@ -1,6 +1,6 @@
PORTNAME= delegate
PORTVERSION= 9.9.13
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net www
MASTER_SITES= http://www.delegate.org/anonftp/DeleGate/
DISTNAME= ${PORTNAME}${PORTVERSION}
diff --git a/net/delegate/files/patch-src_spinach.c b/net/delegate/files/patch-src_spinach.c
new file mode 100644
index 000000000000..e4cb18450b72
--- /dev/null
+++ b/net/delegate/files/patch-src_spinach.c
@@ -0,0 +1,27 @@
+--- src/spinach.c.orig 2024-02-05 14:49:26.506828000 -0800
++++ src/spinach.c 2024-02-05 14:49:29.073850000 -0800
+@@ -1,6 +1,7 @@
+ const char *SIGN_spinach="{FILESIGN=spinach.c:20141022165616+0900:6d5712e8b172965e:Author@DeleGate.ORG:QAuaedIMjRwBwNOQV6i5Npwxzs5vGiO1LUZGAPvCx/z2/MaibLcm/aDgC8rvQcW099Jkdr9EknO0VzSUXBxHJ3eVBUQmhPQQydP4bqOafcJSwJaccO7R56eqsZ/8/qnDfJEhHyArArSsCPsxJtDo/36DRt1q461MBcYDDWLyasY=}";
+ /*////////////////////////////////////////////////////////////////////////
+-Copyright (c) 2009 National Institute of Advanced Industrial Science and Technology (AIST)
++Copyright (c) 2009 National Institute of Advanced Industrial Science and
++ Technology (AIST)
+ AIST-Product-ID: 2000-ETL-198715-01, H14PRO-049, H15PRO-165, H18PRO-443
+
+ Permission to use this material for noncommercial and/or evaluation
+@@ -57,8 +58,8 @@
+ int eccActivity = 0;
+
+ #ifndef SHUT_WR
+-#define SHUT_WR SD_SEND /* 0 or 1 ? */
+-#define SHUT_RDWR SD_BOTH /* 2 */
++#define SHUT_WR (0|1)/*SD_SEND*/ /* 0 or 1 ? */
++#define SHUT_RDWR (2)/*SD_BOTH*/ /* 2 */
+ #endif
+ int ShutdownSocketRDWR(int fd){
+ return shutdown(fd,SHUT_RDWR);
+@@ -5003,4 +5004,3 @@
+ }
+ return 0;
+ }
+-