summaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2015-08-14 15:03:30 +0000
committerRenato Botelho <garga@FreeBSD.org>2015-08-14 15:03:30 +0000
commit878b22662a431bdcf7e8e7673507e1decabb97f7 (patch)
tree4f7386ec2cdee5edb3c2ff4c8b93d33a016c2e13 /net
parentc8260db5f94ddee57ca1a8fb9cd02804fa967962 (diff)
downloadfreebsd-ports-878b22662a431bdcf7e8e7673507e1decabb97f7.zip
- Backport mpd5 fix (rev. 1224):
Do not print warning, when we a renaming interface to existing name https://forum.pfsense.org/index.php?topic=41061.msg476926 - Bump PORTREVISION PR: 200722 Approved by: maintainer timeout (> 2 months) Sponsored by: Netgate
Diffstat (limited to 'net')
-rw-r--r--net/mpd5/Makefile2
-rw-r--r--net/mpd5/files/patch-src_file.c17
2 files changed, 18 insertions, 1 deletions
diff --git a/net/mpd5/Makefile b/net/mpd5/Makefile
index 84d12c698020..8d0bccc3b822 100644
--- a/net/mpd5/Makefile
+++ b/net/mpd5/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mpd
DISTVERSION= 5.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= SF/${PORTNAME}/Mpd5/Mpd-${PORTVERSION}
PKGNAMESUFFIX= 5
diff --git a/net/mpd5/files/patch-src_file.c b/net/mpd5/files/patch-src_file.c
new file mode 100644
index 000000000000..7f83a1c47861
--- /dev/null
+++ b/net/mpd5/files/patch-src_file.c
@@ -0,0 +1,17 @@
+--- src/iface.c 2015/05/13 12:31:43 1.223
++++ src/iface.c 2015/06/02 08:57:13 1.224
+@@ -3654,9 +3654,11 @@
+ b->name, iface->ifname, ifname));
+
+ if (ioctl(s, SIOCSIFNAME, (caddr_t)&ifr) < 0) {
+- Perror("[%s] IFACE: ioctl(%s, SIOCSIFNAME)", b->name, iface->ifname);
+- close(s);
+- return(-1);
++ if (errno != EEXIST) {
++ Perror("[%s] IFACE: ioctl(%s, SIOCSIFNAME)", b->name, iface->ifname);
++ close(s);
++ return(-1);
++ }
+ }
+
+ close(s);