summaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2015-10-02 15:04:38 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2015-10-02 15:04:38 +0000
commit58aa91ee6e7d103eeb11254a1f5e3d5e10cbc038 (patch)
tree98ae1eb67577e378feae931dd87331d8eabcd097 /net
parenta85ac5a92cfad8f150a04ab542234669dea47194 (diff)
downloadfreebsd-ports-58aa91ee6e7d103eeb11254a1f5e3d5e10cbc038.zip
New port: net/p5-SOAP-XML-Client:
This package is the base class for talking with web services, there are specific modules to use depending on the type of service you are calling, e.g. SOAP::XML::Client::DotNet or SOAP::XML::Client::Generic WWW: http://search.cpan.org/dist/SOAP-XML-Client/
Diffstat (limited to 'net')
-rw-r--r--net/Makefile2
-rw-r--r--net/p5-SOAP-XML-Client/Makefile29
-rw-r--r--net/p5-SOAP-XML-Client/distinfo2
-rw-r--r--net/p5-SOAP-XML-Client/pkg-descr5
-rw-r--r--net/p5-SOAP-XML-Client/pkg-plist6
5 files changed, 44 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 075c2e833e5d..88051cb6a3fc 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -68,6 +68,7 @@
SUBDIR += chrony
SUBDIR += citrix_ica
SUBDIR += clamz
+ SUBDIR += cli53
SUBDIR += cloud-init
SUBDIR += clusterit
SUBDIR += cnd
@@ -757,6 +758,7 @@
SUBDIR += p5-SOAP-Data-Builder
SUBDIR += p5-SOAP-Lite
SUBDIR += p5-SOAP-MySOAP
+ SUBDIR += p5-SOAP-XML-Client
SUBDIR += p5-Samba-LDAP
SUBDIR += p5-Server-Starter
SUBDIR += p5-Socket
diff --git a/net/p5-SOAP-XML-Client/Makefile b/net/p5-SOAP-XML-Client/Makefile
new file mode 100644
index 000000000000..e8c62901e67d
--- /dev/null
+++ b/net/p5-SOAP-XML-Client/Makefile
@@ -0,0 +1,29 @@
+# Created by: Ryan Steinmetz <zi@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= SOAP-XML-Client
+PORTVERSION= 2.8
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Simple frame work for talking with web services
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Carp>0:${PORTSDIR}/devel/p5-Carp \
+ p5-Class-Accessor>0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Encode>0:${PORTSDIR}/converters/p5-Encode \
+ p5-File-Slurp>0:${PORTSDIR}/devel/p5-File-Slurp \
+ p5-SOAP-Data-Builder>0:${PORTSDIR}/net/p5-SOAP-Data-Builder \
+ p5-SOAP-Lite>0:${PORTSDIR}/net/p5-SOAP-Lite \
+ p5-Scalar-List-Utils>0:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ p5-XML-LibXML>0:${PORTSDIR}/textproc/p5-XML-LibXML
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/net/p5-SOAP-XML-Client/distinfo b/net/p5-SOAP-XML-Client/distinfo
new file mode 100644
index 000000000000..6b21230bf08b
--- /dev/null
+++ b/net/p5-SOAP-XML-Client/distinfo
@@ -0,0 +1,2 @@
+SHA256 (SOAP-XML-Client-2.8.tar.gz) = 8dcc2bf326c7d4660e169677bc715b24dba18f4014509d6f3309024cc7f91dd1
+SIZE (SOAP-XML-Client-2.8.tar.gz) = 18591
diff --git a/net/p5-SOAP-XML-Client/pkg-descr b/net/p5-SOAP-XML-Client/pkg-descr
new file mode 100644
index 000000000000..59a311f72e04
--- /dev/null
+++ b/net/p5-SOAP-XML-Client/pkg-descr
@@ -0,0 +1,5 @@
+This package is the base class for talking with web services, there are
+specific modules to use depending on the type of service you are calling,
+e.g. SOAP::XML::Client::DotNet or SOAP::XML::Client::Generic
+
+WWW: http://search.cpan.org/dist/SOAP-XML-Client/
diff --git a/net/p5-SOAP-XML-Client/pkg-plist b/net/p5-SOAP-XML-Client/pkg-plist
new file mode 100644
index 000000000000..d4d3a6e89ffa
--- /dev/null
+++ b/net/p5-SOAP-XML-Client/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/SOAP/XML/Client.pm
+%%SITE_PERL%%/SOAP/XML/Client/DotNet.pm
+%%SITE_PERL%%/SOAP/XML/Client/Generic.pm
+%%PERL5_MAN3%%/SOAP::XML::Client.3.gz
+%%PERL5_MAN3%%/SOAP::XML::Client::DotNet.3.gz
+%%PERL5_MAN3%%/SOAP::XML::Client::Generic.3.gz