summaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2015-08-30 16:38:47 +0000
committerSteve Wills <swills@FreeBSD.org>2015-08-30 16:38:47 +0000
commit1cdd854a437ad45d69c6beb86c1e25e51d77780b (patch)
treee4e95df493caa773c13c08946cd8feb57a4ceba2 /net
parent2b03fc9e96c22aae16211a6cbe699096e81170bf (diff)
downloadfreebsd-ports-1cdd854a437ad45d69c6beb86c1e25e51d77780b.zip
Fix build by using Go 1.4 until upstream supports Go 1.5
Diffstat (limited to 'net')
-rw-r--r--net/syncthing-discosrv/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/net/syncthing-discosrv/Makefile b/net/syncthing-discosrv/Makefile
index 0671b893592b..c33f7b502059 100644
--- a/net/syncthing-discosrv/Makefile
+++ b/net/syncthing-discosrv/Makefile
@@ -9,7 +9,7 @@ CATEGORIES= net
MAINTAINER= swills@FreeBSD.org
COMMENT= Discovery server for syncthing
-BUILD_DEPENDS= ${LOCALBASE}/bin/go:${PORTSDIR}/lang/go
+BUILD_DEPENDS= go14>=1.4:${PORTSDIR}/lang/go14
USE_GITHUB= yes
GH_ACCOUNT= syncthing golang:gc
@@ -34,7 +34,8 @@ post-patch:
${WRKSRC}/src/github.com/golang/groupcache
do-build:
- @cd ${WRKSRC} ; ${SETENV} GOPATH=${WRKSRC} go build
+ @cd ${WRKSRC} ; ${SETENV} PATH=${PATH}:${LOCALBASE}/go14/bin \
+ GOPATH=${WRKSRC} go build
@${MV} ${WRKSRC}/discosrv-${GH_TAGNAME} ${WRKSRC}/syncthing-discosrv
do-install: