summaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2015-05-06 20:10:09 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2015-05-06 20:10:09 +0000
commit0bff8d28e5b3ef36314d2842d63e4385db2d9452 (patch)
tree9243bab53c6476b810eeda1917b3a2c6b3c910e1 /net
parent96887754b7ed850d53a75b8b8136cee75163ed05 (diff)
downloadfreebsd-ports-0bff8d28e5b3ef36314d2842d63e4385db2d9452.zip
Add a slave port to net/pjsip to force installing pjsip with external
SRTP library. Make the www/asterisk13 depend on this slave port when both SRTP and PJSIP options in it are enabled, this allows enabling SRTP support in asterisk13 without the need to manually reconfigure other ports. Reported by: mat@ and a few others
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/asterisk13/Makefile11
-rw-r--r--net/pjsip-extsrtp/Makefile10
-rw-r--r--net/pjsip/Makefile4
4 files changed, 21 insertions, 5 deletions
diff --git a/net/Makefile b/net/Makefile
index b513c795b3d6..234a120f0ac3 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -869,6 +869,7 @@
SUBDIR += pimdd
SUBDIR += pipsecd
SUBDIR += pjsip
+ SUBDIR += pjsip-extsrtp
SUBDIR += pktanon
SUBDIR += pload
SUBDIR += plugdaemon
diff --git a/net/asterisk13/Makefile b/net/asterisk13/Makefile
index ba535c3713d0..cccfd7e3c0d3 100644
--- a/net/asterisk13/Makefile
+++ b/net/asterisk13/Makefile
@@ -2,7 +2,7 @@
PORTNAME= asterisk
PORTVERSION= 13.3.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -113,7 +113,6 @@ LUA_CFLAGS= -I${LUA_INCDIR}
LUA_LDFLAGS= -L${LUA_LIBDIR}
LDAP_CONFIGURE_WITH= ldap
LDAP_USE= OPENLDAP=yes
-PJSIP_LIB_DEPENDS= libpj.so:${PORTSDIR}/net/pjsip
PJSIP_CONFIGURE_WITH= pjproject
PJSIP_USES= pkgconfig
SPEEX_LIB_DEPENDS= libspeex.so:${PORTSDIR}/audio/speex
@@ -128,8 +127,12 @@ GROUPS= ${ASTERISK_GROUP} dahdi
.include <bsd.port.options.mk>
-.if ! ${PORT_OPTIONS:MPJSIP} && ${PORT_OPTIONS:MSRTP}
-LIB_DEPENDS+= libsrtp.so:${PORTSDIR}/net/libsrtp
+.if ${PORT_OPTIONS:MPJSIP} && ${PORT_OPTIONS:MSRTP}
+LIB_DEPENDS+= libpj.so:${PORTSDIR}/net/pjsip-extsrtp
+.elif ${PORT_OPTIONS:MPJSIP} && ! ${PORT_OPTIONS:MSRTP}
+LIB_DEPENDS+= libpj.so:${PORTSDIR}/net/pjsip
+.elif ! ${PORT_OPTIONS:MPJSIP} && ${PORT_OPTIONS:MSRTP}
+LIB_DEPENDS+= libsrtp.so:${PORTSDIR}/net/libsrtp
.endif
.include <bsd.port.pre.mk>
diff --git a/net/pjsip-extsrtp/Makefile b/net/pjsip-extsrtp/Makefile
new file mode 100644
index 000000000000..f6255b0df9de
--- /dev/null
+++ b/net/pjsip-extsrtp/Makefile
@@ -0,0 +1,10 @@
+# $FreeBSD$
+
+PKGNAMESUFFIX= -extsrtp
+
+CONFLICTS= pjsip-[0-9]*
+
+OPTIONS_SLAVE= EXTSRTP
+MASTERDIR= ${.CURDIR}/../pjsip
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/pjsip/Makefile b/net/pjsip/Makefile
index 8b965e0fead1..ac233ee7d833 100644
--- a/net/pjsip/Makefile
+++ b/net/pjsip/Makefile
@@ -2,7 +2,7 @@
PORTNAME= pjsip
PORTVERSION= 2.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= http://www.pjsip.org/release/${PORTVERSION}/
DISTNAME= pjproject-${DISTVERSION}
@@ -14,6 +14,8 @@ LICENSE= GPLv2
LIB_DEPENDS= libportaudio.so.2:${PORTSDIR}/audio/portaudio2
+CONFLICTS= pjsip-extsrtp-[0-9]*
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-external-pa \
--disable-silk