summaryrefslogtreecommitdiff
path: root/net/hostapd-devel
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2022-06-09 14:53:18 -0700
committerCy Schubert <cy@FreeBSD.org>2022-06-09 14:58:23 -0700
commitc86f32d652eb9dd023049122d8ca37cb13ed07b6 (patch)
tree7cc04e66197eee5eb9d1d58f3597dbc64d0fbaa2 /net/hostapd-devel
parentadcec87925971b825179437178ec402aa1ad3431 (diff)
downloadfreebsd-ports-c86f32d652eb9dd023049122d8ca37cb13ed07b6.zip
*/*: Restore non-IBSS part of wpa patches
b8477825c2dc42f6c595697a36f593c71f39fbad removed some non-IBSS patches. Restore them. We only want to remove the patches that make IBSS use ADHOC mode. Fixes: b8477825c2dc42f6c595697a36f593c71f39fbad
Diffstat (limited to 'net/hostapd-devel')
-rw-r--r--net/hostapd-devel/Makefile2
-rw-r--r--net/hostapd-devel/files/patch-src_drivers_driver__bsd.c23
2 files changed, 24 insertions, 1 deletions
diff --git a/net/hostapd-devel/Makefile b/net/hostapd-devel/Makefile
index c5d7efdc0c3a..e3e48c5dc457 100644
--- a/net/hostapd-devel/Makefile
+++ b/net/hostapd-devel/Makefile
@@ -2,7 +2,7 @@
PORTNAME= hostapd
PORTVERSION= ${COMMIT_DATE}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
PKGNAMESUFFIX= -devel
diff --git a/net/hostapd-devel/files/patch-src_drivers_driver__bsd.c b/net/hostapd-devel/files/patch-src_drivers_driver__bsd.c
new file mode 100644
index 000000000000..f56c30c30ad3
--- /dev/null
+++ b/net/hostapd-devel/files/patch-src_drivers_driver__bsd.c
@@ -0,0 +1,23 @@
+--- src/drivers/driver_bsd.c.orig 2021-06-02 14:11:18.000000000 -0700
++++ src/drivers/driver_bsd.c 2021-06-13 23:11:15.089256000 -0700
+@@ -853,14 +853,18 @@
+ drv = bsd_get_drvindex(global, ifm->ifm_index);
+ if (drv == NULL)
+ return;
+- if ((ifm->ifm_flags & IFF_UP) == 0 &&
+- (drv->flags & IFF_UP) != 0) {
++ if (((ifm->ifm_flags & IFF_UP) == 0 ||
++ (ifm->ifm_flags & IFF_RUNNING) == 0) &&
++ (drv->flags & IFF_UP) != 0 &&
++ (drv->flags & IFF_RUNNING) != 0) {
+ wpa_printf(MSG_DEBUG, "RTM_IFINFO: Interface '%s' DOWN",
+ drv->ifname);
+ wpa_supplicant_event(drv->ctx, EVENT_INTERFACE_DISABLED,
+ NULL);
+ } else if ((ifm->ifm_flags & IFF_UP) != 0 &&
+- (drv->flags & IFF_UP) == 0) {
++ (ifm->ifm_flags & IFF_RUNNING) != 0 &&
++ ((drv->flags & IFF_UP) == 0 ||
++ (drv->flags & IFF_RUNNING) == 0)) {
+ wpa_printf(MSG_DEBUG, "RTM_IFINFO: Interface '%s' UP",
+ drv->ifname);