summaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2019-03-05 10:06:37 +0000
committerLars Engels <lme@FreeBSD.org>2019-03-05 10:06:37 +0000
commita27778f04abf2996e39deacd939cfcd1b8ace1ca (patch)
tree26f59a6b99fd7a0ec9ae12ab080c0c36f1562b00 /net-mgmt
parent54465a7ac6164ab9d7aafe02714f632defc0ce25 (diff)
downloadfreebsd-ports-a27778f04abf2996e39deacd939cfcd1b8ace1ca.zip
Add new port: net-mgmt/icingaweb2-module-ipl
This module ships the new Icinga PHP library and is used by some Icinga Web 2 modules. WWW: https://github.com/Icinga/icingaweb2-module-ipl
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/icingaweb2-module-ipl/Makefile26
-rw-r--r--net-mgmt/icingaweb2-module-ipl/distinfo3
-rw-r--r--net-mgmt/icingaweb2-module-ipl/pkg-descr4
-rw-r--r--net-mgmt/icingaweb2-module-ipl/pkg-plist89
5 files changed, 123 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 5482f9dee222..286262d2b3e1 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -93,6 +93,7 @@
SUBDIR += icingaweb2-module-generictts
SUBDIR += icingaweb2-module-grafana
SUBDIR += icingaweb2-module-graphite
+ SUBDIR += icingaweb2-module-ipl
SUBDIR += icingaweb2-module-map
SUBDIR += icingaweb2-module-vsphere
SUBDIR += icmpmonitor
diff --git a/net-mgmt/icingaweb2-module-ipl/Makefile b/net-mgmt/icingaweb2-module-ipl/Makefile
new file mode 100644
index 000000000000..9866dac6f11f
--- /dev/null
+++ b/net-mgmt/icingaweb2-module-ipl/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= icingaweb2-module-ipl
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.1.1
+CATEGORIES= net-mgmt www
+
+MAINTAINER= lme@FreeBSD.org
+COMMENT= Icinga PHP library
+
+RUN_DEPENDS= icingaweb2>=2.4.1:net-mgmt/icingaweb2
+
+USE_GITHUB= yes
+GH_ACCOUNT= icinga
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+WWWDIR?= ${PREFIX}/www/icingaweb2/modules/${PORTNAME:C/^.*-//}
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${WWWDIR}
+ (cd ${WRKSRC} && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/icingaweb2-module-ipl/distinfo b/net-mgmt/icingaweb2-module-ipl/distinfo
new file mode 100644
index 000000000000..172dc554b9bf
--- /dev/null
+++ b/net-mgmt/icingaweb2-module-ipl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1551779858
+SHA256 (icinga-icingaweb2-module-ipl-v0.1.1_GH0.tar.gz) = 5a1fba393fce707111118bf59f2ca55eef917d4830b7d8c17e721dd16ee276d8
+SIZE (icinga-icingaweb2-module-ipl-v0.1.1_GH0.tar.gz) = 47520
diff --git a/net-mgmt/icingaweb2-module-ipl/pkg-descr b/net-mgmt/icingaweb2-module-ipl/pkg-descr
new file mode 100644
index 000000000000..73a5b7c16036
--- /dev/null
+++ b/net-mgmt/icingaweb2-module-ipl/pkg-descr
@@ -0,0 +1,4 @@
+This module ships the new Icinga PHP library and is used by some Icinga Web 2
+modules.
+
+WWW: https://github.com/Icinga/icingaweb2-module-ipl
diff --git a/net-mgmt/icingaweb2-module-ipl/pkg-plist b/net-mgmt/icingaweb2-module-ipl/pkg-plist
new file mode 100644
index 000000000000..39d0ead0e621
--- /dev/null
+++ b/net-mgmt/icingaweb2-module-ipl/pkg-plist
@@ -0,0 +1,89 @@
+%%WWWDIR%%/.gitignore
+%%WWWDIR%%/README.md
+%%WWWDIR%%/bin/make-release.sh
+%%WWWDIR%%/composer.json
+%%WWWDIR%%/module.info
+%%WWWDIR%%/run.php
+%%WWWDIR%%/vendor/autoload.php
+%%WWWDIR%%/vendor/composer/ClassLoader.php
+%%WWWDIR%%/vendor/composer/LICENSE
+%%WWWDIR%%/vendor/composer/autoload_classmap.php
+%%WWWDIR%%/vendor/composer/autoload_files.php
+%%WWWDIR%%/vendor/composer/autoload_namespaces.php
+%%WWWDIR%%/vendor/composer/autoload_psr4.php
+%%WWWDIR%%/vendor/composer/autoload_real.php
+%%WWWDIR%%/vendor/composer/autoload_static.php
+%%WWWDIR%%/vendor/evenement/evenement/LICENSE
+%%WWWDIR%%/vendor/evenement/evenement/src/Evenement/EventEmitter.php
+%%WWWDIR%%/vendor/evenement/evenement/src/Evenement/EventEmitterInterface.php
+%%WWWDIR%%/vendor/evenement/evenement/src/Evenement/EventEmitterTrait.php
+%%WWWDIR%%/vendor/ipl/html/LICENSE
+%%WWWDIR%%/vendor/ipl/html/src/Attribute.php
+%%WWWDIR%%/vendor/ipl/html/src/Attributes.php
+%%WWWDIR%%/vendor/ipl/html/src/BaseHtmlElement.php
+%%WWWDIR%%/vendor/ipl/html/src/DeferredText.php
+%%WWWDIR%%/vendor/ipl/html/src/Error.php
+%%WWWDIR%%/vendor/ipl/html/src/Form.php
+%%WWWDIR%%/vendor/ipl/html/src/FormDecorator/DdDtDecorator.php
+%%WWWDIR%%/vendor/ipl/html/src/FormDecorator/DecoratorInterface.php
+%%WWWDIR%%/vendor/ipl/html/src/FormElement/BaseFormElement.php
+%%WWWDIR%%/vendor/ipl/html/src/FormElement/CheckboxElement.php
+%%WWWDIR%%/vendor/ipl/html/src/FormElement/FormElementContainer.php
+%%WWWDIR%%/vendor/ipl/html/src/FormElement/HiddenElement.php
+%%WWWDIR%%/vendor/ipl/html/src/FormElement/InputElement.php
+%%WWWDIR%%/vendor/ipl/html/src/FormElement/SelectElement.php
+%%WWWDIR%%/vendor/ipl/html/src/FormElement/SelectOption.php
+%%WWWDIR%%/vendor/ipl/html/src/FormElement/SubFormElement.php
+%%WWWDIR%%/vendor/ipl/html/src/FormElement/SubmitElement.php
+%%WWWDIR%%/vendor/ipl/html/src/FormElement/TextElement.php
+%%WWWDIR%%/vendor/ipl/html/src/FormElement/TextareaElement.php
+%%WWWDIR%%/vendor/ipl/html/src/FormattedString.php
+%%WWWDIR%%/vendor/ipl/html/src/Html.php
+%%WWWDIR%%/vendor/ipl/html/src/HtmlDocument.php
+%%WWWDIR%%/vendor/ipl/html/src/HtmlElement.php
+%%WWWDIR%%/vendor/ipl/html/src/HtmlString.php
+%%WWWDIR%%/vendor/ipl/html/src/Table.php
+%%WWWDIR%%/vendor/ipl/html/src/Text.php
+%%WWWDIR%%/vendor/ipl/html/src/ValidHtml.php
+%%WWWDIR%%/vendor/ipl/sql/src/Adapter/AdapterInterface.php
+%%WWWDIR%%/vendor/ipl/sql/src/Adapter/BaseAdapter.php
+%%WWWDIR%%/vendor/ipl/sql/src/Adapter/Mssql.php
+%%WWWDIR%%/vendor/ipl/sql/src/Adapter/Mysql.php
+%%WWWDIR%%/vendor/ipl/sql/src/Adapter/Oracle.php
+%%WWWDIR%%/vendor/ipl/sql/src/Adapter/Pgsql.php
+%%WWWDIR%%/vendor/ipl/sql/src/Adapter/Sqlite.php
+%%WWWDIR%%/vendor/ipl/sql/src/CommonTableExpression.php
+%%WWWDIR%%/vendor/ipl/sql/src/CommonTableExpressionInterface.php
+%%WWWDIR%%/vendor/ipl/sql/src/Config.php
+%%WWWDIR%%/vendor/ipl/sql/src/Connection.php
+%%WWWDIR%%/vendor/ipl/sql/src/Contracts/QuoterInterface.php
+%%WWWDIR%%/vendor/ipl/sql/src/Delete.php
+%%WWWDIR%%/vendor/ipl/sql/src/Expression.php
+%%WWWDIR%%/vendor/ipl/sql/src/ExpressionInterface.php
+%%WWWDIR%%/vendor/ipl/sql/src/Insert.php
+%%WWWDIR%%/vendor/ipl/sql/src/LimitOffset.php
+%%WWWDIR%%/vendor/ipl/sql/src/LimitOffsetInterface.php
+%%WWWDIR%%/vendor/ipl/sql/src/OrderBy.php
+%%WWWDIR%%/vendor/ipl/sql/src/OrderByInterface.php
+%%WWWDIR%%/vendor/ipl/sql/src/QueryBuilder.php
+%%WWWDIR%%/vendor/ipl/sql/src/Select.php
+%%WWWDIR%%/vendor/ipl/sql/src/Sql.php
+%%WWWDIR%%/vendor/ipl/sql/src/Update.php
+%%WWWDIR%%/vendor/ipl/sql/src/Where.php
+%%WWWDIR%%/vendor/ipl/sql/src/WhereInterface.php
+%%WWWDIR%%/vendor/ipl/stdlib/LICENSE
+%%WWWDIR%%/vendor/ipl/stdlib/src/Contracts/ValidatorInterface.php
+%%WWWDIR%%/vendor/ipl/stdlib/src/Loader/AutoLoadingPluginLoader.php
+%%WWWDIR%%/vendor/ipl/stdlib/src/Loader/PluginLoader.php
+%%WWWDIR%%/vendor/ipl/stdlib/src/Loader/PluginLoaderInterface.php
+%%WWWDIR%%/vendor/ipl/stdlib/src/MessageContainer.php
+%%WWWDIR%%/vendor/ipl/stdlib/src/functions.php
+%%WWWDIR%%/vendor/ipl/stdlib/src/functions_include.php
+%%WWWDIR%%/vendor/psr/http-message/LICENSE
+%%WWWDIR%%/vendor/psr/http-message/src/MessageInterface.php
+%%WWWDIR%%/vendor/psr/http-message/src/RequestInterface.php
+%%WWWDIR%%/vendor/psr/http-message/src/ResponseInterface.php
+%%WWWDIR%%/vendor/psr/http-message/src/ServerRequestInterface.php
+%%WWWDIR%%/vendor/psr/http-message/src/StreamInterface.php
+%%WWWDIR%%/vendor/psr/http-message/src/UploadedFileInterface.php
+%%WWWDIR%%/vendor/psr/http-message/src/UriInterface.php